Jump to content
Followers 0
HolyHobo

OpenCore Shutdown/Restart Broken - "will be calling reboot(2) with flags: 0x8."

1 post in this topic

Recommended Posts

So, I successfully converted from clover to opencore on my msi gp63 leopard laptop, but ever since then I haven't been able to properly power off or restart. Sleep doesn't work either but I'm not as worried about that. When I'm in verbose, shutdown and restart hangs at "will be calling reboot(2) with flags: 0x8." and it won't turn off until I hold down the power button. I hope someone has come across this issue. I've successfully did the usb mapping for my machine, I've tried the fix shutdown patch at Dortanias guide. Fix usb causing shutdown issues guide (Maybe I did something wrong here, it was kind of confusing). I feel like I've tried everything. I could really use some help/advice. I attached my opencore folder in my EFI if you want to look through it, maybe I did something wrong, I did look at the open core sanity checker and everything came back positive. I also attached a picture of the screen it hangs on. 

Thank you in advance for any advice, I've been having this issue for about a month and have done all the troubleshooting I could think of. 


edit: just for clarification, the way I converted was doing a complete clean setup of OC, the only thing I used from clover was SSDT patches for disabling my gpu.

Spoiler

IMG_0522.jpg

 

OC.zip

Edited by HolyHobo
Share this post

×