Jump to content
dustojnikhummer

BCM4352 WiFi not working, Thinkpad X230

10 posts in this topic

Recommended Posts

Lenovo Thinkpad X230

Unlocked advanced BIOS (WIFI Whitelist removed)

Catalina 10.15.7

i5 3320m

Azurewave CE-123H / BCM4352 / BCM94352HMB (Aliexpress link to what I bought)

 

I'm trying to get my Azurwave card working, but can't do it. Bluetooth does work, but the AirportBrcmFixup doesn't seem to do anything. Card properly detected in Hackintool. I even tried using the IO80211 kext from Mojave, which did nothing, though a user on OSXLatitude forums said his card worked again after Catalina 10.15.5

Screenshot 2020-09-25 at 17.36.54.png

Screenshot 2020-09-25 at 17.32.31.png

Screenshot 2020-09-25 at 17.32.12.png

Screenshot 2020-09-25 at 17.31.14.png

Edited by dustojnikhummer
Share this post

Damn. The reason why I use this card is that I bought it well over a year ago for a project that never happened, and because most forums said it is easy to get going. I will take look at that thread, thanks for now.

 

Or should I just downgrade to Mojave?

Edited by dustojnikhummer
Share this post

Hey, thanks for your help, but I'm declaring this WiFi card as dead. Even under Windows, it sees networks but refuses to connect (doesn't even ask for a password). I guess I will have to buy a new one, but apparently BCM94352 is supported even under BigSur, so I'm thinking about buying that one. Or what card under 25USD (tax purposes) would you recommend? And in the meantime, lets hope itlwm is stable

Share this post

×