Jump to content

Strix Z390-i no back audio after BIOS upgrade


1 post in this topic

Recommended Posts

Hi,

 

Sorry for cross-posting this here (I also posted in Reddit - one day ago /tonymac - two days). I can remove the post if this is not welcomed.

 

After upgrading Asus Strix z390-i Gaming BIOS to latest (released on 2020/07/23), there is only one front-jack audio and digital out. Previously there was front-jack, digital out and 2 line outs. Also, headphone output is very weird, e.g. doing 'bursts' when going from silent to having some sound.


CPU: i7 9700k

GPU: Sapphire Pulse RX 5700 XT
RAM: Ballistix Sport LT 32GB Kit (16GBx2) DDR4 2400 MT/s (PC4-19200)
Motherboard/Laptop model: ASUS ROG Strix Z390-I Gaming
Audio Codec: S1220A
Ethernet Card: Intel® I219V
Wifi/BT Card: BCM94360NG (I replaced the one that came with the MB)

 

 

What guide/tool I followed:
https://khronokernel.github.io/Opencore-Vanilla-Desktop-Guide/ I also based my setup with this https://github.com/eramdam/hackintosh/blob/master/README.md

 

Context:

It was working flawlessly, including wifi, bluetooth, standoff, sleep etc. I then got a new wd black nvme and migrated my install to it. It also worked, but the nvme random writes was slower than the Sata in the benchmarks, so I upgraded the BIOS to latest, which indeed made the ssd report faster writes.

I upgraded both Lilu and AppleALC(because upgrading only AppleALC did not work), but that didn't solve the issue.

I also tried all supported alcid ids 1, 2, 3, 5, 7, 11, 20, 21.

 

This is my OpenCore config https://pastebin.com/Bt5Y2yYB

I know I could likely downgrade the BIOS version, but I am hoping to not need it, since it improved the SSD performance.

 

Edited by khronnuz
improve formatting.
×
×
  • Create New...