Jump to content

Help needed with my dream machine Ryzen 3970X


3 posts in this topic

Recommended Posts

Hi

 

I'm 70 percent ready with my AMD hack

Hardware:

MoBo: Asrock Taichi TRX40

CPU: AMD Ryzen Threadripper 3970X

GPU: Gigabyte Aourus RX580

Mem: 32Gb GSkill 3000MHz

Power: EVGA Supernova 750 G2

OS: 10.15.6 Catalina

profile: iMacPro1,1

With OpenCore 0.6.1

 

Strange thing: I have a big multicore difference between win10 and Catalina with GB4, maybe OS X is written a bit better... I don't know

win: https://browser.geekbench.com/v4/cpu/15754100

osx: https://browser.geekbench.com/v4/cpu/15765221

 

Things: I cannot turn off CSM support on the mob, in this case my video card won't run, only turns on, when OSX or windows starts up, so I cannot see anything before that, like BIOS or UEFi setup.

And for above 4G decoding CSM must be off on this mono, but I cant .... But tried with my Nvidia CSM off above 4G on, but had the same results.

 

During the installation I always stucked, froze in the 2 minutes remaining screen. So I have installed Catalina on a real Mac to an external HDD, booted from it,  and then carbon copied it into my NVme drive.

 

Many things are working now:

iMessage

sleep

cpu handling, monitoring, power management

built in bluetooth

i211 ethernet port

2.5Gbs port.... with the Lucy kext I can see it, but there is no data flow

NvMe

usb

 

Mainly followed this thread:

https://dortania.github.io/OpenCore-Install-Guide/AMD/zen.html#nvram

 

What do not works:

Restart or Shut Down

Firewire card not seen by system

 

RESTART/Shutdown

After any of these commands, the dock disappears, and computer freezes with the background screen, no reaction

Tried to make a virtual nvram by this:

https://dortania.github.io/OpenCore-Post-Install/misc/nvram.html#cleaning-out-the-clover-gunk

But as I write tis line, got this error message

root@192 ~ # sudo nvram -c

nvram: Error clearing firmware variables: (iokit/common) not permitted

For me it seems that the SIP is turned on, but the car-active-config 77000000 flag is used. With this flag I have this:

 

@192 ~ % csrutil status

System Integrity Protection status: disabled (Apple Internal).

 

With disable SIP FF070000 I have only partial disables.

 

Seems okay, with the other flags, I always have partial disables.

For me seems, that the system cannot write to the nvram, but iMessages works perfectly

 

Tried to make a FixShutdown-USB-SSDT, but I cannot find any _PWR in my DSDT, so don't know what to change

 

 

Firewire pci card:

This would me mandatory for me to work, have to use it for my Universal Audio interface

On windows it is working fine, and it was natively working in my previous hack builds (with Asus prime z370A, or Gigabyte Z390 Designare with an I7 8086K)

Tried to fix IRQ with SSDTTime, copied aml and merged the plist patches

The UAD software writes: Driver not installed correctly. For them it means, that at the first start I have to allow this program at Security and Privacy at the first start, but there was no option for that. Tried to reinstall several times, but no success.

Again seems like SIP and Nvram problem connection.

In the previous hack builds by default I had my Firewire card in the System profiler/Firewire, showed my 800/400FW ports.

Also tried to force load FW kexts in OC, no success.

Tried both npci=0x2000 and 3000, the same. Without I stuck in PCI CONFIGURATION BEGINS

 

If my IOreg is needed: (too big to attach here)

https://www.dropbox.com/s/v67lzkq9spraryn/fojerhar iMac Pro.ioreg?dl=0

 

Help me to be a happy person with this Monster working :)

 

Thank you

Viktor

 

fojerhar config.plist

pcidevices.txt

×
×
  • Create New...