Jump to content

only 3mb of vram on macos catalina (qemu-system-x86)


1 post in this topic

Recommended Posts

hi, i'm new here, and today i installed a virtual machine with macos catalina on my computer, using qemu-system-x86.
here's the host configuration:
ram: 16gib ddr4
hd: sata 1tb
motherboard: asrock a320m-hd
processor: amd a6-9500 radeon r5, 8 compute cores, 2c + 6g
operating system: debian gnu/linux 11 bullseye/sid
guest configuration:
ram: 12gib (there is also a bug where macos says that the memory is ddr3 at 0mhz speed)
processor: intel core 2 duo (I wanted to switch to the broadwell generation, but unfortunately the penryn generation was the only one that worked)
processor cores: 2
gpu: virtio-gpu (with virgl)
ssd: 256gib (there is also another bug where macos only detects the ssd, but does not detect the connection (like sata, nvme, ide))
computer recognized by macos catalina: imac 27-inch (late 2009)
I tried several tutorials on the internet, but none of them worked, not even the fake id worked. so the system ends up having only 3mb of vram, but I can adjust the resolution to different levels:
1280x720
1600x900
1920x1080
2048x1154
2560x1440
and unfortunately, my monitor resolution (1440x900) is not listed.
one thing i realized is that depending on the resolution i set, the video memory changes its value; for example:
at 1280x720 resolution there is only 3mb of vram
and when I switch to 2560x1440 resolution, there’s 14mb of vram
doing calculations, I ended up realizing that this happens depending on how much memory is needed; for example:
1280x720 resolution:
1280 pixels wide, multiplied by 720 pixels high, multiplied by 3 bytes (24 bits) of color depth, results in 2 764 800 bytes, which is equivalent to 2,764 megabytes of vram, so the system rounds this value up to 3 megabytes, and the same calculation with different resolutions. but the problem is that I want the system to have at least 128 mib of vram so that the system animations are smoother. although, i can play videos on youtube, but the highest resolution the system can handle without crashing is 720p.
I think it will be more difficult to solve this compared to other people, because other people installed macos on a real machine, not a virtual machine. my suspicion is the generic qemu video driver, and i don't know if there are video drivers for qemu, i researched a lot and still found nothing.

here's the configuration file, if something is wrong:

launch

Edited by RetroGamerCX
×
×
  • Create New...