Jump to content

Problem injecting my Intel HD4600 Mobile mobile graphics in Opencore Big Sur

2 posts in this topic

Recommended Posts


I've only been with Opencore for 4 weeks and I think I've already made progress; but I have a problem with my HD4600 mobile Graphics card

After several years with Clover, I cannot understand or fix some of the issues that opencore has raised for me that I have already discussed here. This is what is happening with my mobile Intel Graphics HD 4600 (0x04168086) and platform 0x0A260006; Fake device ID = 12040000:

Whereas in Clover, with Catalina and Apples above, I have QE / CI, without any problem, before with FakePCII and now with WhateverGreen. In opencore 0.6.1, and without making any changes, this is not possible in UEFI mode, it gives me glitches - 8 apples - and does not open the desktop; however, in CSM mode if you are doing QE / CI; but it is very uncomfortable for me to be in CSM and I don't want to use it as other devices do not work in that Bios medium.
What solution can this have?
I am using Lilu 1.4.8; VirtuaSMC 1.1.7 and WhaterverGreen 1.4.3 compiled by me with Xcode and Opencore 0.6.1

Finally, with Big Sur- only its installation possible, until now, with Opencore - which in Bios-CSM mode, does not update from Public Beta to Beta 6, which I do in UEFI mode without QE / CI.
These glitchs, which were so common in the old apple versions with HD4600, were easily fixed with a few patches. I have not succeeded with Big Sur. I need help, if anyone knows about this strange case


Regards. wellcome




Edited by wellcome
eliminar foto

At last, I have solved the problem of glichs and 8 apples in my BS. I understood, a little late, that in the same way that in Clover with Intel HD400 mobile we have to lower the maximum resolution at the beginning; Well, it turns out that in opencore you have to do it too: from 1980x1200 to 1280x1024 and I already have QE / CI in UEFI mode and Bluetooth: With this, I have solved all my problems with BS opencore. It only remains for me to finish with: "Sleep EFI failure" that sometimes restarts my PC.

Thanks for your no help.


  • Create New...