Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
acsapos

X99 Boot stuck at “PCI configuration begin” - Catalina 10.15.6

3 posts in this topic

Recommended Posts

Hello dear insanelymac family!

I have a problem with my clover Catalina 10.15.6 installation.

When i boot up, start the installer, after that it got stuck at PCI CONFIGURATION BEGIN.

I did read some topics, i tried some bootargs, npci=2000 & 3000 , PCIRootUID=1.. but no one got me trough.

I just noticed something, when i boot with npci 3000, pci configuration start 2 times. I dont know why, i uploaded a photo to this topic.

What can i do now? USBownership is turned ON in clover.

 

My kexts: APPLEACPIPLATFORM , AppleALC , APPLEUSBXHCI , FAKESMC , INTELMAUSI , IOPCIFAMILY , LILU , USBINJECTALL , VOODOOTSCSYNC , WHATEVERGREEN , XHCI-UNSUPPORTED

 

CPU: Xeon 2620-v3

GPU: XFX RX 580 XXX Edition 8GB

RAM: 2 x 8GB DDR4 2400Mhz

Motherboard: Killsre X99-D4 (bought from aliexpress)

 

I can send you my efi in message.

E8EB41C2-DC53-4CD2-8C8C-ABA6139FC650.thumb.jpeg.2f873bbc2bfa1f01468909c7cbfe2349.jpeg

(when i boot up with npci 3000)

 

C1B16AD0-B65D-4ADF-9714-C1957B97996B.thumb.jpeg.18956202ef01f2fe183d7d541e01d6a5.jpeg

(my normal bootargs)

 

Share this post


Link to post
Share on other sites

Not sure this is going to help you but I’m stuck exactly at the same point.

 

i believe the issue comes from the line which says Waiting on IOProviderClass etc.

 

I’ve been trying to find more about this but at the moment I’m still stuck. I have a X99 ASUS Deluxe. Good luck!

Share this post


Link to post
Share on other sites

@acsapos Finally i managed to install my two hack on 2 different drives (catalina and big sur) on X99.

Overall i fixed the PCI configuration begin through patches to my SSDT files with the great help of @MaLd0n

So I would recommend looking in that direction. I can see that you are booting with Clover so worth having a look at your DSDT file.

Good luck!

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By rvilbert
      Hi all,
       
      I have been trying to install Big sur on Opencore and i believe i'm almost there but i get stuck on a grey screen with my mouse pointer just before i can see the installer screen.
      I have applied the various SSDT patches for X99. I thought that was linked to VirtualSMC which I replaced by FakeSMC but same issue. I also declared my graphic card in config.plist as i thought it could come from there but that's not the issue (Radeon RX 570).
      I have been scratching my head for some time now. Any idea from anyone please.
       
      I have attached my EFI folder and my ioreg extract. Let me know if you need anything else.
       
      Thanks a million.
       
      My config:
      Asus X99 Deluxe
      Core-i7 5960x
      Radeon RX 570
       
      @RemB
      @jmacie
      I would appreciate your help please. Any views of what could be wrong? Thanks a lot
       
      OpenCore 0.6.2 for X99 BIG SUR.zip
      X99 iMac Pro.ioreg.zip
    • By rvilbert
      Good evening,
       
      I apologies for the broadcast message but i have decided to reinstall my Hackintosh machine using Catalina 10.15.6 and .... I'm stuck at "PCI configuration begin".. 
       
      My configuration is:
      Asus X99 Deluxe Core i7 5960x 32 Gb memory GTX 980  
      Knowing that my graphic card would not be fully recognised in Catalina i have also tried to install High Sierra but I managed to get exactly to the same point  and i have therefore decided to give another try to Catalina and .... I'm still stuck.
       
      (FYI I had managed to install 10.8 on my machine a while ago but a few things have changed since then and I may be missing a trick).
       
      In a nutshell I believe my issue is linked to this message that i'm getting:
       
      Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourcesMatch</key><string ID="2">boot-uuid-media</string></dict> 
       
      I tried all options (with/without flags and with/without kext) but i think that my issue is between my DSDT, SSDT and config.plist files.
       
      Any help would be much appreciated!
       
      I have attached my EFI folder and the print screen with the error message.
       
      Let me know if you need any further information.
       
      Thanks a lot
       
       
       
       

      EFI.zip
    • By acsapos
      Hello dear insanelymac family!
      My plan for this week, to build a hackintosh. I'm trying, reading a lot of forums, posts, but i cant go forward. I tried OpenCore, Clover, and [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] too. I have an Opencore right now, because this loader went longer than the others, and its easy to configure in my opinion. So, the problem is.. When i boot up to my installer USB, it will always stop somewhere after about 10 seconds. Always changing positions, like in the middle of a text, etc. You can see the screen on the image what i uploaded. I tried a lot of things, but somehow, nothing is happening. CPU: Xeon 2620-v3 GPU: XFX RX 580 XXX Edition 8GB RAM: 2 x 8GB DDR4 2400Mhz Motherboard: Killsre X99-D4 (bought from aliexpress) Guide followed: I followed the Dortaina's Opencore guide / HASWELL-E What part I got an issue with: Booting up to my Installer USB What files/config I am using: My entire EFI uploaded to this post Extra Info: I cant get to open the installer overall, the longest what i reached what you see on the imgur link. I have an opencore file with some LOG(uploaded) Thanks in advance, for any help. I would really appreciate that. David acsapos-EFI.rar


      opencore-2020-08-11-020217.txt
    • By Flavio1989
      Hello everyone.

      I hope you’re all having a good day.

      I’m trying to do a clean install on MacOS Catalina 10.15.5. But I’ve not been able to even boot into the USB installer.

      My System Specs are:
      _ASUS X99 Deluxe II
      _intel i7 6950X Broadwell-E
      _AMD RX 5700 XT Anniversary edition
      _128GB of DDR4 RAM @ 2400MHz
      _ASUS Thunderbolt Card
      _Bootloader Clover r5119 (latest version)
      _The drive I’m trying to install to is a NMVE Samsung 950 Pro

      I’ve been trying for a couple of days as I was having some issues relating to the Memory Fix (AptioMemoryFix). But I solved those by changing the FakeCPU in my config.plst. I actually don’t know if it was that that fixed it since it’s together with a million other things I tried including trying to change boot loader to OpenCore. For now I prefer Clover.

      Now the boot process is going quite a bit further but I’m having some Kernel Panics and reboots at the point shown in the picture. I tried googling the issue before bothering this forum and several things but no luck yet.

      To troubleshoot the issue I’m currently doing the following steps:
      _I disconnected all not essential drives, I only have the target drive plugged in
      _I removed all the PCI-e Cards other than the GPU.
      _I Used all the suggested BIOS setting (no OC or other extra)
      _Left only 2 modules of RAM out of 8 in the correct slots (per MOBO manufacturer Manual)
      _ALL external peripherals are disconnected. Just my monitor, keyboard and mouse
      _the monitor is connected to the GPU via HDMI
      _Plug the USB Installer into a USB2 port, and even creating another installer on a spare drive and connecting internally via SATA

      I have a MacBook Pro where I can modify the EFI folder and do the necessary changes.

      I must point out that the Hack was working amazingly for the past 3+ years with a GTX 980 Ti (last working OS High Sierra). Since I was having issue in booting into the installer from the start I ditched the old EFI folder and build a new one

      I’m attaching the photo of my Kernel Boot and my EFI Folder.

      If anyone can help me I’ll be very grateful. I bet it’s an extremely stupid fix I overlooked due to being tired.

      Thanks in advance

      EFI_10_15_5_X99D2_i76950X_FB_23062020.zip
    • By denixx95
      Hello,
      Big Problem.., My Hack can not recognize my USB3 and no Bluetooth ....
      I'm on High Sierra 10.13.6  (max with my NVIDIA GeForce GTX 970 CG 4070 MB)
      My Setup
      - Rampage V + 5820K config  
      - 32G Ram
      - GeForce GTX 970
      - full of HD ssd
      I am attaching my config.plist! and print my ktext screen ( I have to clean my room...)
       
      Thank you for your help !!
      config.plist.zip

×