Jump to content
About Just Joined group Read more... ×
Gunzar

[OpenCore][Vanilla] Displays are very blurry - AMD Ryzen/Radeon build [Help]

1 post in this topic

Recommended Posts

Hello there!

 

TL:DR; I built a Hackintosh system using the OpenCore Vanilla Desktop Guide (running Catalina 10.15.4) and I use an AMD Ryzen 1600 CPU and Radeon RX 5700 XT GPU. All works well except my displays are very blurry and it feels like I’ll get a headache if I try to look at the screen for very long. The picture quality is noticeably worse than Windows or Linux. What can I do to fix it?

 

--

 

Let me start off by saying that this is my first hackintosh build. I based my build on the Opencore Vanilla Desktop Guide at https://khronokernel-2.gitbook.io/opencore-vanilla-desktop-guide/. I’m running macOS Catalina 10.15.4.

 

So I finished installing macOS after slowly and carefully taking about 8-10 hours to go through the guide yesterday and make sure I did everything properly. It paid off - it has been solid as a rock. However, there is one problem that is currently bugging me to no end - my displays are very blurry. This seems to be independent of any application or display resolution. My dock icons are blurry, the system text is blurry, app text is blurry (like in Slack, Safari, Notes, etc). This does not occur in Linux or Windows when using the same screens. 

 

Also, as a test, I hooked up my girlfriend’s MacBook Pro to the same two screens, and the monitors are crystal clear again, just like they usually are in Windows. This leads me to think that my EFI may be configured improperly or my system may be missing some software or a kext that enables the displays to show a sharp image. I attached my EFI folder and my config.plist file for reference. 

 

EFI setup:

  • ACPI:
    • SSDT-EC-USBX-AMD.aml
  • Drivers:
    • ApfsDriverLoader.efi
    • OpenRuntime.efi
    • VBoxHfs.efi
  • Kexts:
    • AppleALC.kext
    • AppleMCEReporterDisabler.kext
    • Lilu.kext
    • RealtekRTL8111.kext
    • VirtualSMC.kext
    • WhateverGreen.kext (version 1.3.8)
  • My boot args are: "npci=0x2000 agdpmod=pikera keepsyms=1 debug=0x100 alcid=1"

 

System specs:

  • Ryzen 5 1600, no overclock or anything special
  • Corsair Vengeance Pro RGB RAM, 32GB total (2x16GB DDR4 dimms running at 2400MHz)
  • XFX Radeon RX 5700 XT RAW II 8GB GPU (this is listed as a PCIe 4.0 GPU, could that cause issues since my motherboard is PCIe 3.0 only? Works great in Windows/Linux)
  • ASUS Prime B350M-A motherboard
  • Samsung PM961 256GB NVMe SSD

 

My monitors:

  • Samsung U32J59x (32” @ 3840x2160)
  • ASUS MX279 (27” @ 1920x1080)
  • The blurry issue also occurs when I plug directly into my 58" Samsung 4K TV.

 

I’ve already tried these steps:

  • Adjusting monitor “sharpness” settings, totally unbearable at “0” but still looks pretty bad even at “100”
  • Trying a bunch of different resolutions in the “Display” preferences. On the 4k monitor, the only one that looks any better is the 1920x1080p option, but then I have far too little screen space left.
  • Using SwitchResX, no different than using different resolutions in the regular Display preferences
  • Using subpixel antialiasing in the terminal with no noticeable difference, even through reboots
  • Turning on/off AMD FreeSync on my 4K monitor — if I turn on FreeSync, the display lags and stutters, and quality is not any better. Also tried turning on/off “game mode” but that had no difference.
  • Tried switching DisplayPort version between 1.1 and 1.2 in monitor settings (on 4K monitor)
  • Checking my BIOS settings, such as making sure CSM is off, against the OpenCore guide that I used to make sure everything was correct

 

Does anyone else have some other ideas that could help to correct this issue? Any ideas would be greatly appreciated. Thanks in advance!!

-Gunzar

EFI.zip

config.plist

Share this post


Link to post
Share on other sites
Advertisement

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By kokozaurs
      Hi all,
       
      I'm using ESXI 7.0b (did use 6.7 to try but with no difference).
       
      Right now on Catalina but I can't seem to try to get GPU (RX580) working properly.
       
      I pass it through to the VM(tried with windows before with no problems) and it appeared just as pci-device with no name.
       
      After that, I've applied whatevergreen + lilu kexts and it does properly recognize it under system report however that's all there is. It's listed at GFX0. See attached images.
       
      No hardware acceleration. Monitor also not turning on using either DP/HDMI. 
       
      Since it is being passed through to the VM, it seems that the problem is not on ESXi side but on macOS side. 
       
      Has anyone has been able to pass through an AMD GPU to ESXI VM? Can anyone suggest some pointers as to where I could find some solutions to this problem?
       
      Thanks! 
       
       



    • By b2550
      Currently my install is 100% working except that so far I have only been able to get one of my 1080p monitors working with a MiniDP to HDMI cable. I currently am getting a second MiniDP to HDMI cable but for now I am stuck with a DVI to HDMI cable.

      The monitor that is working is plugged in via the MiniDP to HDMI. The monitor that isn't working is using the DVI cable. However I also tried switching it to HDMI to HDMI which had the same result. The monitor wakes up but it's black. However for whatever reason, both monitors are still recognized in system preferences and hackintool.

      I know all my cables are good and work because I updated from an install of El Capitan (which I still have on it's original SSD just in case this install fails) as well as a Windows install. Both monitors worked fine on El Capitan for literally years. El Capitan is just too old now and I need to update to keep up with software updates.

      Problem reporting files should provide needed info about how I've configured this install. Build is in my signature.
      debug_22725.zip
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By asheenlevrai
      Hi
       
      I recently built my 1st ryzentosh.
      I also used Opencore (0.6.1) for the 1st time and followed the install guides on Dortania.
       
      Now I need to map my USB ports and apparently it's not achieved the same way on AMD platforms compared to what I was "used to" on Intel platforms.
       
      The guide on Dortania is a bit confusing to me since there is information that is not clearly labelled as "for Intel" or "for AMD" and I thus don't understand very well what I should and shouldn't do.
       
      Can anyone give me advice or point towards as comprehensive tutorial intended for AMD-based builds.
       
      Thank you very much in advance for your help.
       
      Best,
      -a-
    • By Johnnycale
      Hi everybody. I'm stuck here and after a few days I'm really not able to boot.
      My setup is the following:
       
      CPU AMD Ryzen 9 3900x
      GPU Aorus RX 5700 XT
      MOTHERBOARD AsRock x570m Pro4
      SSD 1 Corsair MP600 1TB
      SSD 2 Gigabyte Aorus NVMe 1TB
      RAM Crucial Ballistix 2x32GB
      WIFI BCM94360CD

      Error message from Bios attached to this thread.

      Thanks to anyone willing to help me. I've tried different open core versions, adding and removing a lot of kexts, keeping essentials ACPIs, setting as true or false different .plist settings that I saw resolving similar issues as mine but nothing seems to work.
      opencore-2020-09-07-214007.txt
×