Jump to content
Sign in to follow this  
Followers 0
saadi93

XPS 13 9350 | Weird Mojave Installer Issue | Help!!!

2 posts in this topic

Recommended Posts

Hi Hackintosh Community! Please advise...

 

1. My specs:
Dell XPS 13 9350 | i5 6200U | Intel HD 520 Graphics | 3200x1800 Display | 8GB RAM | 256GB Samsung SSD | Dell Bios 1.12.2


2. My Story:
I've been trying to install OSX Mojave 10.14.6 on this machine and am stuck in a weird spot.


I was following this guide: https://github.com/tlefko/macOS-Mojave-XPS13-9350 (which focuses on the same specs system as mine so it should have been smooth sailing :p)


Created Clover USB using CreateInstallMedia command. It booted just fine the first time to the installer, with everything working fine (mouse, keyboard) apart from Wifi which was expected. The UI was scaling well too meaning the graphics were working.


I formatted my drive and the installation began but about 5 mins in, the screen turned black/grey and stayed there. So, I rebooted thinking to start over but now for some reason the installer does not even start. It would neither continue from the SSD using the USB nor through the USB partition itself for the installation to start afresh.  It always reboots saying Attempting System Restart... and then reboots.


Tried multiple guides for Mojave for this XPS but it always does the same reboot.


Thought it was an issue with Mojave, so I made a High Sierra USB and switched to this guide and Clover folder: https://github.com/tlefko/OSX-XPS13-9350
But same reboot loop issue. Some pictures of the verbose error output (for High Sierra) are attached at the bottom.


I've tried changing USBs from 3.0 to 2.0, tried multiple guides and Clover folders, but still the same result. This leads me to believe the issue lies somewhere else. I have set the BIOS as advised in the guides btw.


Can you guys debug what the issue can be? It booted fine the first time. What gives? If you need anymore info, I will be happy to provide. The Clover folder is the same as in the github account linked above.

 

20200229_113312.jpg

Share this post


Link to post
Share on other sites
Advertisement

I figured out the issue. The kernel panic was related to the stock DW 1820A wifi card inside. It appeared above the reboot phrase in verbose as BRCM.NIC in backtrace. I disabled the chip in bios and it booted fine.

Hope this helps someone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×