Jump to content
Mull7965

Disable NVIDIA GPU using Clover config

1 post in this topic

Recommended Posts

In order to run Mojave and Catalina I added an AMD GPU (Radeon RX560) to my Hackintosh. I don't want to remove the much more powerful NVIDIA GPU that was in there already because I also use the machine for gaming under Windows. So far, so good, I'm not the only on in this situation.

 

Things mostly work but the Hackintosh can't sleep anymore. (It worked well under High Sierra with the NVIDIA web drivers installed.) Of course, this could be another issue with Mojave, but searching this forum makes me believe that the reason why the Hack doesn't sleep anymore is that macOS still sees the NVIDIA GPU and doesn't know how to make it sleep.

 

Now, I've seen a number of reports that seem to fix this with custom DSDT's. I have also found an article that describes multiple options to disable an unwanted GPU (https://khronokernel-4.gitbook.io/disable-unsupported-gpus/). I have tried option 2 and 4 from this article, but in both cases macOS still shows the NVIDIA GPU in a somehwat generic way (see attached), and sleep doesn't work.

 

Before I continue, can someone who has successfully "disabled" a GPU tell me what the list in System Information should look like? When you disable the GPU, with a DSTD or config.plst, should the GPU not show up the Graphics/Displays section? Or is that normal and I have another issue?

Screenshot 2020-02-09 at 14.56.53.png

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×