Jump to content
Sign in to follow this  
Followers 0
3dimensions

NVMe and IONVMeFamily

2 posts in this topic

Recommended Posts

IMG_20200207_224758.thumb.jpg.858c11a9dce223e445591e49c9dcbb77.jpg

 

AppleNVMe Assert failed: ( 0 != data ) Release IDNode file: /BuildRoot/Library/Caches/com.apple.xbs/Sources/IONVMeFamily/IONVMeFamily-470.40.4/IONVMeController.cpp line 5416

 

Most of NVMe problems with IONVMeFamily were fixed in macOS 10.13 High Sierra so people rarely have this kind of problems so I have not been able to get information on how to fix this problems on newer macOS versions, macOS Catalina in my case.

 

So if anyone has any idea on how to bypass or fix this problem, let me know.

My disk specs: (INTEL SSDPEKNW512G8H) 512GB SSD PCIe NVMe M.2

 

If you need more information, tell me what you need and how to get it with Windows or Ubuntu.

 

If there is no solution or it is very hard to fix just tell me and I will try to install macOS Catalina on another PC with HDD because things look very grim. :wallbash:

 

I am using Clover UEFI Bootloader.

Uploading EFI folder if you want to take a peek.

EFI.zip

 

Computer: HP 15-da1083ns

Some basic computer specs

Test.png.bfcf5ac99a1f2c5a3f71f937b44ea24f.png

Edited by 3dimensions

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By RoroMush
      Hi Guys,
       
      I was finally able to get my Catalina installer to boot using by changing EC0 to EC 4543305f 45435f5f. Huge headache with this as it took me a good couple of days to fix the error. 
       
      The good news is I can make it to the installer but now the problem is now the Catalina installer gets stuck at 2 minutes with the error code showing disk25s1 is not convertible to APFS.
       
      My Troubleshooting Steps:
       
      - Tried another NVMe drive, with same results
      - Checked Samsung Magician for updates, no luck
      - Formatted the drives in Ubuntu, same exact installer error.
       
      For some reason the disks always show as "Writable: NO" 
       
      Hardware:
      - Asus Z390-E 
      - Intel i7 9700K
      - Samsung 970 Pro
      - 16GB Crucial 
      - Intel UHD Graphics
       
      Is there something wrong with my kexts or config? 
       
      Thank You!
       
       
       
      EFI.zip

    • By Humboldt421
      I would like to use an intel H10 optane SSD module to create a fusion drive container for an osx install. 
      I have an MSI b360i pro AC mobo with intel i5-8400 amd rx580 8gb and 2x 8gb ddr4 2666 
      Its all in a Dan case with the HdPlex 400w Pure DC PSU 
      Its running windows on a Toshiba KXG5A 512 SSD which is fast but i wanted to install osx and I wanted to use a new drive for that, I chose the H10 intel optane drive because from what I gather if I dont use any optane software or bios settings it will appear as two drives to the UEFI firmware, one 32gb Optane drive and the 512 SSD, I wanted to know if I could use this as a fusion drive container. Has anyone done this? Also I need to figure out the DSDT or clover setup to use to make this mobo boot with the hardware I have. I havent built a osx86 box since ML but I think that i can figure it out with some help. Thanks.
    • By peanutman314
      As you might know the Samsung 970 EVO Plus variant causes major issues on hackintosh installs. I want to keep it plugged into my motherboard for use in Windows. However, if it's plugged in, macOS is going to try to index this disk eventually and it will crash macOS even though it's not the main install disk. 

      Because I don't need this disk under macOS I thought it would be a good solution to somehow disable/hide the unsupported disk for macOS. I looked into doing this via Clover but couldn't find anything useful. I'm hoping I can disable the slot via a DSDT patch. I only want to disable one specific M.2 slot, the others should remain functional (I have another working M.2 disk). So disabling the driver is not an option.

      I have very little experience with DSDTs and I have no idea how to do this. I recently created a USB injection patch using RehabMan's excellent guide, so I have some experience with the process, but no idea how to formulate the DSDT patch. 

      I have a Gigabyte Aurus Pro z390 motherboard. Below is a screenshot of IORegistryExplorer showing the other working drive (not the one I want to disable, that one is not plugged in yet). 
       

      I would be very grateful if anyone can point me in the right direction. If anyone knowns of a non-DSDT solution to disable a specific slot (but not all slots) then that's also fine of course.

      Thank you for your time
    • By NoEnd
      Hi everyone, I have ordered an NVME drive to upgrade my hackintosh drive. My question is how to upgrade my system with this drive? should I clone the drive then plug and play or there are other measurements I need to consider? Also which Application you recommend for the clone? I'm using APFS.
       
      Thanks 
    • By viktr
      Hi!
       
      Please help - cannot install mojave on the gb z370n wifi, 8700, 2x samsung 970 nvme, rx570
      Downloaded latest clover and kexts and installation hangs at the beginning.
      Got some errors at boot (during clover boot, before menu appears) then boot "Mojave install" and then it stuck. Please help. Tried to turn off all fixes, tried old apfs.efi instead of apfsdriverloader - all with no success. Maybe it's a known issue and I'm just doing something completely wrong?
       
      ty
       
       


      clover.tar.gz

×