Jump to content

unmounting hard drives?


12 posts in this topic

Recommended Posts

in osx ive got 3 hard drives that show up, the osx partition the windows partition and a dell utilty partition.

the dell utility partition is useless to me and i dont want it to be visible from osx.

ive tried unmounting it from disk utility but it comes back every time i reboot. can anyone help?


also how do i rename drives for osx (but not for windows).



Link to comment
Share on other sites

Rename drives - click on the icon of the drive and hit Enter. Type a new name. Hit Enter. Same for any OSX file/folder. Or click on the icon, Get Info on it and change name there.


Unmount drives - In Disk Utility, click on the Dell partition. At the bottom of the window, find the Mount Point. It should be /Volumes/(some-partition-name).


Make a text file called: rc.local (Make sure it is called rc.local and not rc.local.txt - Use Get Info on it to verify)


In the text file, put the line(s): diskutil unmount "/Volumes/(some-partition-name)"

If the name has spaces, be sure to use the quotes.


In Finder, Go menu -> Go to Folder -> type: /etc -> click Go


Drag the rc.local file to the etc folder. It will ask you to Authenticate. Click the button and give your password.


Run Disk Utility and repair permissions on your OSX partition



Link to comment
Share on other sites

The file has to be called rc.local.


Go to Terminal and type:

cd /etc
ls rc*

Is the file named rc.local or rc.local.txt?


If the partition that you want to unmount is called "No {censored}" then the command inside of rc.local should read: diskutil unmount "/Volumes/No {censored}"

You get this from Disk Utility at the bottom: "Mount Point"


Be sure you repaired permissions using Disk Utility.

Link to comment
Share on other sites

this was just the same as unmounting from diskutility - the drive came back after reboot.

Yes, yes. That was just a test to verify that the command in the rc.local file was working on your system. Now it is time to diagnose why rc.local isn't doing its thing.


Fire up terminal and type the following and copy/paste the results here.


ls -al /etc/rc* ; cat /etc/rc.local

Link to comment
Share on other sites

ok, here are the results


-rw-r--r-- 1 root wheel 7754 Feb 19 2006 /etc/rc

-rw-r--r-- 1 root wheel 1633 Dec 25 2005 /etc/rc.common

-rw-r--r-- 1 randyfur randyfur 377 Nov 26 21:54 /etc/rc.local

-rw-r--r-- 1 root wheel 4413 Dec 25 2005 /etc/rc.netboot

-rw-r--r-- 1 root wheel 183 Dec 25 2005 /etc/rc.shutdown


{\fonttbl\f0\fswiss\fcharset77 Helvetica;}





\f0\fs24 \cf0 diskutil unmount "/Volumes/DellUtility"}randy-furlongs-computer:~ randyfurlong$

Link to comment
Share on other sites

OK, I see 2 problems - file format and permissions.


The biggest problem is that when you made the file in TextEdit, you created it as an RTF file. This file contains information for fancy formatting of the text. You needed to create a text file. See all that {censored} listed in the file before your "diskutil unmount" command? That is formatting data.


In TextEdit, open a blank document, go to Format menu -> Make Plain Text. Then type your command in the document. When you save the file, give it the name rc.local and be sure to UNcheck the box near the bottom about the .txt extension.


Drag the document to the /etc directory. Then go to Terminal and type the following:

sudo chown root:wheel /etc/rc.local
sudo chmod 644 /etc/rc.local

Then reboot.

Link to comment
Share on other sites


  • Create New...