Jump to content
Piterakos

Can't boot when using SSDT

7 posts in this topic

Recommended Posts

Hi fellas, i've encountered a problem i have never seen before on my build.

My pc specs are: i7 3770 (nont K), Gigabyte GA-Z77M-D3H R1.1 on F15a bios (latest), 16gb ram, Sapphire rx570 pulse 4gb, ssd.

I disabled onboard gpu and installed Catalina 10.15.2 vanilla way on my pc, all ok.

Rx570 works oob with lilu+weg

Audio works with appleALC + audio inject 5.

No DSDT needed

 

The problem is that even with generate p states in clover i only get  pstates (min + max non-turbo)

I have used Piker Alpha's ssdtPRGen script to generate my own ssdt for cpu pm which worked fine. So i installed the generated ssdt in acpi/patched, dropped oem ssdt in clover and unticked generate p + c states.

Upon reboot it hangs after DSMOS has arrived with no apparent error (to my eyes).

I also tried generating my own DSDT, fixed the errors and i still get the same result.

it drives me nuts!!!

Can anyone have a look at my config?

20200112_184003.jpg

ssdt.aml

config.plist

Share this post


Link to post
Share on other sites
Advertisement

Update. I followed your links, replaced my folder, extracted my own DSDT from clover, repaired the only error i got (didn't apply any patch yet) and this time it boots but when i generate ssdt it hangs at the same error i posted above

Share this post


Link to post
Share on other sites

ok after further searching i believe that i may have ACPI errors and that is why when i use ssdt it freezes.

@MaLd0n  could you please take a look at my DSDT and see if u can make anything of it?

I have attached the original without any fixes

Z77M-D3H.aml

Share this post


Link to post
Share on other sites
45 minutes ago, Piterakos said:

ok after further searching i believe that i may have ACPI errors and that is why when i use ssdt it freezes.

@MaLd0n  could you please take a look at my DSDT and see if u can make anything of it?

I have attached the original without any fixes

Z77M-D3H.aml

DSDT.aml.zip

Share this post


Link to post
Share on other sites

ok i have managed to solve my problem.

I was using SMBIOS macmini6.2 (for aesthetic reasons mostly). I switched to Imac13.2 and BOOM!!! Booted right up with my generated ssdt and drop oem ticked. P-states all working along with turbo boost.

 

So i leave this here for future reference

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×