Jump to content
norcimo

AppleIGB.kext. for Intel I350 onboard LAN Catalina issue

8 posts in this topic

Recommended Posts

Greetings

 

I have a SuperMicro X9DRI MB running Catalina, Vega 56, SSD.   However I can't seem to get my onboard lan to work.

 

it crashes during the clover boot.  AppleIGB.kext,  reason I use it it because it has  PCI ID for my card, I did get it to boot once...it was unstable. lastest version was 10.10.

 

from info.plist

 

<key>i350</key>
        <dict>
            <key>CFBundleIdentifier</key>
            <string>com.insanelymac.driver.AppleIGB</string>
            <key>IOClass</key>
            <string>AppleIGB</string>
            <key>IOPCIMatch</key>
            <string>0x15218086 0x15228086 0x15238086 0x15248086 0x15468086</string>
            <key>IOProviderClass</key>
            <string>IOPCIDevice</string>
            <key>NETIF_F_TSO</key>
            <true/>
        </dict>

 

Are there any alternative or an updated KEXT?  I tried IntelMausiEthernet... does not work. No crashes, simply does not see it. I tried Smalltreexxxx .kext same result, no crashes, simply does not see it. 

Share this post


Link to post
Share on other sites
Advertisement

Well, I got it to work.  It seems ok, I was able to boot it, it panicked once, so I did a complete power shut down.

 

This is what I did.  Installed the kext on the "s/l/e" instead of in the EFI.

I also had to delete networkinterfaces.pilist and preference.plist, that reset just about everything.

 

I'm using SMBIOS MacPro5,1

Vega56

64GB EEC

2 Xeons E5-2680

Currently on a 120GB SSD, going to image to into NVME, still looking around a real fast NVME. 

Share this post


Link to post
Share on other sites

dammit!

 

well today I got kernel panics again.

 

There has to be a updated. appleIGB.KEXT?    anyone?

 

Share this post


Link to post
Share on other sites

IntelMausi does not work . :( no panics, it's not recognized, no ethernet.

 

However I will try the AppleIntelE1000  you posted, I can assume its modded with the proper Hardware ID?

 

Thank you by the way.

 

 

Share this post


Link to post
Share on other sites
On 11/30/2019 at 10:08 AM, chris1111 said:

Did you try Intelmausi 1.0 ?

 

IntelMausi.kext.zip

 

EDIT Did you try AppleIntelE1000

??

 

AppleIntelE1000e.kext.zip

sorry none worked. 

 

There must me a way to fix AppleIGP.KEXT .

 

SO far I have gotten to work by removing it, clear the kext cache and installing it again.  It works great. but I shut down the computer for 12 hours or so, when i boot up, i get the panic...  can anyone help? 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Success! Well. Got it to work with a different KEXT.

 

AppleIntelIi210Ethernet.kext.  This the original "10.9" kext, I modified the hardware ID:

 

key>IOPCIPrimaryMatch</key>
            <string>0x15218086</string>

 

Then I just renamed the file with "i350". Place it in your clover "other" Kexts. Make sure you don't have any other. "intelmausi, apple IGB, smalltree_xxxxx, remove them all from all the extension locations, etc. etc.   Reboot and you're done. Catalina here we go!

 

FYI Only for  0x15218086.  I have not tested any other onboard nics.

 

Good luck!

 

 

 

AppleIntelIi350Ethernet.kext.zip

Edited by norcimo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×