Jump to content
Hugo_bee

ASROCK H270M EFI Mojave + HD630 full package

1 post in this topic

Recommended Posts

Here I am back again, with a little work for a noob colleague with a mission

 

Asrock H270M is an ITX mobo (we really appreciate them) that is coming to become an IMAC.

To let this, we have to do the basic Mojave USB setup installation (create install dir procedure) by erasing a normal 16gb USB3 pen

 

After that, apply a Clover UEFI+ESP setup with latest Clover

 

Mount EFI folder of the USB Mojave install disk

 

Replace ENTIRELY the content of EFI partition with the one here.

 

For the BIOS configuration I've applied this one:

 

Advanced \ CPU Configuration → Intel Virtualization Technology : Enabled

Advanced \ Chipset Configuration → Primary Graphics Adapter : PCI Express

Advanced \ Chipset Configuration → Vt-d : Disabled

Advanced \ Chipset Configuration → IGPU Multi-Monitor : Disabled

Advanced \ USB Configuration → Legacy USB Support : Enabled

Advanced \ USB Configuration → PS/2 Simulator : Disabled

Advanced \ USB Configuration → XHCI Hand-off : Enabled

Security  → Secure Boot: Disabled

Boot  → Fast Boot: Disabled

Boot  → Boot From Onboard LAN: Disabled

 

Then: SETUP Mojave

Reboot, mount EFI of DESTINATION DISK and REPLACE its EFI content as done before.

 

you will have:

1 lan 1gigabit (the 1st one to the left, by standing in front of ports)

2 HDMI audio and video with QE/CI

3 all the 15+ USB and XHCI ports enabled

4 SATA and M2 up & running

5 NO WIFI but you can replace with a broadcome native one easily.

6 NO sleep wake

 

 

H270M-Asrock.zip

Edited by ugokind

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By WeBeRiO
      Hi all! I have a Asus h110s1 with a i5-7400 working.

      Only no wake up from sleep, screen black and reboot.

      Is posible fix this problem? No is model UHD.

      Thank U.-
    • By evilshot
      Добрый день! Работает все, кроме встроенного WiFi/Bluetooth( нет модуля, не могу проверить). Сижу пока на USB Wi-Fi TL-WN722N, в дальнейшем собираюсь покупать модуль от MacBook.
      Железо:
      Процессор i5-9600k Материнская плата ASRock z390 Phantome Gaming 6 Встроенное видео: Intel HD Graphics 630 - ok, аппаратное ускорение работает Дискретное видео: Планируется покупка Встроенная сеть: Intel I219V - ok Встроенная сеть: Dragon RTL8125AG - нет драйвера Встроенный WiFi: - Bстроенный Bluetooth 5.0: - Встроенный звук: Realtek ALC1220 - ok SSD: M2 WD green 128gb Память: 24 Gb DDR4-3000 Full-HD монитор - HDMI - подключен к встроенной видеокарте - ок USB 3.0, 3.1, 3. 1gen2-ok Аппаратный NVRAM - не работает, решается тем, что кловер необходимо ставить с EmuVariableUefi - ок. Много усилий и времени заняла настройка биоса в мат плате. Это того стоило. Конечно же не обошлось без добрых людей, которые помогали в ходе установки, настройки загрузчика и системы. Mojave стоит в качестве основной системы, Windows на виртуалке. Прикрепляю загрузчик, Legacy USB, Backup биоса, версии 4,10.
      Вам остается только, вписать модель iMAC( какая вам больше подойдет, у меня сейчас iMac 19.1) и завести iСервисы (FaceTime,imasseges,и т.д.)
      Желаю удачной установки системы
      Фото настроек биоса 
      https://cloud.mail.ru/public/3xd9/2Xtpm64zq
      OSX.BIN.zip
      EFI.zip
      FixUSBPort_AsRockZ390_PG6.zip
      Mojave10,14,6.BIN.zip
    • By hoangmytr
      Hi,
       
      I've just bought Giga Z390 Ultra (+8700k) because I read a lot of people reported this mainboard will easily work.
       
      I create a USB boot drive following the post on Olarila forum. It booted and get through the verbose but then the installation enters the black screen. It seems that it's still going on but there's no signal. 

      I read some topics here and there but still can't figure out how to get HD 630 works in Mojave. I've been using 10.12.6 Sierra on Z77X-UD3H + 2600K for a very long time, so I know I have to update some news info to get this work. But could you please lead me to some of helpful topic because there are a lot of them out there.
       
      Thanks so much!
    • By Bushi93
      Finally Manage to make on of the most powerful and compact Hackintosh available with > the i9-9940X 14 cores + the AsRock X299e motherboard and Vega RX 64 8GB.
      Used for Editing, Motion Design and VFX on Mojave 10.14.3
      Exports time >Four time faster compared to my last i7 6 cores hackintosh.

      Need to add a lot of parameters to get the config.plst to work but once it's right it Works very smoothly!
      Turbo Boost up to 4.2 Ghz all core

      Geekbench scores
      Multi core : 54000 (above the iMacPro 18 cores)
      Single core : 5200
      GPU : 186 800

      Ethernet & Audio work without kext
       
      GPU : The Gygabite VEGA RX 64 required a lowfanspeed.kext otherwise it will always have the fans running in full speed mode (and it can get really noisy).

      Bluetooth & wifi (you can get a blue tooth dongle - the Azus works but you may experience some issue or lag sometime so the best solution is to replace the Bluetooth/Wifi card with the Bcm94360cs2 AC + its adaptor:
      https://www.amazon.fr/gp/product/B07HFQKC2Z/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1
      https://www.amazon.fr/gp/product/B073XHY68N/ref=ppx_yo_dt_b_asin_title_o02_s00?ie=UTF8&psc=1
      With this card you won't need any kext to make it work : you will get native bluetooth and wifi support and even be able to control your bios and clover with your bluetooth magic mouse / keyboard !
       
      USB3 PORTS : need to add some kext
      1 of the 2 USB 3.1 WORK in full speed > USB C  in 3.1 and for some mysterious reson the other USB type A in 3.1 work as USB 2 only
      The other 4 USB3 work fine and the 2 USB3 of my front IO (NCASE M1) work fine too 

      XRP RAM OVERCLOCK : YES
      CPU Overcloking to 4.5GHz may work but did experience some freeze/crash and didn't notice any increase in render time when activated.

      Here is a quick overview of my setup
       
       
       
       
    • By vin047
      Hi, have an old Asrock X58 Deluxe motherboard with an i7-920 Nehalem CPU (yes old board ) + AMD RX460 . As per the title, i've managed to get Mojave installed and running with Speed Step working too!
       
      Final issue i'm having is with sleep - it sleeps fine and even responds to keyboard/mouse event, but instead of waking up to the desktop it restarts and loads from BIOS boot screen. When finally booted into macos, it restores as if restored from unexpected shutdown (though no error is shown).
       
      I've tried for days to get it working, sometimes depending on clover config changes, I can get it to wake up without reboot, but it just remains at a black screen and is unresponsive. 
       
      I have no custom DSDT, i've tried writing one but don't know really know what i'm looking for? Currently relying on clover patches. I've uploaded my original DSDT (dumped from Clover, F4 option) + current config. Anyone have any ideas?
      dsdt original.zip
      config.plist.zip
×