Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
Sign in to follow this  
Followers 0
insanelymacdonald

Unable to perform fresh install of High Sierra, keeps asking me to RE-INSTALL and then fails

1 post in this topic

Recommended Posts

So unfortunately my story is rife with bad choices so I hope you'll be patient with me.

 

I had been contemplating updating my hackintosh (currently on El Capitan) to High Sierra for some time, because I didn't want to go to Mojave while there were still no Nvidea drivers. 

 

While doing groundwork to prepare I started running in to issues just getting the actual installer. The app store kept giving me a 22.7 MB app which, if run will ask prompt you to install High Sierra and even ask which hard drive to perform the installation on to. I assume what happens is that on a normal mac, if you go through with the next step of choosing a hard disk, the installer will initiate the download of the full installer but I was aware that for my hackintosh it wouldn't be that simple and I'd need to create bootable media and take a bunch more steps, I just wanted the full installer. This proved ridiculously hard, and while I was trying to figure why on earth the App Store wouldn't just give me the bloody thing I read someone say on a forum that while they still updates pending in the app store, it refused to give them anything other than the 22.7 MB stub, but, once they had applied all pending updates, the app store link worked as expected with a ~5GB installer download. I duly did this, checking carefully to see if High Sierra itself was among the available updates and it wasn't so I felt comfortable hitting update (previously these types of non-major updates have worked just like a normal mac). On this occasion though, it actually prompted a few restarts which WAS unusual, but they seemed to work, until suddenly, it restarted and got stuck in a boot loop from which I've never recovered. This was bad, as I hadn't yet dove in to what I'd need to do to carefully perform this update, nor done a bootable backup clone (just a time machine).

 

Oh well, as it's now bricked, I may as well go full tilt in to performing the High Sierra install since it's already buggered now anyway. So I tried performing the internet install guide posted on reddit's hackintosh forum here. This method was supposed to allow you to get the full installer in addition to preparing the ground for the install itself plus linked to other sections covering various install situations. I tried this and was able to get a 400MB installer that, while I knew wasn't the full thing, I figured might contain whatever materials were necessary to prompt the 'mac' to attempt to recover over the internet and thus download the full High Sierra install. This method required the erasing of my existing boot disk, but I was okay with this, since I had a Time machine backup of the data plus cloud storage of all important documents, unfortunately though it DIDN'T WORK! It said the installer was damaged or corrupt. I figured this must have been because it was indeed only a 400MB installer and not the full thing so I tried another suggestion that the linked guide made which was that depending on different releases, one must either click the 'install' option or the 'recover' option. I tried recover, which almost worked except it became apparent that it was attempting to recover El Capitan. This is the crux of my problem. Firstly, it can't recover El Capitan anyway, because it attempts to phone home and one way or another determines that this is an unverified mac and refuses to begin, and secondly, this turmoil, and the destruction of my working hackintosh all took place so I could update to High Sierra so it's pointless anyway. Therefore I finally used the 'Dosdude' tool to download the full 5GB installer and started looking in to updating that way.

 

My boot drive is wiped and I have a full installer now so I figured I could now treat this as a fresh hackintosh build rather than an update, only whenever I boot from the USB installer I made, I am only given the option to 'RE-INSTALL' despite having wiped the hard disk. This always fails citing corrupt install media. I can't say for sure whether the install media really is corrupt, I hope not, given how much data it used getting it, however even if it IS, the real problem here is that obviously some trace of the previous, now broken, El Capitan install remains and is causing this install to be an update or repair of sorts. Given High Sierra was never installed on there to begin with, it's no surprising a 're-install' of it is failing. I also tried a simpler 'for the masses' approach to the install found in this youtube video, to see if it helped and found identical results. I tried once again to wipe the hard drive using the disk utility provided in the bootable USB, but it said it couldn't unmount the drive because it was in use which would strongly suggest to me that even though I know it is indeed booting from the USB because it has a High Sierra re-install option on there and because the clover version is different and the GUI looks different, it is somehow using the hard disk, I hesitate to say 'booting' from it, but maybe reading the EFI partition? I don't really know, it's very confusing and frustrating because I thought since I had now obliterated any chance of doing this delicately and retaining my data, at least it could be simpler and closer to starting from scratch but now I can't even do that. My tower is a giant brick that does nothing now.

 

How can I perform a completely fresh High Sierra install on here? Do I need to, and how can I - completely erase the hard disk of ANY TRACE of the previous install, including the EFI partition?

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×