Jump to content

10.4.7 working as SSE2, but kernel panic as SSE3

e lo

5 posts in this topic

Recommended Posts

I had a working install of JaS's version of 10.4.7. I initially installed it with the SSE2 patch, because the installer reported that it saw SSE and SSE2, but not SSE3. This confused me, 'cause I've got a P4 Prescott, and CPU-Z detects the SSE3 instruction set. Some helpful person in my other thread told me that the install runs on a SSE2 kernel, and so is ill-equipped to detect SSE3.


Accordingly, after fooling around with other stuff for a while tonight, I decided to try to re-install 10.4.7, this time with the SSE3 patch. No joy. I now get a kernel panic upon starting up, and it looks to be the same thing that I got when I installed a probable bad burn of 10.4.6. With that burn, I'd get EBIOS errors occasionally, but I was finally able to install, only to get a kernel panic later.


When I run in verbose mode, I see it load a whole boatload of HFS+ files, etc, and the the screen goes blank momentarily, and comes back with the message:


"panic(cpu 0 caller 0x0019C352): Unresolved kernel trap (CPU 0, Type 0=divide error), registers:" and the the following registers, each with what looks like a memory address pointer, in the format XxXXXXXXXX, where it appears "X" is any hex character. The registers listed are CR0, CD2, CD3, CD4, EAX, EBX, ECX, EDX, ESP, EBP, ESI, EDI, EFL, EIP, CS, and DS.


Then below this, I get:

"Debugger called: <panic>

Backtrace, Format - Frame : Return Address (4 potential args on stack)"


memory pointer: memory pointer (more of the same)

10 lines of this, then: "Backtrace terminated-invalid frame pointer 0x0


Kernel version:

Darwin Kernel Version 8.4.1: Tue Jan 3 18:23:53 PCT 2006; root:xnu-792.7.90.obj~1/RELEASE_I386"


Whew! that was a long error. Sorry if it's TMI -- I'm a brand newb to OSX, and I don't know what's important and what isn't. The last time I used a mac, it was a Mac II, the year was 1989 or so, and Al Gore hadn't taken the initiative and invented the Internets yet. :(


Anyway, does anybody have any idea what gives? Why would I be getting a kernel panic with the SSE3 patch installed that I didn't get with the SSE2 patch installed?


Machine is a Dell Dimension 8400

Pentium 4 Prescott, 3 GHz

1.4 GB Corsair RAM

NVidia 6600 GT

Onboard NIC disabled

SMB 10/100 ethernet adaptor (working prior to re-install)

Intel 925 Express MoBo

Link to comment
Share on other sites

I get the same error with an install of 10.4.8 with the 8.8.1 kernel. I had a perfectly working install of 10.4.5 and i upgraded to 10.4.8 with an older kernel. But for some reason 8.8.1 gives me the exact same error as yours does.


Edit: My machine is the same Dimension 8400 with prescott 3.2 ghz and 1 gb ram and an nvidia 6800

Link to comment
Share on other sites


  • Create New...