Jump to content

[HELP] Having sleep/shutdown issues on Mojave upgrade

1 post in this topic

Recommended Posts

Hi all, this is yet another request for help to get sleep/shutdown working on a hackintosh.


I recently upgrade from High Sierra 10.13.6 to Mojave 10.14.4 and have decided to update everything (Clover, Kexts, etc.) and try and get my system to sleep properly (never bothered with it under HS). At the moment, all I get is: the computer goes into sleep mode, then less than a second later wakes back up again. When I have the IGPU enabled, it wakes up to a black screen, but when I have it disabled (nvidia card only) it wakes back up to the login screen. When attempting to shutdown the computer, it will restart a few seconds later.


The only problem is that no matter what I try, I cannot seems to get it working correctly. Everything else is working perfectly, including correctly setup USB and proper CPU power management (using SSDT method).


I have tried just about everything I could find across all the forums to get this working, but without much luck. The only hint at the cause of the problem that I can see came from the output of the system logs (looking for "Wake reason"), this appears to be just about my entire PCI Bus that is preventing sleep (not entirely sure about that, so I'll leave it to you to form your opinions).


Here is what I get from the system logs:

Obelix-iMac:~ johnstray$ log show --style syslog | fgrep "Wake reason"

2019-04-07 20:02:43.280180+0930  localhost kernel[0]: (AppleACPIPlatform) AppleACPIPlatformPower Wake reason: GFX0 PEG1 GFX0 PEG2 GFX0 PXSX RP10 PXSX RP11 PXSX RP12 PXSX PXSX PXSX RP02 PXSX RP06 PXSX RP07 PXSX RP08 PXSX PXSX RP18 PXSX R

Sidenote: In IOReg, there is nothing attached to RP02, RP06, RP07, RP08, RP10, RP11, RP12, RP18, PEG1 and PEG2


Here is my build ("Obelix iMac" in my signature):

Motherboard: Gigabyte GA-Z170-HD3

Processor: Intel Core i7-6700K

Graphics: Intel HD Graphics 530 - Primary output, 1 display connected via HDMI (audio working), Full Metal Support

Graphics: nVidia GeForce GTX 680 Reference Card (flashed with the mac edition vbios) - Secondary output, 1 Display connected via DVI-D, Full Metal Support

Audio: Realtek ALC888B (works with AppleALC and layout-id 1), nVidia HDMI Audio (not tested under Mojave)

Ethernet: Realtek RTL8168E (works using RealtekRTL8111.kext)

Bluetooth: USB Dongle (Cambridge Silicon Radio) works natively

PSU: Corsair H1000i

Memory: Kinston HyperX Fury 2400Mhz DDR4 2x8Gb (16Gb)

SSD: Samsung 960 EVO 500Gb NVMe (works with TRIM support, no patches required) (macOS Drive)

SSD via PCIe card (SATA Mode): Samsung MZHPU128HCGM (Windows 10 Pro Drive)

Clover Bootloader: V 4910

This might be relevant so...

PCIe x1 slot: VIA VL805 USB 3.0 Host Controller

PCIe x16 slot: nVidia GeForce GTX 680

PCIe x1 slot: RALink RT3090 802.11n WiFi Card (doesn't work under OSX, not used anyway since I'm connected by ethernet)

PCIe x16 slot: M.2 SATA Board with Samsung MZHPU128HCGM attached

I have tried to attach as much relevant information as I could think of in the ZIP file below. Any help or suggestions that you can provide will be greatly appreciated.

Cheers, John


Edited by johnstray2001
Link to comment
Share on other sites


  • Create New...