Jump to content
Stompyy

Cant seem to boot the mojave installer (Black screen upon booting)

10 posts in this topic

Recommended Posts

Im having a hard time booting the installer.

I can get to the clover menu just fine, but once I click boot macos from osx_install, my screen just goes glowin black and hangs there regardless of the verbose boot flag being present or not. Its just black, no boot log whatsoever.

Things I tried so far:

* Creating the USB both ways (MBR & GPT).

* Completely removing any previous OS installs.

* Adding the igplatformsi recommended on this thread here.

* Tried booting with GraphicsEnabler=YES/NO IGPEnabler=Yes/No .

* Used OsxAptioFixDrv-64.efi instead of AptioMemoryFix.efi.

Any clue as to what could be going on here? Last year I was able to install HS with no issues so the system should be compatible (I reverted back to win since I had no compatible wifi card). Im now trying Mojave though.

Target laptop: SamsungNP550P5C - 6GB RAM - i7 3610QM (HD 4000) - NVIDIA® GeForce® GT 630M (I think) with Optimus technology. Afaik neither Optimus nor this nvidia card is supported, so goal is driving the whole system via integrated graphics.

Thanks.

EDIT: Booting without inject nvidia, intel nor amd (default config.plist provided by rehabman comes with inject ati and nvidia by default) gives me this kernel panic. Hopefully that sheds some light into whatever is going on here?

Share this post


Link to post
Share on other sites
Advertisement

GraphicsEnabler is a Chameleon boot option; not applicable to Clover

Same for IGPEnabler, except it's a Voldemort's option.

 

Post a zipped copy of your Clover EFI folder, bearing in mind that TMX tools have no support here...

Share this post


Link to post
Share on other sites
Posted (edited)
On 4/5/2019 at 6:00 PM, Hervé said:

GraphicsEnabler is a Chameleon boot option; not applicable to Clover

Same for IGPEnabler, except it's a Voldemort's option.

 

Post a zipped copy of your Clover EFI folder, bearing in mind that TMX tools have no support here...

 

Hey! Thanks for reaching out.

 

I actually made some progress and was now able to at least get to Desktop.

 

Did a fresh High sierra install and was able to get to the desktop, which is extremely choppy and garbled as you can see on the attached picture. I tried HS due to the fact I remembered last year being able to boot to the Desktop (what I just accomplished), if I am able to iron out all the bugs, then Ill upgrade to Mojave.

 

* I tried countless ig-platforms-ids for my HD400 and the one which came by default on RehabMans config.plist was the one which actually "worked", choppy af but I got an image at least, all others would just either reboot or give me insane graphics. id being: 04006601.

 

* Also disabled my dGPU by following this guide. (havent checked if it worked though, how can I check that?).

 

**The config.plist provided by RehabMan wasnt bootable at all, I had to untick inject Nvidia and slide=0 (maybe this last one doesnt matter, but inject nvidia had to be unticked afaik).

 

 

Upon googling, RM suggested this could be fixed by enabling/disabling CSM in BIOS, sadly my BIOS has no toggle related to CSM whatsoever.

 

Ill attach a pic of the garbling as well as my efi folder.

 

Thanks again!

 

PD: Im aware I linked a TM guide as well as tagged a TM moderator, if thats not allowed then my apologies. One things for sure, Im staying the f*** away from any beast related tools :).

 

 

 

IMG_2873.JPG

Stompys EFI.zip

Edited by Stompyy

Share this post


Link to post
Share on other sites
5 hours ago, Hervé said:

Try this config.plist (yours with some cleaining up, especially the removal of ATI graphics injection...)

config.plist.zip

 

Thank you for taking the time to provide a custom config. Just tried it.

 

Without touching your config, it goes straight into a black glowing screen (with and without -v).

 

Making a couple changes such as injecting nvidia and using nv_disable=1 results in the attached picture.

 

If you can think of anything else for me to try, let me know please!

 

Thanks.

IMG_2877.JPG

Share this post


Link to post
Share on other sites
Posted (edited)

There's really no point trying to inject nVidia since that Fermi model is not supported.

 

What's your screen resolution? If higher than 1366x768, we need to get you on the HiRes layout 01660004 + DualLink and you may try the attached revised Clover config.

config.plist.zip

Edited by Hervé

Share this post


Link to post
Share on other sites
Posted (edited)
42 minutes ago, Hervé said:

There's really no point trying to inject nVidia since that Fermi model is not supported.

 

What's your screen resolution? If higher than 1366x768, we need to get you on the HiRes layout 01660004 + DualLink and you may try the attached revised Clover config.

config.plist.zip

 

Resolution is 1600x900.

 

And yeah, sadly enough that new config boots me to a black glowing screen and nothing else. 

 

As for your statement regarding fermi, you still left inject nvidia ticked in this new config. Tried with and without it though and the issue remains.

 

Also tried combinations of bootflags & injects and it either goes to the black screen or kernel panics like on the previous picture.

 

Should you think of anything else I can do, shoot please!

Edited by Stompyy

Share this post


Link to post
Share on other sites

You're mistaken: I set "Inject Intel", not "Inject nVidia". I guess you did not read the config properly...

 

If you're using the latest version of Lilu + WEG, you won't even need to specify "Inject Intel" + the layout-id. You may still need to keep the DualLink parameter set.

Share this post


Link to post
Share on other sites
20 minutes ago, Hervé said:

You're mistaken: I set "Inject Intel", not "Inject nVidia". I guess you did not read the config properly...

 

If you're using the latest version of Lilu + WEG, you won't even need to specify "Inject Intel" + the layout-id. You may still need to keep the DualLink parameter set.

 

omg I didnt realize your attachments were .zip, I thought they were .plist, so the config wasnt actually being used at all by Clover. My bad.

 

Anyway, the first one you provided reboots my system. The second one gets me to the desktop, but still looks choppy af.

 

And yeah, im using latest lilu+weg. 

 

 

:(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×