Jump to content
Sign in to follow this  
Followers 0
DoZe

DeLL LaTiTuDe 5414 Rugged (P46G) Bios v1.22 DSDT

8 posts in this topic

Recommended Posts

Advertisement

Ok :0D

 

I'll do it without and with your DSDT !

 

and -=* T-H-A-N-K-S *=- for your Work !

 

 

Share this post


Link to post
Share on other sites

Like i promised, this is my 2 Ioreg , with and without DSDT :0p

 

20 hours ago, MaLd0n said:

 

the best is one ioreg xD

 

Like i promised, this is my 2 ioreg with and without your DSDT :0)

 

 

Lat5414Rug.ioreg

Lat5414RugDSDTMald0n.ioreg

 

And my latest config.plist :

 

config.plist

 

Last fact with or without DSDT:

 

1) The most anoying thing is the USB3 not work when i plug an UBS3 key, no prob with USB2 key.

2) PowerButton work like this : You push it more than 1 second when you are on the desk: Shutdown the screen, you briefly push it: back to the logon Screen.

3) The "FN+ button" for screen backlight Don't work (no problem via prefs panel)

4) Restart is Strange, very often it seems to be difficult, like if the ACPIbatterymanagement.kext is Rolling 3 or 4 times and shutdown.

    when i restart a new OSx session, a nag screen indicate me osx was not shutdown properly.

    This fact is when i'm running the laptop without AC adapter (on battery).

    With AC adapter : work most of the time, but sometimes 1 or 2 Rolling of the "ACPIbtterymanagement" before shutdown.

 

This is why i join my config.plist to see IF it can cause some prob with DSDT.

Ah , i forget to precise, i'm running Mojave latest flavor.

 

Regards, Ray

 

Edited by DoZe

Share this post


Link to post
Share on other sites
3 hours ago, DoZe said:

Like i promised, this is my 2 Ioreg , with and without DSDT :0p

 

 

Like i promised, this is my 2 ioreg with and without your DSDT :0)

 

 

Lat5414Rug.ioreg

Lat5414RugDSDTMald0n.ioreg

 

And my latest config.plist :

 

config.plist

 

Last fact with or without DSDT:

 

1) The most anoying thing is the USB3 not work when i plug an UBS3 key, no prob with USB2 key.

2) PowerButton work like this : You push it more than 1 second when you are on the desk: Shutdown the screen, you briefly push it: back to the logon Screen.

3) The "FN+ button" for screen backlight Don't work (no problem via prefs panel)

4) Restart is Strange, very often it seems to be difficult, like if the ACPIbatterymanagement.kext is Rolling 3 or 4 times and shutdown.

    when i restart a new OSx session, a nag screen indicate me osx was not shutdown properly.

    This fact is when i'm running the laptop without AC adapter (on battery).

    With AC adapter : work most of the time, but sometimes 1 or 2 Rolling of the "ACPIbtterymanagement" before shutdown.

 

This is why i join my config.plist to see IF it can cause some prob with DSDT.

Ah , i forget to precise, i'm running Mojave latest flavor.

 

Regards, Ray

 

config.plist.zip

battery check rehabman repository

 

check if brightness slider is done

Share this post


Link to post
Share on other sites
2 hours ago, MaLd0n said:

config.plist.zip

battery check rehabman repository

 

check if brightness slider is done

 

Just tested with your config.plist

 

Brightness Slider works without problem, i test it again like before, no prob :0) but "FN + F11 or F12" (brightness key) Don't work.

ALL USB3 is ok ! :0)

I try with Ac adapter unplugged, same as before. (Rolling AcpiBatterymanager (Maximum 8 times) when i shutdown)).

I use the Acpibatterymanage.kext from rehabman repository.

 

I send you the latest ioreg i've made with your DSDT and config.plist :0)

 

Hope this help

 

Regards, Ray.

 

Lat5414Ruglatest.ioreg

Edited by DoZe

Share this post


Link to post
Share on other sites

Hi :0)

 

@ Boot, ACPI error i can read, hope this can help you :

 

ACPI error : Needed type [Reference], found [integer] fffffff001c723b90 (20160930/exresop-183)

ACPI exception : AE_AML_OPERAND_TYPE, While resolving operands for [Shiftleft] (20160930/dswexec-570)

[\___] @000C0 #0079  -Return Value- () <<= 0x14

 

No Local Variables are initialized for method ["\"  ]

 

No Arguments are initialized for method ["\"  ]

 

ACPI Error : Method parse/execution failed [\]  (Mode ffffff7f83a9f720), AE_AML_OPERAND_TYPE  (20160930/psparse-632)

 

 

Regards, Ray

 

 

Edited by DoZe

Share this post


Link to post
Share on other sites

For those who want to update from Mojave to Catalina :P

 

Some problem with Catalina, i have the famous apfs_module_start error.

 

You need to inject with Clover :

 

Change ECDV to EC  : 45434456  45435f5f

 

It works to install from FULL WIPE, update from Mojave result in KerneL Panic !

 

Latest Problem, i never have with Mojave or before : LCD backlight not working

 

What's wrong ?

 

PS: ONLY the brightness control is out, LCD backlight is fonctionnal after a cold reboot :0p

 

Regards, Ray

Edited by DoZe

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×