Jump to content
Khalid Mushtaq

DW1560 Wifi Not Working on X1 Carbon 3rd Generation

16 posts in this topic

Recommended Posts

I have got DW1560 yesterday and installed into my machine. I am using High Sierra 10.13.6.

I have tried all available methods and patches but couldn't get Wifi working. BT is working properly.

Note: I got Wifi working momentarily on two instances but it was for 5-10 seconds and after that it got changed to "Wifi: No hardware installed". One is this morning when I turned on my laptop and I could see it working and connecting to my Wifi Network and second instance was yesterday. I have posted screenshots when system detected wifi but it worked momentarily as I explained. One thing I have noticed if I shutdown my laptop at night and then power ON it in morning then wifi gets detected but just momentarily.

I have attached PR files, please take a look and let me know where I am going wrong.

 

Any help would be highly appreciated.

Thanks,

Khalid

debug_775.zip

Screen Shot 2019-02-08 at 6.54.27 PM.png

Screen Shot 2019-02-08 at 6.54.39 PM.png

Screen Shot 2019-02-08 at 6.54.43 PM.png

Screen Shot 2019-02-08 at 6.55.19 PM.png

Screen Shot 2019-02-08 at 6.56.36 PM.png

Share this post


Link to post
Share on other sites
Advertisement

Check that the card is properly fitted into its slot, that the antennas are properly plugged in and that there is no soft/hard switch that placed the wifi service in the off position. Your screenshots clearly show that the card is detected, the driver installed but that Wifi is turned OFF...

Share this post


Link to post
Share on other sites

Thanks for the response.

 

I have checked many times and it is fitted properly but I am not understanding why it works for 5-10 seconds and then it won't get detected even if I restart my laptop.

 

These screenshots I have taken when it was detected but then it changes to off mode and I can't power it on and on restarting it shows "No hardware installed".

 

 

Share this post


Link to post
Share on other sites
22 minutes ago, Hervé said:

Check that the card is properly fitted into its slot, that the antennas are properly plugged in and that there is no soft/hard switch that placed the wifi service in the off position. Your screenshots clearly show that the card is detected, the driver installed but that Wifi is turned OFF...

 

One thing I also noticed when wifi card is detected then FakePCIID is also loaded and I can see it in kextstat but when FakePCIID is not loaded then Wifi shows "No Hardware installed"

Share this post


Link to post
Share on other sites

I don't know what your system's specs are but there are probably many things not adequate in your Clover setup (ACPI, Device, Graphics, SMBIOS).

 

As far as the wireless card is concerned, I've not looked in details at the Brcm4360 patch you've injected in Clover but it may well be that your issue come from there.

Edited by Hervé

Share this post


Link to post
Share on other sites
10 hours ago, Hervé said:

I don't know what your system's specs are but there are probably many things not adequate in your Clover setup (ACPI, Device, Graphics, SMBIOS).

 

As far as the wireless card is concerned, I've not looked in details at the Brcm4360 patch you've injected in Clover but it may well be that your issue come from there.

 

Thinkpad X1 Carbon 3rd Generation

 

Intel Core i7 5600U 2.6GHz (turbo boost up to 3.2GHz)
Intel HD 5500 Graphics
Samsung 860 EVO SATA M.2 - 500GB Solid state drive
8GB DDR3 Ram Clocked at (1600MHz)
Realtek ALC3232 Audio (Realtek ALC292)
LCD Display 1920x1080 14"
Intel AC7265 Wireless/Bluetooth Card ( Replaced with DW1560 )
Trackpoint/Trackpad with physical buttons for Trackpoint

 

 

Can you please guide how to do proper setup that will be optimal according to my system specs as I am newbie in hackintosh but I have got everything to work except wifi card.

 

Thanks for your time.

Share this post


Link to post
Share on other sites

Things to adjust:

  • MBA7,x or MBP12,x SMBIOS for your 5th gen Broadwell laptop (MBA6,2 is 4th gen Haswell)
  • CPU power management settings
  • Kernel & Kexts patches
  • Graphics settings (why enable Inject Nvidia ?)

 

config.plist

 

Coming back to your DW1560, it shows a RegDomain set to FCC/US. Are you sure this country code is supported in your part of the world? It affects the available frequencies so it's most important to get that right. See if you can change it to the RegDomain that matches your own country. I know that some country codes are required to enable 5GHz band but... You may also look at these threads:

https://osxlatitude.com/forums/topic/10932-country-code-wifi-dw1560-bcm94352z-high-sierra/?page=3

https://osxlatitude.com/forums/topic/11230-mojave-dell-e7450-dell-dw1560-wi-fi-no-hardware-installed/?tab=comments#comment-87553

 

Edited by Hervé

Share this post


Link to post
Share on other sites
3 hours ago, Hervé said:

Things to adjust:

  • MBA7,x or MBP12,x SMBIOS for your 5th gen Broadwell laptop (MBA6,2 is 4th gen Haswell)
  •  CPU power management settings
  • Kernel & Kexts patches
  • Graphics settings (why enable Inject Nvidia ?)

 

config.plist

 

Coming back to your DW1560, it shows a RegDomain set to FCC/US. Are you sure this country code is supported in your part of the world? It affects the available frequencies so it's most important to get that right. See if you can change it to the RegDomain that matches your own country. I know that some country codes are required to enable 5GHz band but... You may also look at these threads:

 https://osxlatitude.com/forums/topic/10932-country-code-wifi-dw1560-bcm94352z-high-sierra/?page=3

https://osxlatitude.com/forums/topic/11230-mojave-dell-e7450-dell-dw1560-wi-fi-no-hardware-installed/?tab=comments#comment-87553

 

 

Are you suggesting me to use attached config.plist in your post?

Share this post


Link to post
Share on other sites

Still no luck, at this point it is about my laptop not detecting Wifi card. When it is detected I can think about 5GHz...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×