Jump to content

AMD 10.4.8 DVD SSE3


9 posts in this topic

Recommended Posts


I installed OSX 10.4.8 DVD AMD (native DVD installation)

I have two problems and I hope you can help me to solve them

The complete file name is:



Reboot problem

Reboot doesn't work (on 10.4.7 it works fine):

If I select restart from the menù bar I can close OSX session but I cannot restart my PC:

I obtain a black screen and I can see these written commands on it:



MACH reboot"

After few seconds these commands disappear and I have only a black screen

Then... nothing... and the machine doesn't restart

I tried to edit the file mach_kernel by using Hex editor as described for the 10.4.7 but this method doesn't work for 10.4.8


"Network - smb problem"

Wireless internet connection works fine (I can use internet) but I cannot connect my hackintosh to my iBook in wireless because smb and network connection don't work

In Network (in Finder) I can see my iBook but if I double click on it I receive an error message: I cannot find the alias... You can repair or delete the alias...

I tried to delete the alias but I don't have privileges and I don't know how I can repair it

Smb doesn't work, too. I tried the command "Apple+K" and then "smb://" but nothing happens.

From the iBook instead I can see the hackintosh and I can connect to it.


Could you help me ?

Thank you very much


Link to comment
Share on other sites

For the reboot error try getting semthex's newest build of kernel you can find the link in the irc channel devoted to it...#kernel.

For the smb error make sure you have file sharing enabled on both machines and try it then.


I just have the latest semthex's build of kernel but reboot doesn't work...

I tried to edit the file com.Apple.boot.plist changing from platform=ACPI to platform=X86PC but even in this case it doesn't work

I always obtain a black screen with the same commands on it "continuing, done, MACH reboot"



For the smb I have file sharing enabled on both machines... I tried to enable Appletalk, too.



Link to comment
Share on other sites

For the reboot problem:


Open Terminal:


" cp /mach_kernel ~/Desktop/mach_kernel "


(mach_kernel is a hidden file, you'll need onyx etc to see it)


Use a HEX Editor:

Replace "EBFE9090" with "B0FEE664"


Terminal again:


"sudo cp ~/Desktop/mach_kernel /"





Sorry Didn't read earlier - you mostly liked messed up the HEX editor. I have 10.4.8 - had the same problem, showed "MACH REBOOT" and would sit there - just try the mach_kernel again - install the patch again and try it - it should work cuz it worked for me.

Link to comment
Share on other sites

Thank you Rammjet



Smb now works fine with the patch

I used this file:



I hope to solve the reboot problem, too...

I tried to re-install the latest semthex's kernel both by auto-install script both by replacing mach_kernel directly with terminal procedure but reboot doesn't work


Link to comment
Share on other sites


  • Create New...