Jump to content
giovannimogna

Mojave - HD7870 - Intel Framebuffer Patch

14 posts in this topic

Recommended Posts

Hi guys, i need some help with my hackintosh

 

Here's my system

CPU: I7 8700

MOBO: Gigabyte Z370 HD3

GPU: MSI HD7870/OC (flashed with UEFI bios, don't know if it matters)

STORAGE: Intel 760p 256GB

 

I created the bootable USB with the new corpnewt guide, but I can't get it to work, it goes black screen after the initial loading

Following that guide I had to put the Intel Framebuffer Patch, but shouldn't AMD cards work OOB or just with Whatevergreen+Lilu?

As SMBIOS I put 18,3 (might be the problem)

 

Probably I'm missing something, but what are the advantages of running both the iGPU and the eGPU?

 

Thanks for your help

 

config.plist

Share this post


Link to post
Share on other sites
Advertisement
7 minutes ago, STLVNUB said:

Need the right frame buffer for 7870, apparently Chutoro

  

Hi STLVNUB, I'm a complete noob

 

What do I need to edit? Is there a guide?

Share this post


Link to post
Share on other sites

You need WEG and lilu kexts as well as these boot-args

radpg=15 -lilubetaall

1 minute ago, giovannimogna said:

Should I keep the Intel Framebuffer patch?

Only if you use it.

Share this post


Link to post
Share on other sites
14 minutes ago, STLVNUB said:

You need WEG and lilu kexts as well as these boot-args

radpg=15 -lilubetaall

Only if you use it.

Are there any advantages of using it?

 

I’m such a noob, sorry

Share this post


Link to post
Share on other sites
7 minutes ago, STLVNUB said:

Its what works with me, try the config.plist first I see you have some args in it.

If it don't work replace your args with mine.

 

I meant, what are the advantages of keeping the intel framebuffer, sorry

As SMBIOS version should I keep 18,3?

Share this post


Link to post
Share on other sites

Don't know, never used it myself.

Have you got igpu enabled, if yes, you probably need it but

according to your plist its not injecting Intel so you don't need it.

Keep. 18,3 its what I use but fill out smbios section with Clover Configurator

 

Edited by STLVNUB

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×