Jump to content

-solved- Dual boot ruined after changing other windows partitions?


1 post in this topic

Recommended Posts



I had a perfectly working Dual-Boot solution using Clover with Sierra + Windows 8 which I have been using for 2 years without any issues.

I'm using one HDD and have several partitions:
1. Windows partition

2. Sierra partition

3. Mavericks partition


Today i split the Windows partition using the windows Disk Manager. I didn't touch the Sierra one but after the split (and also reversing the split) my Sierra won't boot anymore.

I'm getting a "Still waiting for root device" message so I assume that windows somehow did something with the Sierra partition :/

Does anyone have an idea what might have happened here and if there is a fix to this?


Some further infos:


- Mavericks is still booting and working

- Tried to repair the Sierra disk via Mavericks but that didn't help

- Using diskutil the Sierra partition is listed as "Microsoft Basic Data" and has no Volume ID anymore

- Booting from Mavericks Clover won't recognise the Sierra partition

- Using HFS driver on my Windows partition I can still access files on the Sierra 



Any help is very appreciated!


After reading a bit through some more guides/Wiki I managed to fix it.

Should someone have a similar issue, the solution for me was booting with rd=disk0s* (replace the * with the partition number) as mentioned in the InsanelyMac Wiki.


Edited by ManuelMac
Link to comment
Share on other sites


  • Create New...