Jump to content

My Vista Business RTM experience so far


deathbots
 Share

1 post in this topic

Recommended Posts

Hi everyone.

 

Here's the status and outstanding issues of my Vista install, maybe this will help someone, and maybe someone can help me.

 

On my 17" mbp, Installed Vista as an in-place upgrade to a fully-updated and functional boot-camp 1.1.2'd XP installation. I didn't need to do any EFI partition deleting, everything just worked great this way.

 

Apple keyboard support didn't work after reboot, so I grabbed a USB keyboard to do ctrl-alt-del to login.

Promptly re-installed the apple keyboard stuff by going to device manager and manually pointing at the inf file. There are two devices in device manager. these devices have Hardware Id USB\VID_05AC&PID_0217&REV_0060&MI_00 (will be different if you don't have the same laptop)

USB\VID_05AC&PID_0217&REV_0060&MI_02 (same deal)

After doing that, I ran the apple keyboard setup program again out of program files. For grins. So that works fine.

 

SigmaTel Audio didn't work properly after Vista was working.

I used the intel drivers at

http://72.14.203.104/search?q=cache:v5Ho0P...t=clnk&cd=3

And had already done the registry/cpl hack to get speaker muting/headphone support. Once I re-pointed vista at the C:\Program Files\Intel Desktop Boards\Audio\DISK1\WDM to install the audio codec drivers, I'm rocking and rolling, no audio dropouts. So that's how I did that.

 

Video drivers either carried over from windows XP -OR- they're the Vista default ati drivers included with Vista. I'm guessing they actually carried over from XP. The driver version is 7.4.10.830 and the date is 8/21/06. Who knows. It runs battlefield 2142. I had to take ATI's tray icon starter out of the registry startup because vista complained about it.

 

Wireless worked as a carryover from XP, but there were updated drivers for the wireless card on WindowsUpdate so I went with those.

 

ISight carried over and seems to be loading drivers scucessfully, though it doesn't seem to actually work if Windows Live Messenger AV setup is any indication.

 

Bluetooth carried over just fine but I haven't used it yet.

 

My USB-driven CDMA modem for my pocket PC did not, so I'll have to get the thing working as a bluetooth modem.

 

I made sure to uninstall the Cisco VPN client before doing an upgrade. I figured that wouldn't go over well. Cisco has a beta version built for Vista which does work, but cannot start before login like usual.

 

I have the following outstanding issues:

 

"Performance Counters" is listed as a device and no drivers for the device are installed. No drivers seem to work for it.

I have a USB Human Interface Device which "cannot start"

The HID device under Mice and other ... with hardware ID HID\VID_05AC&PID_0217&REV_0060&MI_01&Col01

(yours will be different if you don't have a macbook pro) loaded the apple trackpad filter driver just fine.

This was out of C:\Program Files\Macintosh Drivers for Windows XP 1.1.2\aapltctp

 

Another HID device is supposed to load the "trackpad" driver (not filter). I would have a similar device ID, and if you're in device manager and do view->Devices by Connection, it'll be

expanded under USB Universal Host Controller - 27C8 (yours may be different), USB root hub, USB Composite Device, USB Human Interace Device. Underneath that there was a HID device

with hardware ID HID\VID_05AC&PID_0217&REV_0060&MI_01&Col02 that I tried to point to the inf file in the C:\Program Files\Macintosh Drivers for Windows XP 1.1.2\aapltp directory.

That didn't work so I manually edited the INF to match the device class and GUID of the device I was trying to install it to.

 

I know that is a bad idea, but it was worth a shot.

 

There's a post about extracting the bootcamp drivers (http://forum.insanelymac.com/index.php?showtopic=33514, thanks htdefiant), but my bootcamp 1.1.2 drivers don't have arc.exe and .dll in there, so Im not sure what's the deal there.

 

I do not have two finger scroll and right click support on my trackpad. If anyone knows a good way to get this to work, please respond so I can lighten my laptop bag and leave the mouse at home.

 

Also, Vista is a welcome change. I was getting a bit tired of XP ;)

Link to comment
Share on other sites

 Share

×
×
  • Create New...