Jump to content

Problema por actualizar Clover


5 posts in this topic

Recommended Posts

Hola, espero me puedan ayudar, Tenia la versión 43.. de Clover,  actualize a 4674, al abrir el programa de instalación deje todo como viene solo active "Instalación para arranque UEFI"; el problema es que al entrar en High Sierra me sale un símbolo de prohibido y así se queda, para poder entrar en High Sierra en Clover presiono space y selecciono verbose o presiono F1 y entra; Otro problema con Clover es que si cambio de tema Clover se queda congelado. Saludos. PD soy Novato.

 

DH67CL

i5 3450

R7 250 XFX 1fb

No te preocupes, Clover muta constantemente así que es normal encontrarse algún que otro problema al saltearse tantas revisiones.

 

Si el cuelgue de Clover se da solo al cambiar a cierto tema específico puede que tenga problemas dicho tema o que tenga un error de formato de archivos, en cuyo caso elimina la carpeta del tema y vuelve a instalarlo o prueba con otro tema.

 

El problema de arranque de HS parece uno de selección de preferencias en tu config.plist, ya que al acceder al menú de barra espaciadora estas cambiando algunas preferencias de arranque (carga de kexts desde Clover, por ejemplo).

Sube tu config.plist y un bootlog para revisar que sucede al arrancar. El bootlog lo puedes crear con Clover Configurator, opción "Boot.log", luego guardas el texto con "Save boot.log to Desktop".

 

  • Like 1

Gracias por responder, Lo del tema es así , puedo poner que inicie con cualquier tema (en MacOs) y este inicia bien pero estando ya en Clover despues de la Bios, si quiero cambiar el tema, el Clover se queda congelado, sucedió al actualizar a 4674, la verdad eso de los temas no me preocupa uso el que tiene default, pero si eso pasa es que algo no esta bien;

 

No se si hice bien pero para regresar a la version que tenia 4359 sustitui la carpeta EFI de High Sierra con la que tenia de respaldo, y ya lo tengo como antes. En Preferencias del sistema me aparece así:

Revisión iniciada actualmente : 4359 

Ultima revision instalada: 4674

 

Respecto al config.plist:  Para instalar el Hackintosh me base en esta guía https://www.tonymacx86.com/threads/guide-intel-dh67xx-with-hd3000-using-clover-uefi-hotpatch.233257/  y baje el config.plist que subió el usuario que creo la guía, pero yo quería hacer funcionar la grafica que tengo y pues le moví  a ciertas cosas, de hecho me aparece que tengo esto AMD Radeon R9 370X 1024 MB cuando tengo esto R7 250 XFX 1gb je je , lo mas seguro es que mi config.plist sea un desastre. 

 

El botlog que me pediste es da la version de Clover que tenia funcionando 4359, porque es la que no me da problemas,  si quieres instalo la versión 4674 para ver los errores, pero antes quisiera saber que opciones marcar en la instalación de Clover antes de actualizar.

 

 

Mi PC esta así: tengo 2 DD en el primero Windows 10 y una partición de datos

                                         en el segundo MacOs High Sierra y una partición de datos

 

PD: Todo esto fue por querer actualizar a Mojave ya que en todos lados dicen que hay que actualizar Clover pero no dicen como (que opciones marcar y cuales no) jaja

Total que la actualización a Mojave no resulto bien y ya no pude entrar  a ese disco, estoy en un DD externo que use para respaldo antes de actualizar.

 

DH67CL

i5 3450

R7 250 XFX 1gb  

 

Perdón por tardar en responder y otra vez gracias. Saludos.

config.plist

bootlog.txt

  • 2 weeks later...

Primero que nada te recomiendo tener un pendrive con un Clover funcional en caso que la actualización falle.

 

Segundo, creo que hay problemas con la lectura de varios archivos en tu EFI, probablemente esté corrupta la partición:

0:141  0:001  - [01]: tonymacx86 - bad theme because theme.plist can't be load
0:180  0:000  Loading _CSMVI~1.EFI  status=Unsupported (tarda casi 22 segundos en analizarlo!)
21:974  0:000  Loading OSXAPT~1.EFI  status=Success

Te recomiendo formatear la EFI antes de volver a instalar Clover. Antes de proceder crea una copia de la carpeta EFI para no perder tus configuraciones (y elimina los archivos corruptos de arriba), y luego procedemos a formatear desde un Terminal:

sudo newfs_msdos -F32 -v EFI /dev/diskXsY

Deberás reemplazar la X por el numero de disco y la Y por el numero de partición. Ambos datos los puedes extraer estudiando el resultado del comando "diskutil list", en el ejemplo debajo sería "disk0s1":

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *120.0 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk3         119.8 GB   disk0s2

 

A continuación te indico lo que creo que debes tildar en el instalador según lo que entiendo a partir de tu bootlog:

 

- "Instalación para arranque UEFI"

- "Instalar Clover en la partición ESP"

 

Si no sabes que drivers UEFI seleccionar, puedes mirar la carpeta Drivers64UEFI y comparar. Según tu bootlog tienes estos drivers:

CsmVideoDxe
DataHubDxe
EmuVariableUefi
FSInject
OsxAptioFixDrv
OsxFatBinaryDrv - elimínalo, no debería ser necesario para ti
PartitionDxe - elimínalo, no debería ser necesario para ti
SMCHelper
VBoxHfs
APFS.EFI - elimínalo, te recomiendo reemplazarlo por ApfsDriverLoader

 

EDIT: deberías eliminar los kexts que tienes en EFI\CLOVER\kexts\10.13\ porque son duplicados de "Other".

 

Y perdona la demora, no pude responderte en el momento y luego ya no vi mas el tema.

  • Like 1
×
×
  • Create New...