Jump to content

iMac 21,5 Mid 2011 won't turn on 1 LED lights on


2 posts in this topic

Recommended Posts

Hello guys,


I got two iMacs 21,5" Mid 2011 which shows the exact same curious error.

I have dissassembled it to test some Graphics Cards and reassembled it again. After power is plugged in, its fans start automatically. First in normal speed and after maybe 15-20 seconds at FULL speed.

The last of the 4 LEDs, from left to right is lighting up. I tried a few times to dis- and reassembly this iMacs with no changes.

I tried also to put out the small battery out and in.


One time, I reassembled it wrong. There are to 7 PIN sockets for HDD PWR and the other 7 PIN socket for camera and other things, I accidently put them wrong in, for one time.

Maybe it is one reason? 

I don't know.


Maybe someone can help out here.



Edited by romac90
Link to comment
Share on other sites

  • 1 year later...

Boy I didn't know they made a 21,5 I must have been asleep


edit: Oh I see 21.5, that's better

Edited by STLVNUB
Link to comment
Share on other sites


  • Create New...