Jump to content

(SOLVED) - LG 31MU97Z-B - monitor sometimes sleeping after system wake

8 posts in this topic

Recommended Posts


Sometimes my monitor LG LG 31MU97Z-B won't wake after sleep. If i push power button on monitor for 1sec it's wakes. On Whatevergreen kext FAQ I found possible resolution for this issue - https://github.com/acidanthera/WhateverGreen/blob/master/Manual/FAQ.Radeon.en.md




Why can a highres DisplayPort-connected display fail to wake (e.g. some LG 4K models)?
Sometimes AGDC configuration preference could be the case. For 4K and lower it makes sense to try disabling it by passing CFG,CFG_USE_AGDC — False (00) via SSDT or similar.



Is there someone facing already with that problem and can help with it?

My hardware is:

CPU: Intel 8700K
GPU: integrated
MB: MSI z370m Gaming Pro AC
Monitor: LG 31MU97Z-B


My clover folder also attached.


Edited by v.osypets
On 7/19/2018 at 1:29 PM, millusions said:

here is my 5 cents.

I think it's more monitor issue than Mac OSX / graphics driver.

I've got a dell 32 inch and dell 27 inch on my main, 3rd screen  I never turn on. and this happens more than it should basically.

on my second machine with similar hardware but SONY TV it never happens. Same OS, same kexts, same CPU, slightly different graphics card (GTX980ti/GTX780ti)

the way I get around it is press 'source' on both screens before I wake Mac up, this wakes up the screens and I don't lose the applications layout.

but I could be doing it wrong and am all ears :)



Yes, I think it's problem with monitor, but earlier that problem was very rare, but after few OS updates it's happens almost every wakeup process. Thanks for feedback.

4 hours ago, millusions said:

There's a lot of google results with Dell monitors not waking up, so I blame Dell... specially the horror 32 inch - it's a nightmare screen - so many issues since day 1.

but if you find a fix please share


btw. do you get 4k at 60Hz on your LG? is it MST screen?


At this time it's works with 3840 x 2160 x 30bit @ 60 Hz. It's SST monitor. But it's not a native resolution for that monitor. Native res is - 4096 x 2160, but I can't run it with this resolution. Seems MacOS not supported it with Intel UHD 630. 

Edited by v.osypets
8 hours ago, millusions said:

nice! on Intel 630? far out, thats great result. I can't get 4k 60hz on GTX780ti, have tried other cards as well.


It's works for me without any fixes.


8 hours ago, millusions said:

try SwitchResX .

I'm tried today, but can't create custom 4096 x 2160 resolution. 


8 hours ago, millusions said:

mine wouldn't even do 2k 60Hz without that.

I'm not sure it will work for you but I fiddled with this a lot an no install would give me 2k at 60Hz without SwitchResX on this 32 inch MST screen (have tried all OS versions and all possible


Did you tried this patch? Maybe it's help in your case - https://github.com/Floris497/mac-pixel-clock-patch-V2

  • 2 weeks later...
On 7/24/2018 at 12:56 AM, millusions said:


i have tried that patch, a while ago, i cant remember exactly but it didnt work for me, but maybe it will work, from memory i was on 10.11 when i tried it. so thanks, thats a great idea.

4k works perfectly without fuss in windows.



With latest Mac OS special update 10.13.6 (17G2112) and Whatevergreen.kext I have support for CoffeLake video and native resolution (4096 x 2160 @ 60 Hz) on my monitor, but problem with sleeping still persist.





Edited by v.osypets

I think it's not monitor problem. If I push button on mouse my PC wakes in two stages (please see screenshot) - DarkWare from Normal Sleep and after DarkWake to FullWake from normal sleep. If I pushing power button on case we have wake in one stage - Wake from Normal Sleep. 

Is there possible to program wake with mouse and keyboard same as with power button?


  • Create New...