Jump to content

[Guide] High Sierra 10.13.5 with i5-8400 and Gigabyte B360M D3H (success with a few issues)

2 posts in this topic

Recommended Posts

I am writing this post hoping that this may be useful for others who have a similar configuration. 


CPU: Intel Core i5-8400 
Mobo: Gigabyte B360M D3H (read from many sources that B360 chipset is good enough for i5-8400)
GPU: Intel UHD 630 (iGPU)


I mainly followed this guide: https://hackintosher.com/guides/high-sierra-install-full-guide/ 


As of 6/22/2018, the Clover EFI provided in the above guide is for High Sierra 10.13.4: https://hackintosher.com/wp-content/uploads/High_Sierra_10.13.4_17E199_EFI.zip. One worth mentioning is that this Clover EFI contained the IntelGFX FakeID information (IntelGFX: 0x19168086, ig-platform-id: 0x19160000) for enabling the iGPU I was using. To install 10.13.5, I followed this update guide: https://hackintosher.com/guides/hackintosh-high-sierra-10-13-5-update-guide/. To summarize, what I did was to update all Kexts and apfs.efi to the latest version. I used the patched apfs.efi from: https://github.com/JennyDavid/Apfs.efi-for-macOS-High-Sierra. 


A few things to note during installation:

  1. You can use an external HDD as the installation source: I used an external HDD with GUID partition map (which automatically creates an EFI partition) with a 16 GB partition as the installation source. Simply treat this 16 GB partition as a USB flash drive, and follow any guide on creating a bootable installation disk. This saves some installation time because an external HDD is faster than a USB flash drive. 
  2. Try to use DisplayPort if you can: My mobo comes with 4 video ports: VGA, DVI, HDMI, and DisplayPort (DP). I knew that VGA was not supported by macOS, so I started with connecting my monitor to DVI. However, the installation would always end up with a blank screen (no video output). I spent quite some time on this. Eventually, a simple solution of switching to DP solved the problem. 


The installation went smoothly, during which the computer rebooted for 3 to 4 times. Video worked right out of the box with correct VRAM allocation: "About this Mac" -> "Graphics" showed "Intel UHD Graphics 630 1536 MB". 


There are still a few remaining issues:

  1. Audio and sleep/shutdown: I tried two ways to get audio working. I started by using the latest (1.2.7) AppleALC.kext and setting "Audio Inject" in Clover to be 1. (Note: 1.2.6 that came with Clover EFI mentioned in the beginning of this post did not work.) More details can be found in: https://hackintosher.com/guides/get-hackintosh-audio-working. However, this would give me the infamous sleep/shutdown problem -- the computer reboots every time I try to shut down or sleep. The other method is using the latest (2.9.1) VoodooHDA.kext. It seemed to partially solve the sleep/shutdown problem. Sometimes the computer could properly shut down, and sometimes it would simply reboot. It was still somewhat inconsistent, and I haven't found the pattern yet. As a side note, I had to disable ErP in BIOS because my PSU (Corsair CX550M) does not seem to support it. (With ErP enabled, my computer did not start unless I unplugged the power cord and reconnected it.) 
  2. DVI: I mentioned this in my installation notes. After installation, I could not get any video output from the DVI port. I did some research and suspected that this had something to do with framebuffer, but I am not capable enough of solving this problem myself. 


I read some posts from this forum and realized perhaps the best way to proceed is DSDT: https://www.insanelymac.com/forum/topic/321872-guide-sierra-high-sierra-mojave-on-mobos-serie-100-200-300-skylake-kabylake-coffeelake-dsdt. I will ask for help over there.  


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.