Jump to content

Help with Sound - Dell Latitude C640


3 posts in this topic

Recommended Posts

I need help getting my Dell Latitude C640's sound working. I think I'm close, but can't get a few of the remaining pieces. I need info from someone who has a Latitude C640 (or any other dell with a Crystal CS4205 sound chip) with working sound. I need to replace my kext info with the same info you have.


What's happened so far:

Installed OSX 10.4.6, no sound :thumbsdown_anim:

Volume controls are greyed out.

Worked with AppleAC97Audio.kext as per other forum docs with no success.

kextload repeatedly failed to load the AppleAC97Audio.kext.

Blew away the existing AppleAC97Audio.kext and replaced it with alternate from another forum post, better, but again no success

This time, the kext loads, but I still have no sound.

Did notice one thing. In system profiler, when I look at the AppleAc97Audio extension, in the bottom message window, I have a Dependency Error. It wants com.apple.iokit.IOAudioFamily. I have no IOAudioFamily extension in the list of extensions that I see.


I think that my problem may be that my sound chip's info is not in the AppleAC97IntelICH.kext.

Looking at the XML, I see where I have entries for ICH2 - 6, and a VIA chip.

My Dell has a Crystal 4205 chip in it.

Crystal CS4205 soundchip to be exact.

From a linux site I have "The Crystal CS4205 soundchip will work as an Intel 810-compatible AC97 soundcontroller, the ALSA-module for it is called snd-intel8x0. There are no noticeable differences between the drivers, they both work fine."

I don't have a good way to get the device and vendor info from this chip without installing windows.

I have booted Ununtu but lspci does not see the chip.


I have now spent 4 days of due diligence crawling through these forums and the web in general with no info on how to solve this. I'm stuck so I'm asking for help here.


If you have a Latitude C640 (or any other Dell with the Crystal 4205 chip in it), can I arrange to get a copy of your AppleAC97Audio.kext? I'd like to see both your settings for the Intel kext as well as your plist.info entries too. Might as well ask to get everything I need to save the effort. If I have a known working set, that gives me a solution to compare and contrast with. I'd also like to know if you have an IOAudioFamily extension in your list of extensions. I do not in mine and did not fool with it as part of anything I did in troubleshooting this.


If you can help me, I'd be very grateful.

Link to comment
Share on other sites

  • 2 weeks later...

It seems this may be a hardware issue with this specific laptop. I have tested further in a wider arena. When booted up under Windows XP, the sound chip is not seen, when booted up under Ubuntu Linux, it isn't seen either. I have plugged in a USB based sound "dongle" and I have sound through that with no issues using headphones.


Sometimes when booting XP I have seen the sound device "show up". Most of the time it doesn't. Never has shown up under Mac OS X, though.


Would ahve been nice to have built-in sound, but at least it isn't an OS problem that I can't solve at this point. Having another hardware alternative has solved the issue as far as I am concerned.

Link to comment
Share on other sites

For HD sound there are usually 2 chips: the codec chip (Cirrus - Crystal) and the controller chip.


From what I can find, you might have one of three different codec chips:

{ 0x43525959 "CS4205 rev A"},
{ 0x4352595a "CS4205 rev B"},
{ 0x4352595b "CS4205 rev C"}

(where vendor id is 4352 [Cirrus] and device id is 5959 or 595a or 595b)

For the controller chip, the best that I can determine is:


(where vendor id is 8086 [Intel] and device id is 2485)

The identifier for the codec chip is backwards from the controller chip - (ven)(dev) vs. (dev)(ven)


Perhaps searching with lspci for "4352" and for "8086" will be fruitful, but there are probably several Intel (8086) devices in the computer.

Link to comment
Share on other sites


  • Create New...