Jump to content

[Post-Installazione] hd interni visti esterni, audio, boot automatico, risoluzione


46 posts in this topic

Recommended Posts

Salve! ho installato yosemite 10.10.5 come mi avete consigliato sul seguente HW

 

mobo z68x-ud4-b3
cpu i5-2500k (sandy bridge)
vga amd radeon hd 6800 xfx

 

 e ho i seguenti problemi:

 

1) gli hd interni li vede come esterni (icone arancioni) c'era un kext da installare (ma non ricordo) o forse si può risolvere da config.plist?

 

2) Audio: ALC889: non ho installato nessun kext, esisteva uno script per poter risolvere con il normale applehda? e specialmente c'era un flag per non perdere le modifiche ad aggiornamenti? NB stranamente funziona l'hdmi ma non il connettore esterno

 

3) boot automatico: da clover configurator non riesco a configurare il boot automatico di macosx, ogni volta devo pigiare invio sulla tastiera.

 

4) il sistema mi riconosce la scheda come radeon hd 6xxx 1gb. se lo collego in DVI si vede perfettamente, mentre se lo collego in hdmi la risoluzione è pessima e va oltre i bordi del monitor. questo potrebbe aiutare? ---->http://www.insanelymac.com/forum/topic/273937-guide-getting-xfx-hd6850-connectors-to-work/

 

grazie in anticipo :)

config.zip

mi sembra che era questo kext...è passato tempo...prova a metterlo in efi...ci sta anche la patch da config ma non la ricordo

 

http://www.insanelymac.com/forum/files/file/436-ahciportinjectorkext/

 

per l'audio metti applealc e lilu.kext in efi ...nel config sezione device\audio prova i layout 1,11,12...uno alla volta seguiti da riavvio

Archivio.zip

Fai quanto richiesto sopra

eheheh svista

mi sembra che era questo kext...è passato tempo...prova a metterlo in efi...ci sta anche la patch da config ma non la ricordo

 

http://www.insanelymac.com/forum/files/file/436-ahciportinjectorkext/

 

per l'audio metti applealc e lilu.kext in efi ...nel config sezione device\audio prova i layout 1,11,12...uno alla volta seguiti da riavvio

Grazie per le dritte! dato che siete in due a seguire questo post non effettuo nessuna modifica prima di aver sentito entrambi altrimenti potrei sovrapporre le stesse modifiche o intralciare il lavoro di voi due. i log che ho condiviso sono antecedenti a qualsiasi modifica suggerita. ho eliminato il kext ATI6000controller. attendo una vostra

Se vuoi vediamo di fare un DSDT ad hoc per la tua scheda. Alla schermata di Clover premi F4 un paio di volte e attendi una 30ina di secondi prima di fare il boot, poi vai in EFI/CLOVER/ACPI/origin e controlla che la crolla sia popolata di file (altrimenti devi ripetere l'operazione) e poi posta la origin zippata


Deisicuro che riserva Nullcpupowermanagement, prova a toglierlo e fammi sapere

Se vuoi vediamo di fare un DSDT ad hoc per la tua scheda. Alla schermata di Clover premi F4 un paio di volte e attendi una 30ina di secondi prima di fare il boot, poi vai in EFI/CLOVER/ACPI/origin e controlla che la crolla sia popolata di file (altrimenti devi ripetere l'operazione) e poi posta la origin zippata

hai per caso controllato il link che ho postato su? http://www.insanelymac.com/forum/topic/273937-guide-getting-xfx-hd6850-connectors-to-work/

 

quell'utente ha la mia stessa scheda video (XFX amd ati 6850)  descrive gli stessi connettori dello stesso colore e presumo che sia identica. solo che dovrei forzare mac os x ad usare il suo kext ma non so come fare (oltre ad attingere informazioni per creare il dsdt adeguato)

 

comunque intanto sono sulla schermata di clover bot e ho premuto 2 volte F4.... attendo i 30 secondi (ma anche 1 minuto) e avvio.

edit: eccolo

origin.zip

Quando si fanno le prove avere sempre il modo di poter fare il boot con una EFI di backup, la pendrive con cui abbiamo installato per esempio.

Copia il DSDT allegato in EFI/CLOVER/ACPI/patched (non in origin mi raccomando) e sostituisci il config prima con il 2 che ha inject ATI e se non funziona a dovere passa al 3 che non ha iniezione.

Riporta i risultati e poi procederemo di conseguenza.

(naturalmente i file vanno decompressi prima di usarli)

DSDT.aml 2.zip

config.plist 2.zip

config.plist 3 .zip

Quando si fanno le prove avere sempre il modo di poter fare il boot con una EFI di backup, la pendrive con cui abbiamo installato per esempio.

Copia il DSDT allegato in EFI/CLOVER/ACPI/patched (non in origin mi raccomando) e sostituisci il config prima con il 2 che ha inject ATI e se non funziona a dovere passa al 3 che non ha iniezione.

Riporta i risultati e poi procederemo di conseguenza.

(naturalmente i file vanno decompressi prima di usarli)

va bene. ho la chiavetta per l'eventuale boot. potresti elencarmi le modifiche che hai effettuato? per "riporta i risultati" intendi i 4 file che mi hai chiesto di allegare? grazie

Ho patchato il DSDT per renderlo consono alla tua MB e ho modificato il config nella sezione ACPI per accordarlo al DSDT.

Con risultati intendevo come funziona il sistema soprattutto riguardo alla grafica, eventualmente servirà rifare ioreg e hack_info.


Che versione di Clover stai usando?

1) gli hd interni li vede esterni (icone arancioni)

2) audio non riconosciuto. (è sparito anche l'audio nell'hdmi)

3)boot clover manuale.

4)configplist 2 schermata nera. config.plist 3 parte ma presenta gli stessi problemi. in più è sparito l'audio dall'hdmi.

 

se puoi elencarmi le stringhe che hai modificato aggiunto. così da capire e imparare.

 

EDIT: l'ultima versione sul sito ufficiale.

Archivio.zip

Se hai scaricato da quel link dovresti avere l'ultima. Purtroppo sono una cippa per quanto riguarda grafica AMD, vediamo se può intervenire gengik che ne sà ben più di me.

Ti farei provare con lilu e whatevergreen ma non so se possano funzionare con Yosemite.

Porta pazienza

Se hai scaricato da quel link dovresti avere l'ultima. Purtroppo sono una cippa per quanto riguarda grafica AMD, vediamo se può intervenire gengik che ne sà ben più di me.

Ti farei provare con lilu e whatevergreen ma non so se possano funzionare con Yosemite.

Porta pazienza

certo sta tranquillo :) mi chiedevo se potevamo forzare l'utilizzo di quel kext al posto di quello base....tu sai farlo? forse con quello risolviamo

Prova sostituire il config con quello allegato e metti i due kext nella EFI

 

1) gli hd interni li vede esterni (icone arancioni)

2) audio non riconosciuto. funziona solo in hdmi ma dal jack sul retro no

3)boot clover manuale.

4) la vga viene riconosciuta. dvi funziona bene in full hd 1080, in hdmi funziona bene solo in in hd 720.

Togli quel kext che hai provato per i dischi rigidi, sostituisci il config con questo e controlla appunto il discorso dei dischi arancione e l'avvio automatico.

Per l'audio vedo che hai un AppleHDA patchato se hai o trovi l'originale installalo in S/L/E (sovrascriverà quello patchato) mi raccomando installare non copiare, usa una applicazione fra le tante disponibili per farlo, poi metti AppleALC.kext nella EFI e riprova?

Ma come controlli se l'audio funziona? Vai prima in Preferenze di sistema e scegli l'uscita adeguata? Se provi con i tasti volume devi prima abilitare i suoni di feedback, meglio sempre ascoltare qualche cosa.

Per l'affinamento della grafica aspettiamo gengik.

Quando hai fatto riposta i risultati di hack_info, ioreg e dici.

Ho visto che hai qualche anche qualche  kext non coevo.


Edit: ho trovato questo AppleHDA provalo

config.plist 5.zip

AppleALC.kext.zip

AppleHDA originale Yosemite.zip

Grande! 

 

Audio Riconosciuto

Boot automatico

HD interni

 

VGA dvi 1080p hdmi 720+ audio hdmi

 

si ma ora devo capire cosa hai modificato e come ci sei arrivato :D

 

ps: questa configurazione posso utilizzarla per una ipotetica chiavetta bootable per installare yosemite su questa macchina? grazie

Quello che ho fatto è stato preparare un DSDT per il tuo hardware modificare il config per accordalo, farti togliere alcuni kext , aggiornarne qualcuno e mettere in EFI qualcun'altro.

Se vuoi posta come già richiesto Hack_info e ioreg che ci si dà una occhiata finale

Guide ne ho lette a centinaia, sono circa 10 anni che bazzico questo mondo e quello che ho imparato è solo una piccola frazione dello scibile disponibile. A queste mancanze ovvia un pò di esperienza. E'difficile riassumere in poche parole la questione. Il DSDT (ma più propriamente le tabelle ACPI) è una rappresentazione dell'hardware che viene resa disponibile dal Bios a vantaggio del sistema operativo qualunque esso sia; patcharlo significa correggere eventuali errori di compilazione e compiere altre azioni come l'aggiunta di determinato hardware e il rinominare alcune cose per renderlo più "comprensibile" a OS X. Questo a grandi(ssime) linee.

Tutto questo è stato reso decisamente più semplice da persone che hanno sviluppato le patch specifiche da applicare tramite programmi come MaciASL.

Riguardo i kext, questi sono in continua evoluzione e solo leggendo/sperimentando si può raggiungere una certa dimestichezza. Importante anche il config.plist in tutte le sue parti. 

Come vedi non è un discorso che si può racchiudere in poche frasi, se ne avrai la voglia e la costanza google ti sarà amico e vedrai che ogni volta per una cosa che capisci ne trovi altre dieci da capire.


EDIT: Non hai tolto nulcpupowermanagement dalla EFI e sembra che non hai installato l'AppleHDA che ti ho passato.

questi kext hanno qualcosa che non va:

Unsigned/Patched kexts:

/System/Library/Extensions/ALF.kext: resource envelope is obsolete (custom omit rules)
/System/Library/Extensions/Apple16X50Serial.kext/Contents/PlugIns/Apple16X50ACPI.kext: resource envelope is obsolete (custom omit rules)
/Library/Extensions/ATTOCelerityFC8.kext: resource envelope is obsolete (version 1 signature)

Dovresti trovarli ed installarli

Guide ne ho lette a centinaia, sono circa 10 anni che bazzico questo mondo e quello che ho imparato è solo una piccola frazione dello scibile disponibile. A queste mancanze ovvia un pò di esperienza. E'difficile riassumere in poche parole la questione. Il DSDT (ma più propriamente le tabelle ACPI) è una rappresentazione dell'hardware che viene resa disponibile dal Bios a vantaggio del sistema operativo qualunque esso sia; patcharlo significa correggere eventuali errori di compilazione e compiere altre azioni come l'aggiunta di determinato hardware e il rinominare alcune cose per renderlo più "comprensibile" a OS X. Questo a grandi(ssime) linee.

Tutto questo è stato reso decisamente più semplice da persone che hanno sviluppato le patch specifiche da applicare tramite programmi come MaciASL.

Riguardo i kext, questi sono in continua evoluzione e solo leggendo/sperimentando si può raggiungere una certa dimestichezza. Importante anche il config.plist in tutte le sue parti. 

Come vedi non è un discorso che si può racchiudere in poche frasi, se ne avrai la voglia e la costanza google ti sarà amico e vedrai che ogni volta per una cosa che capisci ne trovi altre dieci da capire.

mi aggiornerò in qualche modo ^^''''''

EDIT: Non hai tolto nulcpupowermanagement dalla EFI e sembra che non hai installato l'AppleHDA che ti ho passato.

strano. ho utilizzato kext utility http://www.insanelymac.com/forum/topic/140647-latest-kext-utility-macos-sierra-super-speed-edition/ e mi ha dato esito ok. :S comunque non ho ne modificato applehda ne patchato non so perchè risulta modificato..... se tolgo nulcpupowermanagement non si avvia va in panic e si riavvia. vuoi che lo tolgo e fotografo l'errore?

questi kext hanno qualcosa che non va:

Unsigned/Patched kexts:

/System/Library/Extensions/ALF.kext: resource envelope is obsolete (custom omit rules)
/System/Library/Extensions/Apple16X50Serial.kext/Contents/PlugIns/Apple16X50ACPI.kext: resource envelope is obsolete (custom omit rules)
/Library/Extensions/ATTOCelerityFC8.kext: resource envelope is obsolete (version 1 signature)

Dovresti trovarli ed installarli

cercherò! anche se non sembrano facili da trovare, ma ci riuscirò

×
×
  • Create New...