Jump to content

Radeon 9600 Pro Woes - Fixed

4 posts in this topic

Recommended Posts

I tried searching, I followed all the guides I could find everywhere, and to no avail...

I'm running 10.4.6 with a Radeon 9600 Pro (128 Mb) graphics card, Samsung 17" CRT monitor. I added the Callisto 008 kexts (didn't change the device ID because it's the same as mine), edited the EDID to match my monitor (from SwitchResX) , installed AGPGart, and changed the framebuffer to CallistoFB. I also edited the ATIRadeon9700.kext with a hex editor according to a thread that I can no longer locate, and made sure that all my kext's have the proper owner and permissions... all of this does not work. This is the output from my system profiler:

  Type:	VGA-Compatible Controller
 Bus:	AGP
 VRAM (Total):	256 MB
 Vendor:	ATI (0x1002)
 Device ID:	0x4150
 Revision ID:	0x0000
 Kernel Extension Info:	No Kext Loaded
 Resolution:	1024 x 768
 Depth:	32-bit Color
 Core Image:	Not Supported
 Main Display:	Yes
 Mirror:	Off
 Online:	Yes
 Quartz Extreme:	Not Supported


It's odd that it identifies it as having 256 MB VRAM, when really it's only 128. Other than that, it seems to be a problem with the kext not being loaded. I know this question has been asked repeatedly, but none of the currently posted solutions seem to work. Any help would be greatly appreciated. This is the only thing left to making my computer run, aside from a weird issue with usb drives not being loaded...

Link to comment
Share on other sites

Update: Tried callisto 003, which mostly worked... it's now detected as what it is, ATI radeon 9600 pro, agp, etc. I am given a list of resolutions in the preferences pane, but I get the dreaded black screen when I try and select one! This is also what I see after I log in, unless I'm in safe mode. I think the major problem is that my monitor isn't being detected properly - it still says "Resolution: 1024x768, Refresh rate 60Hz". I used SwitchResX to get my EDID, and I pasted this with plistedit pro into the callisto.kext info.plist file. Is it possible my EDID is wrong? By the way, SwitchResX doesn't list the brand or anything, just says "CRT Monitor"... is there a particular Samsung driver that I need? (It's a Samsung 753DF).

Link to comment
Share on other sites

  • 3 months later...
Fixed! Callisto 006 solved the problem. Now if I can just get colour calibration to work...





and i have the same card and monitor with u....very glad to match this post~


u r using Callisto 006 in which version of the osx? 10.4.7 or 8? i got a crash in 10.4.8 by using c006~

Link to comment
Share on other sites


  • Create New...