Jump to content
magic77

VMware can't connect iPhone

5 posts in this topic

Recommended Posts

I'm using OSX 10.12 for Development purposes and need to have a iPhone 6 connected to the VM. But i' m running into issues.


My Host System is Ubuntu 17.04, VM Tools are installed, VMware Workstation 12 (latest Version)


 


This is what i have done:


  1. Start VM with OSX
  2. Plugin iPhone to USB
  3. Now VMware asks me to connect iPhone

This is what happens, after i plug in the iPhone


sAypp.jpg


 


Some moments later this Question appears 


5an9a.jpg


 


But still no iPhone available. Can somebody help me with this?


Share this post


Link to post
Share on other sites
Advertisement

It would help if you shared what Linux distro you're using as I can't tell you if this solution will fix things. Let me know. I'm assuming yours is some Debian variant.

 

Have just tried unmounting your iPhone from Nautilus right before attaching it to your VM? You should always try the basics first.

 

If you never plan on communicating with your iPhone on your Linux host machine and will just be doing it through your macOS VM then you can prevent usbmuxd from loading, which is what is preventing VMware from accessing the device. usbmuxd is a service specific to iOS devices in Linux. Run this in terminal: 

sudo touch /etc/udev/rules.d/39-usbmuxd.rules
sudo udevadm control --reload-rules
This blank file should prevent usbmuxd from launching when you plug in your iPhone from now on.

 

As for the second error, that's the Nautilus file manager automatically mounting your iPhone for photo access. If you don't care about that, you can run this:

sudo chmod a-x /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
that will take away executable permissions for all users so the next time it automatically tries to run it when you plug in your iPhone or any kind of camera plugged into USB, it will fail to mount. There is also an option in Nautlius gconf settings to disable automounting in general, but I think this is the easier way to do it.

 

To undo what you just did in case you want to re-enable it for whatever reason:

 

sudo rm /etc/udev/rules.d/39-usbmuxd.rules
sudo udevadm control --reload-rules
sudo chmod a+x /usr/lib/gvfs/gvfs-gphoto2-volume-monitor

Share this post


Link to post
Share on other sites

Hello nawcom,

you're right, i need the iPhone connection only for the VM.

Now my iPhone is shown in the List of the System Profiler under USB, with this Information

 

  Product ID:       0x12a8
  Vendor ID: 0x05ac  (Apple Inc.)
  Version: 7.02
  Serial Number:
  Speed: Up to 480 Mb/sec
  Manufacturer: Apple Inc.
  Location ID: 0x02100000 / 1
  Current Available (mA): 500
  Current Required (mA): 500
  Extra Operating Current (mA): 0
 
But when i start iTunes, there is no Device available. Is this a "Trust this Computer" Bug, maybe?

Share this post


Link to post
Share on other sites

Shut down the VM and under Virtual Machine Settings, Select the USB controller on the Hardware tab and there should be an option for USB compatibility. Set that to USB 2.0 and see if that makes a difference

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Giuseppe Biondo
      Running macOS Catalina in Windows10 with VMware 15.5
      The system runs perfectly with only one very important problem: the display type.
      In my PC is installed an Asus RX580 4GB but the virtual machine runs with a graphic card of 128MB of GPU ram.
      The resolution is OK, but graphic tasks are very slow.
      VMware Tools are installed.
      How can I fix this issue?
    • By JohnOl
      Hi,
       
      I've just upgraded to OSX Catalina from Mojave on my VMWare Workstation 15.5, running on Windows 10.
       
      The Sidecar feature is there, and after connecting my iPad Pro 12.9" 2018 running iPadOS 13.1.2 via USB cable, it is recognized as a display device in the Sidecar preferences.
       
      However, when I enable it, the Sidecar screen on the iPad is completely black / blank. I can't send anything over, and if I mouse over the green + on an app window (i.e. Safari) to move it to the iPad, nothing happens and the screen remains blank. The sidebar will only appear after I turn it off and on again at Catalina's Sidecar preferences. The buttons there actually work. For example, if I move Safari over to iPad, the screen is blank, but if I activate the on-screen virtual keyboard and type there, the text actually goes to the Safari's search bar (the Safari still appears on the desktop).
       
      Is this a compatibility issue with VMWare, where Catalina can't properly recognize the second screen? I've tried changing host VM settings too, i.e. to "host setting" or 2 monitors, enable / disable 3D acceleration, nothing works. the iPad is definitely correctly connected, as I can browse / backup its data at the Finder.
       
      Can anyone please advice on how to enable Sidecar properly in VMWare? Thank you.
       
      Below is a screenshot of how it looks like on my iPad:

    • By MSoK
      This is the current version of VMware Tools for OS X / macOS from the VMware CDS repository for Fusion 11.5.0
       
      VMware are no longer including the ISO images as separate "packages" in the CDS respository as of Fusion 11.5.0, instead the ISO images are included as part of the "core" download which is 522 MB.
      It is not possible to download the com.vmware.fusion.zip.tar due to upload limits.
       
      However, I have extracted the darwin.iso and darwinPre15.iso from the "core" and uploaded to this thread.
       
      If you prefer to download the "core" tar file and extract the ISO's they are located in the following directory in the tar file:
       
      com.vmware.fusion.zip.tar\com.vmware.fusion.zip\payload\VMware Fusion.app\Contents\Library\isoimages\
       
      Please note: In the latest VMwareGfx.kext from Fusion 8.5.5 onwards VMware have discontinued the 2D-Acceleration code, and graphics performance is better now, thanks to Zenith432 for the update.
       
      To check for the latest version visit http://softwareupdate.vmware.com/cds/vmw-desktop/fusion/.
       
      The various VMware Tools downloads are located under the packages folder for each version upto and including 11.1.0.
       
      Instructions for extracting darwin.iso and darwinPre15.iso
      - Download the files above
      - Extract com.vmware.fusion.tools.darwin.zip.tar
      - darwin.iso is located in the "payload" folder
      - Extract com.vmware.fusion.tools.darwinPre15.zip.tar
      - darwinPre15.iso is located in the "payload" folder
    • By cgilley
      Bear with me please, the vmware site is almost hopeless, so I ran across insanelymac.. So, I have a fairly high end laptop that has enabled me to push much of my development environment into virtual machines.  One of these VMs was a macOS High Sierra install.  As a developer, I always have an interest in learning new things, and some of my co-workers are Apple advocates.  Plus, there was some s/w I wanted to try that would only work on the mac.  Using unlocker, etc, I was easily able to create a Mac workstation (what the hell do you call this - mac, macos, apple, mac VM?  lol, I don't have the lingo down right....).  I've been using it for the last 4 months.
       
      Then came the VM Workstation 14.1.6 update.  It kept nagging at me, so I finally allowed it to install.  Brain fart on my part, I should have backed up all of my virtual machines.  All the Windows VMs came through fine, but the Mac is stuck in a perpetual re-boot cycle.  I'm sure this is a vmware issue, but I was hoping maybe a reader has seen this before and has some ideas.  I've gone through the vmware logs until my eyes bleed - lots of interesting but useless information...
       
      regards,
       
      cg
       

×