Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
fabiobh

Video travado em 1024x768 no Mac OS Sierra

18 posts in this topic

Recommended Posts

Oi pessoal,

 

consegui instalar o Mac OS Sierra em meu notebook, um HP Probook 4430s (i5, 8gb de ram, intel hd 3000)

 

 

Porém agora minha resolução está travada em 1024x768, essa é a única opção de resolução disponível.

 

 

Estou usando o Clover Legacy como bootloader, como posso corrigir esse problema?

Share this post


Link to post
Share on other sites

Instalei a última versão do Clover, o 4064 e usei o Clover Configurator para ativar o Inject Intel dentro de Graphics. Não funcionou. 

Share this post


Link to post
Share on other sites

Share this post


Link to post
Share on other sites

testa aí

remova a voodoohda, tenta usar o audio nativo

remova a nullcpupm tb

 

Substitui a pasta

CLOVER.zip

roda esse .command

Olarila.command.zip

reinicia e cruza os dedos

 

tenha sempre o usb bootável, até acertar tudo vc pode precisar dele algumas vezes

Share this post


Link to post
Share on other sites

Baixei a plasta CLOVER e substitui a minha.

Rodei o command que vc mandou, mas infelizmente não funcionou.

 

Nem consegui dar mais boot

 

Tirei foto da ultima imagem que aparece antes do PC reiniciar sozinho.

 

 

https://drive.google.com/open?id=0BznKjpjS9fAYVjJzeUg4NkUtbm8

 

Parece que foi um erro com o AppleIntelCPUManagamentPower.

 

O que devo fazer agora?

 

 

Que tipo de modificação vc fez com os arquivos que te mandei?

Share this post


Link to post
Share on other sites

Peguei a imagem pronta do Mac OS 10.12 pronta no site abaixo

http://olarila.com/forum/viewtopic.php?f=40&t=5817

 

Usei o Win32DikImager para colocar a imagem no pendrive e removi algumas kexts no pendrive que atrapalhavam na hora do boot

 

Coloquei a NullCPUPowerManagement.kext.zip na pasta Clover/kexts/other, agora o sistema deu boot, porém nada ainda de conseguir alterar a resolução do monitor.

Share this post


Link to post
Share on other sites

Coloque as kexts na pasta Clover/kexts/other e nada, ta do mesmo jeito.

Sera que vale a pena tentar fazer uma nova instalaçao do zero sem usar a imagem do site, ou seja, criar uma instalaçao a partir do Sierra baixado da AppStore?

Share this post


Link to post
Share on other sites

a imagem do olarila é limpa, adiciona só o essencial pra subir a install, vai dar no mesmo, mas o ideal é vc instalar o Clover e já substituir a pasta e usar a NullCPUPM tb

Share this post


Link to post
Share on other sites

Estava pensando, será que tentar dar o boot usando o chameleon pode dar um resultado melhor ?

Como você mesmo disse , o problema não parece ser a imagem do olaria, eu ouvi falar que o chameleon consegue ajustar esses parâmetros de video através da configuração do bootloader.

Share this post


Link to post
Share on other sites

Consegui fazer a tela funcionar com a resolução correta. Apesar de estar me sentindo um pouco bobo.

 

Estava fazendo umas pesquisas no site do olarila e vi um deles que tinha algumas kexts pra intel hd 3000, eu baixei e coloquei na pasta Clover/kexts/other e quando reiniciei tava funcionando perfeito.

 

Depois fui analisar novamente as kexts e vi que eram as mesmas que eu removi para poder fazer a instalação baseando-me neste site "http://olarila.com/forum/viewtopic.php?f=28&t=2193",removi as kexts pois a instalação iniciava com a tela toda bugada.

 

Só agora descobri que 3 destas kexts que eu removi precisavam ser recoladas para poder fazer o vídeo funcionar, vivendo e aprendendo né.

 

Valeu pela ajuda MaLd0n

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • What did you add exactly, i did inject the unsupported 100 series kext and did see my macOS partition. I couldn't boot at all. I still get an error from VoodooPS2Mouse i think here is an image: https://drive.google.com/open?id=1dkcoWh2ZXj56ketONkrV8x9TNOVJdXkf
    • @Slice what's te correct russian translation for "copy to clip board"?   .. I need also a translation for "log copied to clip board!"
    • Hello MaLd0n,   Could you please make DSDT edits for my new Skylake desktop Lenovo M910t    RunMe files: https://www96.zippyshare.com/v/5bgqAiga/file.html
        Thank you very much in advance!
    • Have you tried adjusting the Khz in midi pref pane or editing the info plist to suit your needs. that sometimes corrects weird noise behavior.
    • Hello Mald0n:

      Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

      As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

      However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

      Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

      p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!

      https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/   My system:
      Gigabyte GA-X48-DQ6
      Core 2 Extreme QX9650 C0
      4 x Kingston DDR2 800ghz Ram
      Galaxy GTX460 1GB
      120GB SSD Leven JS500120C, high Sierra installed
      250GB seagate ST3250310AS
      250GB WDC WD2500JS-08NCB1
      File: https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing      


×