Jump to content
Edkroket

X99-UD5-WIFI USB3 all working

10 posts in this topic

Recommended Posts

Hi,

 

I was struggling to get all my USB-3 ports running on the right speed and get rid of the portlimit patch.

Now I have it perfectly working and running on 10.12.3.

 

In my attachment I have the kext files, clover config files en SSDT for USB and the BIOS settings for F23C.

Remove any previous versions of USB injectors and SSDT files.

 

Install the kext in S/L/E

Use my config file for DSDT edits for EHCI and XHC

Use the BIOS settings as in my screenshots

And you should be good to go.

 

No need for port limit patch and waste unused ports and power.

Big thanks and credit goes to RehabMan. He made the kext and how-to.

I just did the job on my system.

 

I was thinking to share this because I know you are never alone with an issue. :-)

 

Ed

X99-UD5-WIFI-F23C.zip

Share this post


Link to post
Share on other sites
Advertisement

Hi,

 

I was struggling to get all my USB-3 ports running on the right speed and get rid of the portlimit patch.

Now I have it perfectly working and running on 10.12.3.

 

In my attachment I have the kext files, clover config files en SSDT for USB and the BIOS settings for F23C.

Remove any previous versions of USB injectors and SSDT files.

 

Install the kext in S/L/E

Use my config file for DSDT edits for EHCI and XHC

Use the BIOS settings as in my screenshots

And you should be good to go.

 

No need for port limit patch and waste unused ports and power.

Big thanks and credit goes to RehabMan. He made the kext and how-to.

I just did the job on my system.

 

I was thinking to share this because I know you are never alone with an issue. :-)

 

Ed

Just a heads up: If you've included any case specific USBs (for example, front panel/top panel USBs on your system's case and/or 3rd party USB devices), they may be incompatible/not be recognized for other users who have the same board, but a different set up!

Share this post


Link to post
Share on other sites

Just a heads up: If you've included any case specific USBs (for example, front panel/top panel USBs on your system's case and/or 3rd party USB devices), they may be incompatible/not be recognized for other users who have the same board, but a different set up!

You are right about that.

There are no 3rd party USB devices involved with this. USBInjectAll.kext is intended for Intel only.

USB-3 front motherboard connection is connected thru SSP01 and SSP02 This board has two connectors for USB3 front/top panel. I used the first one.

USB-2 front motherboard connection is connected thru HS13 and HS14. Also here I used the first one.

 

Anyway you can easily find your used ports when enabling portlimit patch and remove the USB SSDT.

Backpanel is for all boards the same so in worst case only the front panel ports would have an issue.

 

If any one has questions? Feel free to ask of course.

Share this post


Link to post
Share on other sites

AWESOME I just threw away my ASUS X99 Pro as it would crash all the time on El Cap. Swapped it with the Gigabyte X99-UD5-WIFI and used your files together with the BIOS version. System is stable and not any Kernel panic on boot (like before). I am thankful for your post! The X99 pack offered at rampagedev.com was just not working with my system, not sure why. Thank you so much!

 

What are you using your system for? Audio production or Video rendering if I may ask? Do you use After Effects a lot? Just curious.

Share this post


Link to post
Share on other sites

I don't use it anymore. But the systems I've build are ment to work with Video Editors.

Netherlands? Me Too?

 

Grappig dat we dan engels praten toch?

 

Cheers!

Share this post


Link to post
Share on other sites

If the international community benefits from it, why not? ;)

 

I built this machine for my girlfriend, who is doing animation and video editing on her machine. The previous system ran really instable and the computer would spontaneously reboot at times, especially when working inside After Effects (CS6 and CC 2017). I hope it will do its job nicely, now that everything is freshly installed and upgraded ;)

Share this post


Link to post
Share on other sites

OK, it happened again. My X99 Hackintosh crashed during work in After Effects (CS6 version). The mouse starts to jitter and then the computer sponaneously restarts. Googling this gave me something about the RAM voltages that might push the system over the edge. I am going to test that shortly!

Share this post


Link to post
Share on other sites

Hi indeed sometimes the RAM needs a bit more than 1.2 V.

Specially when overclocking. I had in many cases set it for both A en B slots to 1.25 or 1.26 V

Not sure what GPU you use but with the 980 TI I had also some more trouble. But in general these are fast machines and great to work with.

I've build a dozen of them for my customers. If you need Thunderbolt PCI-Card I still have a few of them.

 

Cheers!

Share this post


Link to post
Share on other sites

Hello,

 

I'm having trouble with my system, the usb are recognized as 2.0 instead of 3.0. 

My mobo is ga-x99-ud5 wifi.

 

 

You said something about screenshots, where can I find them?

 

Thanks in advance,

Regards from Mexico.

post-2385101-0-01540900-1516848076_thumb.jpg

Share this post


Link to post
Share on other sites

Hello,

 

I'm having trouble with my system, the usb are recognized as 2.0 instead of 3.0. 

My mobo is ga-x99-ud5 wifi.

 

 

You said something about screenshots, where can I find them?

 

Thanks in advance,

Regards from Mexico.

post ur full clover folder here, remove ur serials

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By Tushark2
      Hello,
      1st my laptop spec. 
      CPU - 2.53 GHz Intel Core i3 380m
      RAM - 6 GB 1333 MHz DDR3
      GPU -  1st gen Intel HD Graphics 288 MB
      Laptop - Dell Vostro 3500 series
      BT/WIFI - AzureWave BCM94352HMB
       
      I installed Olarila Mojave 10.14.6 and managed to install 1st gen intel HD graphics but it was bit laggy bcos this gnu doest support metal and its a old machine, so I decided to move to Olarila High Sierra.
      I installed it with most of things working fine expect some issues, for that I want to make SSDT and DSDT to make it run without glitches.
       
      I am atteching my sendme.zip , can some take a look to my current settings and suggest me some changes  
      (Olarila down from few days for me )
       
      Send me MacBook-Pro.zip
    • By Musicalchairs
      Hi Guys,
       
      First time poster

      Recently switched to OC from Clover where I had a Mald0n created DSDT in my patched folder
      Bringing Device Objects across via SSDT and after much trial and error had some success with SBUS children by editing this SSDT
      https://raw.githubusercontent.com/acidanthera/OpenCorePkg/master/Docs/AcpiSamples/SSDT-SBUS-MCHC.dsl

      Can anyone let me know what this (MKY0) actually does?

      SSDT-SBUS-MCHC+MKY0.aml
    • By Bazza08
      Hi Guys I have been trying to get my hackintosh to work using High Sierra... My Build is:--
       
      Asus Z87-K Mother board
      Intel i5 processor
      8 gig of Memory
      Nvidia Geforce GT 730 4gb DDR3 
      500gb SSD hard drive 
      I can get it up and running if I take Graphics card out and use Internal graphics, but when I have my graphics card in the only way I can get it to work is to use boot flag nv_disabe=1 .... and the graphics are rubbish..... I am trying to get it working by creating my own DSDT file..
       
      what I have tried is to download and used  RwPortableX64V1.7 to extract 4 SSDT.aml files and one DSDT.aml ... I was looking on this forum for any clues what to do next
      but I a am afraid I am stuck... I have uploaded the files I extracted from  RwPortableX64V1.7
       
      Any Help would be appreciated 
       
      Bazza
      DSDT.aml
      SSDT-1.aml
      SSDT-3.aml
      SSDT.aml
      SSDT-2.aml
    • By Aldaro
      Gigabyte, in their infinite wisdom, decided to remove the option to disable serial ports, and not being able to do so has been causing me some problems. I know that I have to either use a patch in clover, or create a custom SSDT to disable super I/O, but I honestly do not know how to go about doing this. One of the weirder problems I'm experiencing is the inability to connect to Apple Music (error 11556) unless I go into my network settings, and delete my serial connection. If anyone could help me out with this, that'd be greatly appreciated; anyway, thank you for taking the time to read this.
       
      SPECS:
      Mobo GIGABYTE Z390 M GAMING (UEFI F8)
      CPU: i5 9600k
      RAM: 32GB DDR4 @ 2666 Mhz
      GPU: AMD Radeon RX 580 w/ 8GB of VRAM (MSI armor oc edition)
      Storage Samsung 970 evo 500GB
×