Jump to content
Sign in to follow this  
Followers 0
ahedgehog

ASUS H97M-E Sleep Problem.

5 posts in this topic

Recommended Posts

Hi!, this is my first post on the forum... well, for a really strange reason, every time that i try to sleep my Hackintosh it wakes in 2 seconds or less with the next message from wake reason:

 

Wake Reason: Glan.

 

I'm trying to fix this, but this is giving me a frikin' headache.

 

DSDT.zip

Share this post


Link to post
Share on other sites
Advertisement

You probably need to patch your EHC1/EHC2 USB2.0 controller devices in a similar manner as the USB3.0 XHC device is:

           Method (_DSM, 4, NotSerialized)  // _DSM: Device-Specific Method
           {
               Store (Package ()
               {
                   // [...]
                   "AAPL,current-available", 
                   0x0834, 
                   "AAPL,current-extra", 
                   0x0A8C, 
                   "AAPL,current-in-sleep", 
                   0x03E8, 
                   "AAPL,current-extra-in-sleep", 
                   0x0834, 
                   "AAPL,max-port-current-in-sleep", 
                   0x0A8C, 
                   "AAPL,device-internal", 
                   0x02, 
                   Buffer (One)
                   {
                        0x00                                           
                   }
                }, Local0)
                DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                Return (Local0)
            }
        }

`

Then, you may have to play a little with _PRW methods of EHC1/EHC2, XHC, GLAN and possibly HDEF devices.
 
In your DSDT, all those methods return (0x0D, 0x04). You may have to replace that by other values ((0x0D, 0x03) or (0x0D, 0x00) or (0x09, 0x00) for instance) or entirely remove those _PRW methods. What SMBIOS do you use?

Share this post


Link to post
Share on other sites

Hi!, thaks a lot for the hand!, i had fixed it by renaming all _PRW 0x0D to 0x09!.

 

Now my machine sleeps perfectly, the only downside is that for waking the machine i have to press the power button.

 

 

Thanks a lot!

 

PD: the smbios that i use is IMac 14,2, because is the closest to my hardware config,

Share this post


Link to post
Share on other sites

Well, how else would you expect to wake your desktop computer? By keyboard or mouse? I guess that would require Wake on USB enabled in BIOS but this may prevent computer from going to sleep. Only one way to know...

Share this post


Link to post
Share on other sites

Well, it´s working perfect, so i don't care now for usb wake support.

 

Thanks a lot Hervé!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×