Jump to content
Sign in to follow this  
Followers 0
jackoloki

Is there any way to open or view contents of a notesexternalrecord file?

5 posts in this topic

Recommended Posts

I had a note in the Notes app synced via iCloud. It was titled "Hera Don't Hate Me". I have no memory of deleting this note, but it is no longer on my iPhone,  desktop, or iCloud.

 

I entered a phrase that I knew the note contained into Spotlight on my Yosemite desktop system... "succulence I had to taste". Spotlight revealed the note by name, "Hera Don't Hate Me" under TOP HIT, but it said the note was inside an External Notes Record, the path of which was deep inside com.apple.Notes Container in my User Library on another system drive (Mountain Lion).

 

The note obviously contains my writing—it wouldn't have shown up in Spotlight if it didn't—but when I try to open it in Notes, nothing comes in. The file can't be Imported into Notes, it's greyed out. I tried opening it with TextWrangler, but there didn't appear to be anything there but a plist header (see below*). I tried moving the file into the Notes Container on my Yosemite system, but that didn't seem to do anything. I tried booting from the Mountain Lion system to view it, but with no luck.

 

Does anybody know if there is any way to get at the actual information that this file contains (or points to?) Any help in retrieving my writing would be greatly appreciated.

 

Thanks,

rob

 

*

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict/>

</plist>

 

post-1091526-0-30585100-1471358424_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

181bytes...

 

-> I guess it's empty of anything else but that header you posted!

That's correct. And if I copy that text and paste/save into a text document, the resulting file is about 180 bytes. Which leads me to believe there is nothing in this file, and that this file points to another or has another pointing to it. Or something, I don't know. But my writing is somewhere, it turned up in the search. How can that be?

Share this post


Link to post
Share on other sites

Try that ML system you mentioned since the Notes file appear to be stored over there. it's clearly not in your iCloud storage...

Share this post


Link to post
Share on other sites

Try that ML system you mentioned since the Notes file appear to be stored over there. it's clearly not in your iCloud storage...

 

Well, that's a whole other thing. Both systems are hacks, and I have a new GPU which has a specific (to OS X build) NVIDIA web driver to get it to work. The last time I tried to boot off of the old ML system, I couldn't get new video card to work. I probably need to go and get the webdriver for that particular build, and I'm not sure what it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×