Jump to content
goldenmaterial

Clover Boot Menu - Choose default boot drive or volume with persistent option

4 posts in this topic

Recommended Posts

Yosemite on disk0 and Windows 10 on disk1. Clover always defaults to macOS, but I would like to auto-select Windows drive.

$ diskutil list
/dev/disk0
   #:                       TYPE NAME                    IDENTIFIER
   0:      GUID_partition_scheme                         disk0
   1:                        EFI EFI                     disk0s1
   2:                  Apple_HFS MacOS                   disk0s2
   3:                 Apple_Boot Recovery HD             disk0s3
/dev/disk1
   #:                       TYPE NAME                    IDENTIFIER
   0:      GUID_partition_scheme                         disk1
   1: DA94BAA4-05D1-4F40-A36A-CFD20114D2CC               disk1s1
   2:                        EFI NO NAME                 disk1s2
   3:         Microsoft Reserved                         disk1s3
   4:       Microsoft Basic Data Windows                 disk1s4

There's a screenshot of config.plist in disk0s1 which is the partition loaded by the BIOS I think.

 

2z4ijv6.jpg

Share this post


Link to post
Share on other sites
Advertisement

SOLVED, finally got default boot option working and in persistent mode, as I wanted it to be. To achieve that:

 

  1. Open Clover Configurator and open the EFI/CLOVER/config.plist from disk0s1 (clover will mount it at /Volumes/EFI).
  2. Then select Boot section
  3. Go to Default Boot Volume and enter there the Disk / Partition UUID of the Windows disk (not the volume uuid). In my case it was the UUID of the disk1s2.
  4. Now reboot to check.

To view all available disks, volumes and partition use the Terminal:

diskutil list

To get the Disk / Partition UUID use diskutil from Terminal (command line) on the partition that you want to auto-select to boot from:

diskutil info disk1s2

Then you will see Volume UUID and Disk / Partition UUID. In my case, since I wanted to load the Windows 10 UEFI partition, I chose the "Disk / Partition UUID". In other cases, it may work with the Volume UUID, not sure.

 

Example result:

 

2qius84.jpg

 

 

Alternatively, you can edit directly config.plist with some text editor. Personally I use the command "nano -w /Volumes/EFI/EFI/CLOVER/config.plist". You can install nano with macports.

        <key>Boot</key>
        <dict>
                <key>Arguments</key>
                <string>slide=0 dart=0 nvda_drv=1 kext-dev-mode=1</string>
                <key>Debug</key>
                <false/>
                <key>DefaultVolume</key>
                <string>C9EB9C41-9CF6-44F6-865D-298E803629DC</string>
                <key>Legacy</key>
                <string>LegacyBiosDefault</string>
                <key>NeverHibernate</key>
                <true/>
                <key>Secure</key>
                <false/>
                <key>Timeout</key>
                <integer>5</integer>
                <key>XMPDetection</key>
                <string>Yes</string>
        </dict>

$ diskutil info disk1s2
   Device Identifier:        disk1s2
   Device Node:              /dev/disk1s2
   Part of Whole:            disk1
   Device / Media Name:      EFI

   Volume Name:              Not applicable (no file system)

   Mounted:                  Not applicable (no file system)

   File System:              None

   Partition Type:           EFI
   OS Can Be Installed:      No
   Media Type:               Generic
   Protocol:                 SATA
   SMART Status:             Verified
   Volume UUID:              9AEC6502-794D-498B-9823-91DDEB031F8F
   Disk / Partition UUID:    C9EB9C41-9CF6-44F6-865D-298E803629DC

   Total Size:               104.9 MB (104857600 Bytes) (exactly 204800 512-Byte-Units)
   Volume Free Space:        Not applicable (no file system)
   Device Block Size:        512 Bytes

   Read-Only Media:          No
   Read-Only Volume:         Not applicable (no file system)
   Ejectable:                No

   Whole:                    No
   Internal:                 Yes
   Solid State:              Yes

Share this post


Link to post
Share on other sites

I solved this problem by going to Oracles mysql documentation on MySQL APT Repository which was a huge help, following all the instructions on the page allowed me to install mysql successfully.

Edited by iosman987

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×