Jump to content

Hi, I think I may need some help :(

Go to solution Solved by EclipseSin,
4 posts in this topic

Recommended Posts

I don't really like posting for help with this kind of stuff because I like to mess around, learn, maybe even figure out some new stuff, but I can't even get El Capitan's installer running. Hell, I'm not even sure if I should post this in the dev forum or not, haha. Sorry if not.

Hardware is in my signature.


Anywho, I used the application over here to create an El Capitan installer partition on the beginning of one of my hard drives, fresh formatted using MBR. I used Vmware 12 without the unlocker thing inside yosemite. The application itself wouldn't run because it said I was missing grep...... so I extracted the packages from the app and things seem to go smooth enough using my manual partitioning.

I applied the MBR installer patch I found on this site in the download section for 10.11.0 (the version image I have) dated Sep. 30 2015.

I have the USB issue seen here

but I have just read about a USB Fix in this section I will be trying. Disabling USB2.0 also works, and I'd imagine patching DSDT would as well. I tried by letting maciasl fix the errors itself instead of manually doing it (worked for yosemite, lazyness +1) and then applying the USB1 to EHC1 (or was it EH01? icr atm), but that doesn't seem to be the case here as I end up with an ACPI error with my aml.


I am currently using Shaneee 10.11.x RC2 kernel and the following kexts, in Extra/Extensions.


  • AHCIPortInjector.kext
  • AppleACPIPlatform.kext
  • AppleACPIPS2Nub.kext
  • AppleATIAT.kext
  • ApplePCIIDE.kext
  • ApplePCIIDE64.kext
  • ApplePS2Controller.kext
  • AppleVIAATA.kext
  • ATAPortInjector.kext
  • Disabler.kext
  • FakeSMC.kext
  • GenericUSBXHCI.kext
  • IOAHCIBlockStorageInjector.kext
  • JMicronATA.kext
  • lspcidrv.kext
  • NullCPUPowerManagement.kext
  • Patched_10.7_AppleRTC.kext
  • RealtekRTL8111.kext
  • VoodooPS2Controller.kext
  • VodooPState.kext
  • WifiInjector.kext

After getting past the USB problem, I'm now stuck with hfs verylowdisk problem, and I'm not sure what to do. Just sits there. Tried every flag I could think of (-v -f busratio cpus=1 dart=0 ahcidisk=1 debug=8 -x npci=0x2/3000, PCIRootUID=0/1, GraphicsEnabler=Yes/No, different kexts for SATA/AHCI.... Suggestions? More kexts or edits?


I have attached my kernel.plist, org.chameleon.Boot.plist, and SMBios.plist. I also included my DSDT if anyone would want to try and help me out with that. I understand the patching, but I dont understand how to fix the Errors mine has, even after reading the guide. Lol


Thanks in advance for suggestions. I have had Yosemite running on this same setup, just could never get DVI or HDMI Audio to work from my GPU and the Framebuffer still had problems at that time, hell might still lol)

Let me know if I forgot any info you might you need, and sorry again if I'm posting this the wrong place. Been at this for like 9 hours or more now. Off to bed, thanks again, have a good day everyone.



  • Solution

Ok well, that efi file doesn't exist for me that I had seen but, I went ahead and just made the disk gpt and started over. I spent some time finding kexts that work for my hardware so my extra folder is slightly different from before.


Anywho, I have managed to get El Capitan installed, booted into windows and applied the patches to the OS partition for USB fix, the kernel, etc.


I seem to have one more problem left, which happened once when trying to install but removing my other monitor and using AtiPorts=1 seemed to work, but it's not working to boot up the OS after install.


When it boot's up, I get a blank white screen without apple logo. I'd post a SS, but it'd just be a blank white box, it's after verbose output. I believe it's a graphics issue. If I let it sit long enough ( about a 20sec to a minute? ), it will output garbled {censored} all over the screen, usually with a black vertical line in the middle of the screen. No kernel panic though.

I have an XFX 7770 GPU, should I edit one of the kexts ( AMDRadeonX4000.kext? ) to fix this issue? I also found another kext called Verde.kext?

Thanks for the help, think it's the only thing I need to figure out yet.


Using the same kernel as before using Enoch with the following boot args: GraphicsEnabler=No AtiPorts=1 npci=0x2000 -v


Editing the kext worked fine. Now for audio. Does OSX support audio over DVI or do I need to use an HDMI port? Card itself supports it, at least in Winblows.

So, I'm assuming no one is going to help me, so can someone just tell me is DVI Audio is possible on OSX? And don't tell me DVI to HDMI doesn't support audio either because it does.

PS> HDMI/DP Audio is already working

  • Create New...