Jump to content

Native SSD on mac pro 5,1 OS X El Capitan.

5 posts in this topic

Recommended Posts




I am on a mac pro 5,1 under OS X El Capitan 10.11.4 recently I had installed can Angelbird SSD that didn't required any third party software to function, the SSD was recognized as a native mac pro disk, I have a Crucial MX100 SSD that I want to install also, but the Crucial MX100 will work natively as the Angelbird SSD, can anyone please provide information on how can I use the Crucial MX100 SSD safely along the Angelbird SSD?.



Thanks in advance. 

Share this post

Link to post
Share on other sites


It'll work as fine as the other one, what I mean is that the system will detect it and you'll be able to store data on it. However, the only thing that may not be supported is the TRIM support, but you can easily check that in Apple menu -> about this mac -> system report -> SATA/SATA ... -> select the Crucial MX100 SSD and look below there will be a line saying TRIM support = YES or NO.

You can find more information about SSDs following the link below.



Share this post

Link to post
Share on other sites

Apple include a tool called trimforce to enable trim on third-party SSDs, so it's possible to enable it for SSDs like this Crucial one.

Hello there,



Thanks for your time and help, so, if I use "Trim force" the SSD will work fine and I avoid the use of third party software like Trim enabler?. Would you please explain the procedure to enable Trim force?.





Share this post

Link to post
Share on other sites

Just open Terminal and type: sudo trimforce enable


Then reboot and check your SSD in System Profiler. You'll see that trim is now enabled.


I just remembered that certain SSDs had potential issues with trim on Linux and there was some concern that this would also apply to OS X. I don't know how that ended up as my older Crucial M4 wasn't on the list and works fine with trim enabled. Your MX100 is on this list so I guess you could enable it and see how things go. If you find you're having issues just run sudo trimforce disable to revert.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.