Jump to content

(solucionado) no puedo iniciar sin el bootlag nv_disable=1


7 posts in this topic

Recommended Posts

que onda gente!

 

hasta el dia de hoy he podido instalar hackintosh Os X Maverics distribucion Niresh y hacerlo 100% funcional y hasta sincronizado con windows 10 y Linux Mint 13 y a pesar de que no pueda ocuapar los programas mas nuevos de momento me habia conformado, pero ahora que a mi taller de reparación de computadoras me han llegado equipos Mac; me han pedido instalarles algunos programas o resolverles algun problema por lo tanto tengo que mudarme a Yosemite pero como todo novato he tenido problemas y el principal es que con la tarjeta de video.

 

 

par juegos, diseño y edición tenia una nvidia gt520 y funcionaba emn perfecta armonia con Hackintosh pero para poder usar programas nuevos y pesados adquiri una Gigabyte Gv-n740d5oc-2gi Gt 740 2gb Ddr5. En maverics tenia el problema de que durante el arranque toda la panatlla se ponia en negro y lo resolvi poniendo el bootlag "graphicsenabler=no" y ahora en Yosemite tengo el mismo problema pero ahora con ese bootlag sno se resuelve el problema si no con el bootlag "nv_disable=1" y como ya saben muchos no carga no utiliza el driver grafico lo que hace  muy dificil utilizar Yosemite.

 

Ya descargue el webdriver de nvidia, de hecho baje varios para la version 10.10.1 y de pura suerte le atine a uno y se dejo instalar pero el problema seguía a pesar de que Yosemite me reconocía la tarjeta grafica.

 

alguna idea de como resolver este problema?

hola. gracias por responder.

 

- la distribucion que uso para yosemite es Niresh ya que niresh en maverics me funciono crei que en Yosemite seria igual

http://www.hackintosh.zone/file/810-nireshs-yosemite-with-amd-intel-iso-usb/nop se si eso sea el problema

 - este es mi board:

tarjeta madre: Asrock H61M-VG3 
procesador: intel core i3 3.10GHz, 2100 sandy bridge, Socket: 1155 lga 
Motherboard Chipset: Intel H61 (Cougar Point) 
Memoria Ram: 8 gb DDR3, 532.1 MHz 
Tarjeta de video pci-express: Video Chipset: NVIDIA GeForce GT 740 Video Chipset Codename: GK107 Video Memory: 2048 MBytes of GDDR5 SDRAM [Elpida]

 

Adaptador de sonido: Intel Cougar Point PCH - High Definition Audio Controller [ B3 ], RealTek ALC662 
Adaptador de sonido de la tarjeta nvidia: NVIDIA GK107 - High Definition Audio Controller 
adaptador de red: RealTek Semiconductor RTL8168/8111 PCI-E Gigabit Ethernet NIC 

 

que por cierto baje unos kext del audio y de red alambrica y los instale mediante kextswizard y no funcionan

 

- por favor podrian darme el link al paquete de webdrive de mi tarjeta he bajado muchos paquetes pero borre el que funciono y no recuerdo cual era

- use los bootlags que me dieron y lo puse en el bootlag de chameleon en especial el "nvda_drv=1" pero aun se ponia pantalla negra antes del login

- no uso DVI uso aun la salida VGA no he provado hackintosh con DVI y HDMI

- este error me ha paso muy seguido cuando reinicio el CPU cuando me pone la panatalla negra pongo me pone la pantalla negra o se desconecta el video no estoy seguro de lo que pasa ahi

OPz1XHH.jpg

y de ahi se queda indefinidamente asi que tengo que reiniciar y nuevamente mesale ese mensaje y se soluciona formateando y reinstalando de nuevo el sistema osea tengo que tener cuindado de que jamas se me salga pantalla negra no se si exista otra solucion

- al volver a formatear y formatear use una smbios distinta use la 5.2 y la 3.1 en diferentes formateos y dio el mismo resultado

dejo adjunto los archivos de smbios y chameleon sin editar tambien dejo los links a los kexts que utilizo para la red y el audio ya que no se si sean los correctos para mi board

 

https://drive.google.com/open?id=0BxspwBIkD3ySc1VCa3ZvbmwyUkk

org.chameleon.Boot.txt

smbios.txt

hola creo que hay una leve confusión pensé que me habías dicho que la tarjeta era la 740 o algo así , yo recuerdo que la 210 subia con graphicsenabler=yes pero no era compatible con web drivers , aunque la 610 también subia pero cuando uno instalaba los web drivers el sistema tiraba kernel panic , ósea que esas tarjeta lo mas que se le puede hacer es ponerle graphicsenabler=yes y no instalarle los web driver , de la 650 para arriba se le podía instalar los web drivers sin problema por eso fue que te dije que la 740 funcionaba pero si es la 520 pues ya no estoy muy seguro que los web drivers funcionen ,pero quien sabe de alla para acá quizás haya cambiado algo y puede que sirvan. solo tienes que ponerle graphicsenabler=yes y probar , también en esos distros hay unas opciones y unos parchos en la sección de video que te pueden ayudar y también te pueden dañar la instalación , como hace tiempo que los deje de usar pues ya no me recuerdo bien , lo mejor seria que trataras de aprender la instalación vanilla es la mejor pero es un poco complicado si estas todavía aprendiendo , cree me yo se que son los flags y las opciones del distro , otra cosa es que aquí en este foro no dejan que uno hable de eso y tampoco dan support a los distros, tiene que ver con las reglas , yo tenia apuntando esos setups pero los borre después que los deje de usar , yo te puedo ayudar a que instales usando la imagen bajada de apple , el problema es que apple retiro la imagen de yosemite del app store . lo mejor es cuando vas a instalar la primera vez no instales audio ni lan , eso lo instalas después que el sistema suba a ver si es que uno de esos paquetes de instalación te da algún problema y después no te deja subir , creo que ya recordé algo bien importante , que version es la que estas usando la 10.10 la primer a o la 10.10.1 bueno el problema es que la primera tenia unos kernels parchados y después en la segunda los quitaron y no pusieron otros que eran necesarios y entonces al final de la instalación en vez de uno dar restart pues uno tenia que copiar el kernel parchado a la instalación , especialmente con los cpus nuevos , no quiero complicar muchos las cosas pero si tuvieras la version 10.10.5 de yosemite genuina o cualquiera original después de la 10.10.1 pues no tienes el problema de el kernel porque ya el kernel genuino trae support para eso cpus nuevos , bueno voy a ver los files , aquí mismo en este forum esta la version de chameleon 2468 si puedes bajada también hay unas opciones en os bios que tiene que estar bien configuras para que el sistema suba sin problemas , pero eso que te sale a ti a mi también antes me salía y es el ditro , después que cambie a imágenes genuinas de apple jamas y nunca me volvió a salir. suerte

 

bueno yo tenia un vecino con una tarjeta media bajita y no podia logear a yosemite porque usaba el vga pero cuando cambio a hdmi entro sin problemas , creo que una ves salio una noticia de eso como que ya los sistema de apple no iban a ser compatibles con vga o daban problemas con tarjeta viejas o low end a atra vez del vga y eso si no me equivoco fue empezando en yosemite , tu tarjeta el vga tiene un cablecito pequeño color gris , si si pues es low end y lo mas seguro eso sea un problema , por eso es que todas las tarjeta de ahora lo que traen es display port hdmi dvi-i dvd-d y no traen vga a menos que sean low end.

 

te voy a enviar un mensaje privado mañana , ya hoy no tengo tiempo estoy un poco tarde y ya tengo que salir , pero te voy a ayudar a que puedas instalar el 10.5 con la imagen genuina de apple , para que veas la diferencia en la velocidad del sistema

 

para darte el link del web driver tienes que darme la version del sistema. quizás el vga no es compatible en yosemite o la tarjeta completa.

no, si es gt 740 lo que pasa es que copie y pegue las caracteristicas de mi board de un archivo viejo de cuando tenia la gt 520, pero ya lo edite tambien vi que el vinculo hacia los kexts estaba en privado y ya lo hice publico.

 

mira queria el yosemite ya que tiempo atras hablaban maravillas de el y no queria instalar el capitan porque pide muchos recursos. Pero si con eso me ahorro problemas.

 

 

como vez?

 

una vez mas gracias por responder y tan rapido  :)

escribi mal el modelo otra vez no es 780 es 740 (donde tengo la cabeza)

los drivers de red y audio los volvi a buscar y los instale con el kextwizard y no habia visto el paquete que habias creado de kexts y chamelon plst si no los habria usado, aun asi gracias. ahora funnciona de maravilla al 100% sin ningun defecto, pero resulta que al alcutizar a la version 10.10.5 al arracar me sale esta pantalla, parece un panic kernel:

 

gfiQEXY.jpg

 

asi que use el bootlag -v para ver con mas aqui el screen

 

v8uI7jq.jpg

 

te volveria agradecer si me ayudaras a saber porque sucedio esto y como se podria arreglar

te hiba a hablar de eso yo se lo que es , mira la foto que me enviaste appletymcedriver , yo tengo el tool para eso pero no sabia si era necesario o no y en verdad no te quería enredar diciéndote muchas cosas , menos todavía si quizás eran inecesarais y no las necesitabas , también me di de cuenta de el # de la tarjeta , bueno te envío el tool pero me imagino que tienes un disco extra verdad , te acuerdas lo que te dije de el backup de emergencia , bueno deja buscar el tool para subirlo y decirte como es , tranquilo es super fácil , dame un par de minutos en lo que preparo todo

si me acuerdo pero no lo hice ya que no tenia otro disco y las particiones nfs+ no me permite reducirlas con el gparted, paragon u otra herramienta para particionar y crear una de rescate.

Debo volver a reinstalar todo desde el pincipio?

Hola

 

fijate, veo le que invertiste mucho tiempo en ayudarme haciendo los tutoriales y ese video unicamente para mi caso y no es que sea desagradecido, pero si de todas a formas voy a instalar un segundo yosemite para arreglar el primero, creo que seria mas practico volver a instalar el yosemite ya que no tengo absolutamente nada instalado mas que la actualizacion y los kexts por lo cual reinstalar todo solo me tomaria unos minutos. Una vez instalado el yosemite limpio 10.1 no le hago nada solo un backup con Acronis (hace lo mismo que el Carbon Copy cloner pero desde DOS) y despues le instalo solo el kexts que me enviaste del Lan para hacer todas la actualizaciones hasta el 2016, si falla restauro el backup y ya cuando este listo con, actualizaciones, bootlags y kexts hago otro backup del sistema para no repetir todo

como vez?

 

segunda opcion

si la herramienta que me pasaste solo borra algunos archivos del sistema que provocan el panic kernel, ¿serviria si los borro manualmente esos archivos desde otro sistema? en  windows y linux puedo leer y escribir en la particion de mac que tiene la actualizacion 10.5

 

Espero tu respuesta

 

PD: hay me haces la cuenta de lo que te debo por la asesoria ya que te has molestado mucho

veo que se borraron unos mensajes incluso uno mio donde estaba la solucion.

 

lo volvere a poner para ver si alguien le sirve:

 

 

 

que flags estas usando para arrancar el sistema , todo depende de la configuración que tengas en el bootloader , si la tarjeta no soporta web driver pues entonces tienes que usar graphicsenabler=yes pero para mi el problema es el distro porque esos distros tienen un montón de flags que puede que no son los flags que lleva tu sistema como tal y al tener andados causan problemas , ok mi suegerencia no importa si instalastes los web drivers porque el problema es si escoges web drivers pero si lo dejas en os default graphic driver pues quizás no te de problemas aunque tengas el web driver instalado , el que el va a usar el genérico de apple el problema es que si la tarjeta no tiene soporte genérico pues no va a funcionar y vas a tener que usar el web driver , a resumidas cuentas sino es compatible con ninguno de los 2 pues hay esta el problema , yo he probado muchas y de las mas baratas y económicas que sirven son de la 610 para arriba por ultimo trata estos flags en el bootloader
-v npci=0x2000 nv_disable=1 pcirootuid=1

ok cuando suba el sistema tienes que ir y entrar al disco duro ir al folder de extra y abrir chameleon boot plist con text edit y verifica si tiene este flag
nvda_drv=1
  • Like 1
×
×
  • Create New...