Jump to content
miliuco

OS X 10.11 El Capitan en placa P55-USB3 usando Clover

1 post in this topic

Recommended Posts

OS X 10.11 El Capitan en placa P55-USB3 usando Clover

 

Introducción

 

La placa base Gigabyte P55-USB3 (y algunas otras de la misma marca con chipset P55 / H55) facilitaron el montaje de un hackintosh y la instalación de OS X  desde la versión 10.6 Snow Leopard hasta la 10.9 Mavericks utilizando  gestores de arranque que emulaban a un Mac real ante el sistema operativo:

  • al principio PC-EFi de netkas, basado en BOOT-132 de David Elliot
  • Chameleon de Voodoo Team (ErmaCKabyl, Tamás Kosárszky, JrCsvalvSlice y otros), muy utilizado, existieron varias versiones creadas por diferentes programadores
  • Chimera de MacMan para unificar las distintas versiones de Chameleon; Chimera siempre ha estado asociado a la web de tonymacx86.

La inyección de código ACPI (Advanced Configuration and Power Interface) mediante DSDT (Differentiated System Description Table) mejoró enormemente la instalación de OS X en los hackintosh. Usando Chameleon / Chimera + DSDT ha sido relativamente fácil utilizar los sistemas operativos de Apple en mi PC (placa P55-USB3 + procesador i5 750 + Geforce 750 GTX) hasta la aparición de la versión 10.10 Yosemite cuya instalación requería mucho esfuerzo por la dificultad de gestionar el arranque del nuevo sistema operativo cuyas modificaciones lo hacían menos compatible con mi equipo.

Un grupo de programadores iniciado por Slice publicó un nuevo gestor de arranque llamado Clover con numerosas ventajas sobre los anteriores, entre ellas la de ser compatible con los nuevos sistemas 10.10 y 10.11. Actualmente es lo suficentemente maduro y fácil de instalar para que quien tenga algunos conocimientos del mundo hackintosh se atreva a probarlo consultando documentación existente en Internet.

He probado a instalar El Capitan en mi PC utilizando Clover como gestor de arranque, con DSDT. A continuación se explica el método empleado.
 

Requisitos previos

  • hackintosh o Mac con 10.9 o 10.10
  • segundo disco duro para instalar 10.11 sin perder la instalación previa de OS X
  • la aplicación “Instalar OS X El Capitan” en la carpeta /Aplicaciones
  • una memoria USB de al menos 16gb preparada desde Utilidad de Discos con esquema de particiones MBR y formateada como Mac Os Plus con registro (en placas Gigabyte como la mía, las memorias USB particionadas con esquema GUID en vez de MBR suelen colgar el sistema al arrancar)
  • utilidad de creación de USB de arranque para instalar OS X de tonymacx86 (utilidad en adelante).

USB de arranque para instalar OS X 11.11
 

Se emplea la utilidad para crear el USB de arranque. Sólo funciona en sistemas con idioma en inglés por lo que hay que cambiarlo en Preferencias del Sistema > Idioma y Región. Al cerrar las preferencias, un diálogo avisa de que es necesario reiniciar pero sólo con cerrar la sesión es suficiente. Después de crear el USB puedes volver a poner el sistema en tu idioma.
 

Las opciones de la utilidad son pocas y sencillas de elegir: en Destination Select elige la memoria USB, en Select OS Installation elige OS X El Capitan, en Bootloader Options elige Legacy Boot Mode y en Graphics Configuration no marques ninguna opción.

 

Al finalizar la creación del USB es conveniente mostrar los archivos ocultos, para ello desde Terminal:

defaults write com.apple.finder AppleShowAllFiles YES;killall Finder

Más tarde podemos volver a ocultarlos con el comando:

defaults write com.apple.finder AppleShowAllFiles NO;killall Finder
 

Con este método se instala Clover en la memoria USB con un archivo config.plist genérico, se localiza en EFI/CLOVER/. Este tipo de archivos se pueden editar fácilmente de forma gráfica con la utilidad Clover Configurator. Los detalles principales para mi PC son:

  • MacPro3,1 en la pestaña SMBIOS
  • algunos parches para inyectar en la pestaña Acpi
  • sin inyección de ningún tipo en la pestaña Graphics
  • nv_disable=1 y dev-kext-mode=1 en la pestaña Boot (no marques nvda_drv=1).

También he copiado mi DSDT.aml dentro del USB en la carpeta
EFI/CLOVER/ACPI/patched/
que es el lugar en que Clover busca los archivos DSDT.
 

Además es necesario copiar unas pocas extensiones en la carpeta EFI/CLOVER/kexts/10.11/ (si no existe hay que crearla), básicamente son 2, FakeSMC.kext y NullCPUPowerManagement.kext, aunque yo aprovecho para copiar también RealtekRTL8111.kext que es la apropiada para mi tarjeta de red integrada (chip RTL8111E).
 

Instalación de OS X 10.11 El Capitan desde USB
 

Reinicia el PC desde la memoria USB, se muestra el menú de Clover, elige el dispositivo USB y arranca desde ahí. Transcurre bastante tiempo hasta que se muestra la pantalla del programa de instalación de OS X 10.11. Una vez en el programa de instalación, abre el menú Utilidades > Utilidad de Discos y crea la partición en el disco duro, con esquema GUID y formato “Mac OS Plus con registro”. Cierra Utilidad de Discos e instala el sistema operativo en el disco recién particionado. Al terminar hay que reiniciar de nuevo desde el USB pero en el menú de Clover elige esta vez el disco con OS X 10.11 recién instalado.
 

OS X 10.11 El Capitan

acercade-750.png?w=1164

Si todo ha ido bien, has entrado en el escritorio de El Capitan después de la configuración inicial. Ahora has de hacer que este disco duro sea arrancable sin necesidad de usar el USB y ajustar algunas cosas, la aceleración gráfica entre ellas ya que el sistema arranca  con una resolución de pantalla básica.
 

1.- Instalar Clover en el disco duro
Instala Clover en el disco duro: existen varios paquetes accesibles por Internet, yo he usado el que viene incluido en el paquete “El Capitan Post-Install Tools” que contiene:

  • varios paquetes para instalar Clover, en mi PC he usado el que se llama “Clover_v2.3k_r3320-Legacy”
  • “CustoMac Essentials” instala en /Library/Extensions (observa que no es en la ruta /System/Library/Extensions) las extensiones básicas FakeSMC.kext, AppleIntelE1000e.kext, AtherosE2200Ethernet.kext y RealtekRTL8111.kext).

2.- Configurar Clover
Modifica el archivo config.plist situado en /EFI/CLOVER/ y ajústalo para tu sistema. El que yo empleo es éste.
 

3.- DSDT.aml
Puedes usar el DSDT que usabas con versiones anteriores de OS X o descargar el adecuado para tu placa base y versión de BIOS desde la base de datos; hay que copiarlo a la carpeta /EFI/CLOVER/ACPI/patched/.
 

4.- Tarjeta gráfica Geforce 750 GTX
Tiene su propio artículo que puedes consultar aquí.
 

5.- Partición EFI
En ocasiones, al modificar la configuración de Clover con Clover Configurator y reiniciar se observa que no se han guardado los cambios y que arranca como si no se hubiese cambiado el archivo config.plist.
Aquí es necesario explicar que el disco duro en el que se instala El Capitan tiene una partición que por defecto suele estar oculta llamada EFI. En esta partición de formato FAT32 existe una carpeta EFI que tiene algunas subcarpetas similares a las de la carpeta EFI de la partición con OS X. En concreto interesan la subcarpeta CLOVER que contiene un archivo config.plist y dentro de ella la subcarpeta ACPI/Patched para el archvio DSDT.aml.
Mostrar la partición EFI es sencillo con Clover Configurator que tiene en el lado izquierdo un menu “Mount EFI” que monta esta partición para que aparezca en el Escritorio.
 

mount-efi.png?w=310&h=624
 

De lo que se trata es de que los archivos config.plist (obligatorio) y DSDT.aml (opcional) de ambas particiones (EFI y OS X) sean idénticos y estén en sus carpetas correspondientes, de esta forma se guardan bien los cambios de configuración de Clover.

Si con ello no es suficiente para que los cambios en Clover tengan efecto, puedes activar la opción “No Caches” en Clover Configurator en la sección “System Parameters“:
 

caches.png?w=1164
 

6.- Tarjeta Ethernet
La tarjeta de red Realtek RTL8111E funciona perfectamente con la extensión RealtekRTL8111.kext.

realtek.png?w=1164

7.- Sonido USB y ALC892
En el hackintosh utilizo desde hace tiempo unos altavoces externos que se conectan por bluetooth a un emisor conectado a un puerto USB por lo que tengo sonido sin realizar ningún otro ajuste.

Cualquier dispositivo de sonido por puerto USB debería funcionar sin problemas en OS X, o bien un dispositivo USB al que conectar altavoces por minijack o bien altavoces de los que obtienen la alimentación y el sonido por un puerto USB.

Esta placa lleva el chip de audio ALC892, menos compatible que el chip ALC889, yo no he conseguido hacerlo funcionar bien en El Capitan a pesar de haber probado varios métodos: "CloverALC110_script.zip", se trata de un script de bash preparado por toleda y otros; AppleHDA Patcher del usuario Mirone; incluso he probado el método propuesto por el fabricante de las placas base QUO que llevan este chip de audio , etc.

 

8.- Puertos USB
Si tienes problemas con los puertos USB, puede ser que el uso de un hub USB (alimentado por corriente o no) en uno de los  puertos USB que funcionan bien sea una solución ya que por lo general todos los puertos del hub funcionan perfectamente. Los puertos USB3 funcionan como USB2.

usb.png?w=1164

Conclusiones
 

En mi PC OS X Mavericks funciona perfectamente pero las ganas de probar algo nuevo y el desafío de volver a contactar con el mundo hackintosh me han llevado a comprobar que OS X 10.11 también se puede instalar y usar en este hardware aunque requiere claramente más esfuerzo y se pierden algunas funciones de gestión y ahorro de energía. A cambio se prueba la versión más moderna del sistema operativo de Apple y se pueden usar programas incompatibles con Mavericks como Office 2016 por ejemplo.

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By kingoffright
      Dear all,
       
      I have a external harddisk about 500GB, I installed the clover into it and the harddisk is GPT format, below is the 3 partitions details:
      FS01: EFI - disk0s1 - fat32
      FS02: install mac  image - disk0s2 -  hfs+
      FS03: install windows 10 - disk0s3 - fat32
       
      I can use this external harddisk to install Mac without issue, I use below steps to install windows 10
      enter the FS03:
      cd to efi/boot/ and excuete bootx64.efi
      after pop up the windows install screen, i click next and it shows error 'A media driver your computer needs is missing...' and the installation can not go any further.
      Firstly I use ultraiso to write the windows 10 image to a flash disk and no issue to start install window 10 so the image is working fine. Since I dont know how to write
      a wiindow installation image into harddisk partition, I used winrar extra all the files into disk0s3, am I missing some steps or actually clover not support to install windows
      by partitions, apprecating any helps.
       
    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15.1
      This post will no longer updated, go for the osxlatitude link for further updates
      Original and updated link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      On Catalina the System folder is read-only, so you need to remount in rw to modify System/Library. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.11.03: Enabled SIP caused a lots of issues so now it's disabled -> updated bootpack
      2019.11.02: Updated to 10.15.1 -> no problem when/after installing
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By Cwtf
      I just made a clean install of High Sierra on a 1TB crucial ssd. Installed clover Clover_v2.5k_r5070 into the EFI of this ssd, but when I tried to make it my default boot drive, the clover screen wouldn't come up, and left a black screen.
      I tried using the Olarilia usb drive and clover did the same thing.  The only way I can currently boot is to use my old drive with clover v2.4k_4945 then select  my new drive from the clover menu.   
       
      Do I need to install v2.4k on my new drive or is there a way I can get v2.5k working?
       
      I have a GA-x79-ud5 motherboard, AMD  rx580 graphics card and use a Sony 4k tv as my monitor.
    • By kylon
      Cloud Clover Editor is an open source application that allows you to manage the configuration of various Hackintosh Bootloaders.

      Open Cloud Clover Editor
       
      Cloud Clover Editor Wiki
      Cloud Clover Editor Sources
       
       
      Features
      Supports Clover EFI, Ozmosis, Chameleon, OpenCore GUI and Text Editor Mode CCE Bank Mobile friendly and more...  
      Officially supported browsers
      Chrome 42+ Microsoft Edge 14+ Firefox 39+ Safari 10+ Opera 29+ Opera Mobile 12+ Chrome for Android 75+ Firefox for Android 67+  
       
      Credits
      mackie100 - took some ideas from his app Clover EFI dev team Eric Slivka - new serial number Virtual1 - new serial number cecekpawon - PHP 5.3.3 patch, , help with the ACPI Loader Mode flag and more Micky1979 - Clover flying editor  (Discontinued) crusher. - Help with the ACPI Loader Mode flag Download-Fritz - Help with the ACPI Loader Mode flag Pavo - Ozmosis fields and values stehor - Ozmosis fields and values Sherlocks - General help and support gujiangjiang - General help and support  
      Please let me know if i forgot you!
    • By fusion71au
      Clover r5101 ISO compiled with GCC and minimal config.plist compatible for use in VMWare Workstation.
       
      Tested with unlocked Workstation 15 running OSX 10.9 -->10.15 guest in Windows X64 host.
       
      Installation
      1. Download and unzip "EFI_Clover_r5101 for VMware.zip". Mount Clover-v2.5k-5101-X64.iso by double clicking on it.
      2. Mount your VM's EFI System Partition eg in terminal
      sudo diskutil mount disk0s1   3. Copy EFI folder from step 1 into the EFI partition
      4. Shutdown the VM, add bios.bootDelay = "3000" to your VM's vmx file
      5. Reboot your VM, press <F2> to access the VMware Boot Manager and add CLOVERX64.efi to the boot menu.
       
      Substitute your own unique and valid MLB and ROM variables in the /EFI/CLOVER/config.plist (Rt Variables section) to activate iMessage/Facetime on your VM.
×