Jump to content
Renard45

P5WDH deluxe sous El capitan fonctionnel!

32 posts in this topic

Recommended Posts

El Capitan enfin fonctionnel :thumbsup_anim: , il reste quelques petits bugs à régler mais voici comment j'ai procédé:

 

alors tout d'abord j'ai créer ma clé usb avec ceci:

http://www.insanelymac.com/forum/topic/307003-clover-os-x-el-capitan-usb/

 

ensuite on boot dessus la clé avec les boot flags suivants:

 

slide=10 -v

smbios.plist d'un mac pro 3,1

inject Nvidia coché (pour ma part vu que j'ai une 9500GT)

déplacer les kexts intel dans un dossier intel_back pour éviter des erreurs de bluetooth par exemple

 

Booter avec -s. ensuite au prompt "root:" taper ces commandes:

mount -uw /
cd /System/Library/Extensions
mkdir intel_back
mv AppleIntelHD* AppleIntelF* intel_back/
touch ../Extensions
Reboot -v

 

on démarre donc partir de la clé crée précédemment et on installe El Capitan, après installation on redémarre sur la clé, arrivé sur le bureau j'installes clover (voir captures d'écran) (version 3280) mais la dernière convient aussi

 

et enfin les kexts à installer dans le pack que j'ai refait

 

concernant le DSDT j'ai prit celui de yosemite d'un ancien post sur yosemite

 

 

ce qui bug:

 

les usb un peu lent (j'ai supprimé le kext AppleHPET.kext ça n'a rien changé je trouves)

parfois les périphériques en usb disparaissent comme ça je suis obligéde redémarrer le finder (sans doute à cause du kext supprimé précédemment)

et bien sur ce qui ne fonctionne pas le wifi 8187 qui je penses ne pourra jamais être résolu à moins de recréer le kext compatible pour El Capitan

Par contre d'après le forum en anglais on m'a dit que les kexts ne sont pas conseillé à installer dans S/L/E sous El Capitan ça fonctionne pour moi je ne comprends pas pourquoi ils disent ça, à confirmer merci

 

ps: Hervé je ne sais pas pourquoi mais ton DSDT modifié boot bien mon El Capitan jusqu'à la fin mais avant d'arriver sur le bureau écran noir, je ne comprends pas...bref donc un peu d'aide pour finaliser tout ça ne sera pas de refus.

ps2: mise à jour vers 10.11.1 en cours...

 

2 applis bien pratique pour El Capitan:

 

http://www.insanelymac.com/forum/files/file/432-insanelyrepairpermission/

 

http://www.insanelymac.com/forum/files/file/397-easykext-utility-for-el-capitan-kext-installer/

 

et enfin l'utilitaire de disque yosemite sous El capitan (que je trouves beaucoup mieux que celui d'El Capitan)

http://www.insanelymac.com/forum/files/file/480-disk-utility-patched-v2/

post-24099-0-92048000-1447217607_thumb.jpg

post-24099-0-54359200-1447217617_thumb.jpg

post-24099-0-47241400-1447217624_thumb.jpg

post-24099-0-31157000-1447218219_thumb.jpg

post-24099-0-78014600-1447218231_thumb.jpg

post-24099-0-22464700-1447218242_thumb.jpg

post-24099-0-29549200-1447218253_thumb.jpg

P5WDH_Deluxe El Capitan.zip

post-24099-0-46837700-1447218865_thumb.jpg

Share this post


Link to post
Share on other sites
Advertisement

alors pour le SIP c'est réglé maintenant c'est le boot je ne peux pas booter sans l'option nv_disable=1 et donc je n'ai pas le pilote de ma carte graphique activée comment faire?

Share this post


Link to post
Share on other sites

Ca devrait pouvoir marcher nativement après un patch DSDT pour injecter les caractéristiques. Il nous faudrait une copie de la DSDT + un IOReg.

Share this post


Link to post
Share on other sites

Salut à tous j'ai toujours c'est bonne vieille carte mère qui fonctionne don je me suis lancé dans une install EL capitan alors avec chameleon j'ai beau essayer j'avais des erreurs impossible à résoudre j'en pouvais plus alors j'ai testé avec clover et ça fonctionne nickel je suis sous El Capitan maintenant mais mon problème c'est que j'ai beau installer les kexts sans succes ils sont bien les dans les extensions mais ça ne fonctionne pas, je me suis rendu compte qu'il y a le fameux SIP à désactiver mais comment faire je découvres à peine cette protection merci d'avance pour votre aide.

Bonne nouvelle ! :)

est ce que tu peut poster ton config.plist et la liste des kext?

merci par avance

Share this post


Link to post
Share on other sites

@Hervé par contre je ne sais pas du tout comment faire un DSDT et un Ioreg tous mes hackintosh que j'ai fait j'en ai jamais fait avec DSDT désolé....

@aliab j'ai prit le pack de kext qui était pour yosemite dans la catégorie yosemite du forum français quelqu'un avait posté un tuto pour yosemite je posterais ma config.plist lorsque j'aurai un moment.

@nyu1985 je vais tester ça merci

Share this post


Link to post
Share on other sites

Pour extraire ta DSDT, tu télécharges le dernier MacIASL ou DSDTEditor et tu extraies ta table du BIOS. Chameleon Wizard le fait aussi.

 

Pour ton IOReg, tu télécharges IORegistryExplorer et tu sauvegardes la sortie dans un fichier. 

Share this post


Link to post
Share on other sites

Ok, ta carte nVidia se retrouve donc en GFX0 sous le device P0P1@1 dans ton IOReg. Par contre, il n'y a évidemment aucune injection à cet endroit dans la DSDT. On va donc essayer le patch suivant sous le Device (P0P1) situé à l'adresse 0x00010000:

               Device (GFX0)
               {
                    Name (_ADR, Zero)
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package (0x16)
                        {
                            "AAPL,slot-name", 
                            "PCI Slot0", 
                            "@0,compatible", 
                            Buffer (0x0B)
                            {
                                "NVDA,NVMac"
                            }, 
                            "@0,device_type", 
                            Buffer (0x08)
                            {
                                "display"
                            }, 
                            "@0,name", 
                            Buffer (0x0F)
                            {
                                "NVDA,Display-A"
                            }, 
                            "@1,compatible", 
                            Buffer (0x0B)
                            {
                                "NVDA,NVMac"
                            }, 
                            "@1,device_type", 
                            Buffer (0x08)
                            {
                                "display"
                            }, 
                            "@1,name", 
                            Buffer (0x0F)
                            {
                                "NVDA,Display-B"
                            }, 
                            "NVCAP", 
                            Buffer (0x14)
                            {
                                /* 0000 */    0x05, 0x00, 0x00, 0x00, 0x00, 0x00, 0xFF, 0xFF, 
                                /* 0008 */    0xFF, 0xFF, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0A, 
                                /* 0010 */    0x00, 0x00, 0x00, 0x00
                            }, 
                            "device_type", 
                            Buffer (0x0C)
                            {
                                "NVDA,Parent"
                            }, 
                            "model", 
                            Buffer (0x17)
                            {
                                "nVidia GeForce 9500 GT"
                            }, 
                            "hda-gfx", 
                            Buffer (0x0A)
                            {
                                "onboard-1"
                            }
                        }, Local0)
                    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                    Return (Local0)
                    }
                }
Essaie un redémarrage avec cette DSDT patchée...

Share this post


Link to post
Share on other sites

non justement j'ai un écran noir avec le DSDT

 

mise à jour en 10.11.2 juste à réinstaller les kexts audio et ça fonctionne.

 

Par contre depuis cette mise à jour Xtrafinder me dis que le SIP est actif alors que j'ai rien touché à ma config clover qui est toujours en CsrActiveConfig 0x67 bizarre.....

Share this post


Link to post
Share on other sites

Mais encore? En principe, dès l'instant que le CPU dispose des instructions SSE4, si ça marche pour EC, ça doit aussi marcher pour Sierra. Par contre, le SMBIOS MacPro3,1 c'est no-go pour Sierra.

Share this post


Link to post
Share on other sites

Salut

 

Il y a un bail que je ne pas fait fonctionné cette P5DWDH, j'ai l'impression qu'il y a encore des possibilités

est ce que l'un d'entre vous a une config.plist qui va bien pour faire fonctionner la P5WDH avec Clover ?

 

merci d'avance 

:)

Share this post


Link to post
Share on other sites

Un peu pareil, j'ai deux machines avec p5w-dh, faut que je m'y repenche pour y mettre une el-capitan... Après quelques années, j'ai l'impression qu'on a été vers de moins en moins de simplicité alors qu'on faisait ça tranquille y a 5 ans...

Share this post


Link to post
Share on other sites

On est jamais mieux servi que par soi-même 

bref! voici l'installation d'El Capitan (testée également sur Yosemite et Mavericks) que j'ai faite sous Clover avec tout qui fonctionne et même la mise en veille automatique, ce qui n'était pas le cas auparavant!

le boot est un peu lent mais c'est l'installation la plus simple et le système le plus rapide que j'ai eu réalisé avec cette carte :)

(5000 avec un Quad a 2,4 Ghz sous GeekBench 4)

 

Installation ;

 

Clover_v2 

post-92099-0-80019800-1485527866_thumb.png

 

Puis ajouter dans le dossier CLOVER/kexts/10.11 ;

 

FakeSMC.Kext (J'ai mis la dernière version publiée : 6.16.1372)

AHCI_3rdParty_SATA.kext ou équivalent

 

et config.plist dans le dossier CLOVER;

 

enfin, applehda-patcher 1.7 by Mirone pour l'Audio

 

 

(surtout ne pas mettre DSDT.aml dans ACPI/patched pour éviter un conflit avec les options de Clover)

 

 

 

Salut et longue vie a tous 

config.plist.AsusP5WDH.zip

Share this post


Link to post
Share on other sites

bon j'ai l'intention de mettre sierra voir high sierra plus tard alors voila si je changes mon cpu il me faut prendre un Wolfdale c'est bien ça? et donc qui ont des instructions SSE4

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×