Jump to content

Can't install Windows with bootcamp & Fusion Drive


5 posts in this topic

Recommended Posts

Hi, I am trying to install Windows 10 on my mac using bootcamp. Everything goes fine until I have to select the drive to install it on.


Here is what I did step by step.


1. Downloaded Windows 10.iso

2. Run bootcamp assistant to create Bootcamp partition and install USB

3. Boot into windows 10 installer.

4. At this point I have to select the drive to install it on, there are seveal different partitions even though in disk utility I only see one. I select the BOOTCAMP partition and format is to NFTS. When I click next I get an error saying. "We couldn't create a new parition or locate an existing one." Out of the many paritions there one in particular seemed like it wasnt needed. It was abotu 600mb so I formated it and clicked next.

5. The installiation begins but Copying files stays on 0% then I get an error saying we could not prepare the computer for the next phase of the installation. At this point the Mac restarts into Mac OS X.


The worst part is everytime I try it messes up the partitioning of the Fusion drive so I have to boot into Internet Recovery. Use terminal to split the fusion drive then refuse it, and lastly reinstall the OS and transfer all my files back. I do not believe that this is a Windows 10 installer issue but a Bootcamp + Fusion Drive issue. I have seen tons of Youtube videos of people installing windows 10 on bootcamp with no problem.


Can anyone help me out with this? I'm going to refrain from puting any of my data back on the Mac until I can get the Windows part working right.

Update: I've enabled show all partitions in Disk Utility and found out that the 650mb partition I deleted is actually the OS X Recovery HD. I've attached a picture of my drives BEFORE the bootcamp process. What I believe the problem is, is that there are too many partitions and windows can create am additional partition that it needs to store some files. I don't know what partitions I can delete to make room for one more but I've never had an issue like this before. 


Link to comment
Share on other sites

It is normal to have 2 EFI partition because you have 2 drives forming a logical volume group (fusion drive).


I have been having this formating issue for the past few days after wanting to clean install my Win8.1 before upgrading to Win10. Problem seems to be somewhere in the PRAM about a partition that is not memorized correctly. My original Win8.1 was working fine, I rebooted with my USB stick, install, format the current bootcamp partition and always had this same error message as you have. I have been spending days (literally) trying to fix the problem and tried many many things. In the end it was all pretty simple, of course.


These instruction assume you have:

- a working OSX installation

- your Fusion drive is only 1 partition in Disk Utility (not including the hidden partitions) (ie: not split up, if it is already split this will not work)

- you have no other USB device connected other than keyboard/mouse/USB stick with Windows installer


1) Reboot and do a PRAM reset (when you hear the startup chime hold cmd-option-p-r until you hear the chime again -- warning: 2nd chime volume will be blasting loud).


2) Open up Bootcamp assistant and create your bootcamp partition and install like you would normally. Your computer will reboot and proceed with the Windows installer. When you need to select your install partition just select the one called Bootcamp, hit format, the window will refresh, reselect the same partition (should be disk1s4 if I remeber correctly). The formated partition will now allow you to continue your Windows install


The key is the PRAM reset when the drive is only 1 partition in order to clear previous entries that were preventing you to install correctly. If you do that when it is split into multiple partitions it will not do anything and the same error will keep popping.


Also, when you want to remove your bootcamp partition, you dont need to boot into recovery and terminal, you can just go back to OSX, run bootcamp assistant and select "remove windows installation" and it will resize your osx partition to the full fusion drive size.


I have tested this numerous time since saturday and everytime it worked. Between wednesday and saturday, you don't want to know how many 10s of times I have tried installing and getting that error message :)


I only signed up to reply and hope that this info can help others having the same issue that was very very [...] very frustrating for me this weekend

Link to comment
Share on other sites

  • 8 months later...

Hi Guys


Thanks so much for these posts. It's saved me so much time and frustration..! :thumbsup_anim:


I ran into the same issues with a 5K iMac Retina with 3TB Fusion drive trying to install Windows 10. I first was unable to create a Windows USB install disk through Boot Camp Assistant (failed on downloading the Apple Support Software).  Eventually found the Boot Camp drivers here and had to use a Windows 8.1 machine to create USB install disk with Rufus and then copy the drivers/folders to the USB stick afterwards.


When formatting the Boot Camp disk in the Windows installation screen to NTFS I first got the message "Windows cannot be installed to this disk. The selected disk is of the GPT partition style." I then found out that when reformatting the Boot Camp to an exFat format I might progress further but then got the error as described by mpalomba3. As I had already had run the Boot Camp Assistant creating a partition, I had to do the following before achieving a successful Windows 10 installation:


1. Remove Boot Camp partition with Boot Camp Assistant

2. Reboot and do a PRAM reset

3. Create a new Boot Camp partition with Boot Camp Assistant and let Boot Camp initiate the Windows 10 and Boot Camp Software install in Windows 10

4. Update the Boot Camp Software to the latest - this resolved an AMD Radeon R9 M290X 2048 MB Graphics Card issue where Windows wasn't using the highest screen resolution




Link to comment
Share on other sites


  • Create New...