Jump to content
Sign in to follow this  
Followers 0
Panda Stirling

SNB Framebuffer did not show up - HD 3000

6 posts in this topic

Recommended Posts

Bonjour,

Je viens d'avoir un ordinateur portable Acer Aspire V3-771G.

Quand je démarre après avoir installer OS X 10.8.5, le démarrage reste bloqué sur SNB Framebuffer did not show up.

J'ai déscativé le UEFI (j'ai régler le mode en Legacy BIOS).

Voila les specs:

CPU: Intel Core i3-2348M (2.3GHz,3MB L3 cache)

GPU: NVIDIA GeForce 710M 1GB & Intel HD 3000 2GB (j'utilise la HD 3000 pour OS X)

RAM: 6Go DDR3

HDD: 500GB

Partition: 400Mb (Parition Récupération) 300MB (Partition du système EFI) 350GB (Windows 8.1) 100GB (OS X) 450mb (Partition de récupération) 17GB (partition de récupération)

Je crois que c'est du GUID.

Donc, comment pui-je utiliser OS X sur mon laptop ? 

On m'as dit (sur ce forum) que je ne pouvais pas utiliser la 710M sur OS X, alors j'ai régler la video sur la HD 3000.

Merci.

Share this post


Link to post
Share on other sites
Advertisement

Comment as-tu fait pour "régler la video sur la HD 3000"? Par un patch DSDT qui passe la carte nVidia en Off? Pour l'Intel HD 3000, d'habitude ça fonctionne OOB sauf peut-être l'écran qui peut nécessiter un patch DSDT pour support de la résolution.

 

Assure-toi que la virtualisation est désactivée dans le BIOS ou, si tu démarres avec Chameleon, utilise l'option dart=0.

Share this post


Link to post
Share on other sites

Y'as une option dans le UEFI. Integrated (HD 3000) ou dedicated (710M), j'ai choisie integrated. EDIT: Au final, non, y'a pas d'option x(

Sinon, je vais essayer de faire une clé Mavericks, vais devoir passer par VMWare, vu que mon hackintosh est mort >...< (black screen après le boot, arrivé après la réinstallation de Chimera avec ##### x'(

Share this post


Link to post
Share on other sites

C'est bien ça de pouvoir choisir son GPU dans le BIOS. Ca veut également dire qu'il y a une chance que le GPU nVidia soit en fait bien supporté par OS X; ça te bouffera juste plus vite ta batterie. Essaie la bascule de GPU puis un reboot de ton système pour voir. Si tu utilises Chameleon, bootes avec les flags -f -v.

Share this post


Link to post
Share on other sites

hello

comme le dit Hervé , vu ta resolution , il te faut un patch DSDT pour ta HD3000 (repo laptop rehab avec maciasl)

essayes aussi de supprimer (backup of course) tous les kexts nvidia du repertoire Extension

tu utilise finalement quoi comme bootloader ?

tu me diras par la suite avec 6Go de ram , combien osx attribut de ram a ta HD3000 !

Share this post


Link to post
Share on other sites

En possible alternative au patch DSDT pour ta résolution écran, tu peux tenter de démarrer avec l'option Chameleon EnableDualLink=Yes (et/ou EnableBackLight=Yes).

 

En terme de patch DSDT, tu auras besoin d'un code dans le genre suivant, à insérer dans le Device (XXXX) (idéalement Device (IGPU)) répertorié à l'adresse 0x00020000:

           Method (_DSM, 4, NotSerialized)
           {
               Store (Package (0x0A)
               {
                   "AAPL00,DualLink", 
                   Buffer (0x04)
                   {
                        0x01, 0x00, 0x00, 0x00
                   }, 
                   "device-id", 
                   Buffer (0x04)
                   {
                        0x26, 0x01, 0x00, 0x00
                   }, 
                   "model", 
                   Buffer (0x17)
                   {
                       "Intel HD Graphics 3000"
                   }, 
                   "AAPL,snb-platform-id", 
                   Buffer (0x04)
                   {
                        0x00, 0x00, 0x01, 0x00
                   }, 
                   "hda-gfx", 
                   Buffer (0x0A)
                   {
                       "onboard-1"
                   }
               }, Local0)
               DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
               Return (Local0)
           }

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×