Jump to content

Plus de son depuis Yosemite


Go to solution Solved by Bassclik,
16 posts in this topic

Recommended Posts

Bonjour à tous,

 

Je suis passé sous Yosemite 10.10.1, après être resté un certain temps sous Maverick (Niresh).

Tout fonctionne très bien à part le son.

Honnetement, je ne sais même pas par ou commencer, tout fonctionnait avant, mais plus maintenant...

 

Pour résumer, j'ai déjà tester beaucoup de VoodooHDA kext mais soit il ne détecte aucune sortie, soit il me met un message d'erreur.

 

Pour info, je tourne sur un HP m9355.fr, avec une carte graphique GeForce 210, 4GB de RAM et une carte audio de type ALC888S.

 

Si quelqu'un avait des infos, ce serait super.

 

Merci et bonne soirée (nuit ?) à tous.

salut

tu peux te servir du kext de maverick et ensuite patcher ton applehda avec un des script dont on parle sur ce site

sinon pour voodoo si tu l'utilise , perso je ne sais pas

quelle est la ref exacte de ton audio car j'ai un acer avec alc888s qui fonctionne tres bien avec un applehda patché

clover ou chameleon ?

Oula, ca va vite !

 

Alors, @gils83: Je ne connais pas kext-dev-mode=1, désolé ...

 

@ legot: le soucis, c'est que je ne sais pas ce qui était utilisé sur maverick, tout fonctionnait donc je n'ai jamais été voir.

 

@Hervé: je vais essayer, j'en ai tellement essayé que je ne sais plus si j'ai fais celui ci !

kext-dev-mode=1 est une option bootloader permettant de charger des kexts non signés. C'est indispensable pour tout ce que tu vas rajouter de non vanille à Yosemite.

 

Tu vois peut-être maintenant l'utilité de faire soit même des installations vanille propres dans lesquelles tu maitrises les rajouts (par ex les kexts pour le matériel spécifique) plutôt que des distros qui marchent façon Inch'Allah...

D'accord, merci pour l'info, je ne connaissais vraiment pas. 

Après, en toute honnêteté, je n'ai pas les connaissances requises pour créer mes propres installations et j'avoue que l'utilisation d'une bistro m'arrange bien, quitte à bidouiller derrière (même si, en ce moment, je galère un peu pour ce son !!! ).

bon alors si tu veux utiliser applhda.kext il faut le codec dump de ton audio (linux dristrib en live) et après on trouvera le bon kext patché

car voodoo ne marche pas du tout bien sur mon alc888s sur mon acer 7736zg et je préfère utiliser applehda

Alors, j'ai avancé un peu (je crois).

J'ai utilisé Ubuntu pour trouver l'ID de ma carte son: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 02)

J'ai ré-installer VoodooHDA 2.7.2 (le seul qui n'affichait pas "no Voodoo device detected) et j'ai changer l'info plist avec l'ID de ma carte.

 

J'ai maintenant ce message d'erreur: "Can't get registry-entry path" 

 

Ce pourrait-il que cela vienne de la version de voodoohdaprefpanel ?

Si oui, comment revenir à une version compatible Voodoo 2.7.2 ?

 

Merci encore

 

PS: Je vais tenter AppleHDA en attendant !

  • Solution

Et bien c'est enfin bon !!!

Pour ceux que ca intéresse, je suis passer par ici: http://www.hackintoshosx.com/files/file/1431-applehda-alc888s-v2/

C'est un AppleHDA (donc finalement, legot28 avait raison !) et ca fonctionne juste très bien !

 

Quelqu'un pourrait-il passer le topic en résolu ?

J'ai posté un lien mais si celui ci enfrain une règle, je le supprimerais et je reste dispo par message pour ceux qui aurait un soucis avec le même problème.

 

Merci !

hello

tu auras donc certainement de eapdfix.kext ou codeccommander.kext pour avoir l'audio apres la veille

as tu testé la hdmi audio car non fonctionnelle chez moi avec ma G210 512Mo (video ok)

Alors, j'ai tester la cdmi mais elle ne fonctionne pas. J'ai G210 1GB pour ma part (ok également), 4 sortie HDMI dont une qui fonctionne 1 seconde puis se coupe.

Ce n'est pas un handicap pour l'instant.

Concernant la veille, je l'ai désactiver puisque tout plante au réveil...

merci, cela confirme encore un peu plus mes recherches sur la hdmi audio avec cette série de carte

concernant le sleep and wake , c'est a mon avis ce qu'il y'a de plus complexe a obtenir

bonne continuation

  • 4 weeks later...

Bonjour,

 

Je ré-ouvre le sujet puisque...j'ai eu la bonne idée de déplacer mon "pc" sur un nouvel écran.

Depuis, plus de son..

C'est à n'y rien comprendre. J'ai réinstaller mon AppleHDA qui allait bien mais rien... Aucun périphérique de sortie (ni d'entrée d'ailleurs).

Si quelqu'un a déjà eu le soucis, je suis preneur d'une solution.

 

Merci

×
×
  • Create New...