Jump to content

Dell D830 Crestline Graphics post installation problem (OS 10.7.2)


1 post in this topic

Recommended Posts

Hi.  First of all new user here, so hello.


On to the point.


So I got myself dell d830 with crestline graphics(can support resolution of up to 1920 x 1200).  I have tried installing many versions of mac on it, but decided to stick with OS X 10.7.2.  Now I tried mountain lion 10.8.5(using this method http://forum.osxlatitude.com/index.php?/topic/2468-dell-latitude-d830-intel-gma-x3100-ml-with-full-qeci/) and it was working graphic wise, However it had problems with shutting down and I didn't have battery or sound support and when I ran EDP on it, it would stop booting.  So I decided to go with 10.7.2 instead since EDP supports it. 


Now with 10.7.2 Everything works beautifuly except for graphics.  I am stuck with the 1024x768 resolution.  I have used the OSXLatitude's d830Low res, and d830 high res bootpacks when installing but that doesn't seem to work.  I tried running the system in 32 bit mode using (arch=i386 flag) but it always gets stuck at "resetting iocatalogue"


I have included a DSDT file I extracted from my laptop.  If anyone can help me with this problem I would be really grateful.  I have been trying to get the laptop fully functional for almost 2 weeks now, in the end, I am unable to do so.


BTW, I should mention that I am using A17(the latest) bios version on the D830. So maybe thats why I am having problems with EDP bootpacks.

dsdt d830.zip

Link to comment
Share on other sites


  • Create New...