Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Problem with HD4400 on higher resolutions

3 posts in this topic

Recommended Posts



first of all I'd like to thank you for your support, which helped me setting up my Sony Hackintosh.


But I still have some Problems with Graphics.

I have a Sony Vaio Fit Notebook with a 2880x1620 Resolution.

It has a Intel 4500U Processor with a HD4400.

I get full qe/qi, but only on Resolution lower than 1920x1080.

When I set the native Resolution the screen flickers, the strangest is, as long as I move a Window (for example a Finder Window) the flickering is gone. When I stop moving around it starts flickering again.


The Resolution I use now is 1440x810. On that Resolution everything works correct.

When I set the Resolution to 1920x1080 I get a weird Menubar.  The Screenshot I attached shows this.


I have also tried debugging my dsdt/ssdt, but I have figured out that only a few Methods are called.


P.S I found a little touch support for my N-Trig Touchscreen in 10.10


Any help or hint is appreciated



Share this post

Link to post
Share on other sites

I have the same problem but in 10.9.4 (latest beta) only, i did not know where is the problem comes from

i installed intelFrameBufferAzul from 10.9.3 but did not work.

I wonder who can  this issue and solves it will be a super expert user.

As soon as i got a solution i will upload the file/s (if any needed) and will write down how to.

Share this post

Link to post
Share on other sites

same here after update to 10.9.3 and 10.9.4. Issue was from Use AppleIntelFramebufferAzul. On 10.9.3, I can use the kext from 10.9.2 and issue resolved. but on 10.9.4 using same kext also gone but i lost my QE/CI

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MetalBreaker
      I noticed some weird behavior with macOS High Sierra. This system was working just fine on Sierra 10.12.5, until I decided to update to High Sierra (10.13.3). The upgrade process went mostly fine I guess, but it got stuck in an infinite spinning wheel which would just keep overlapping. I went into verbose mode, and sure enough, I found "IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0" repeating over and over along with ACM errors... I'm really lost right now. I can boot in recovery mode and safe mode just fine, when the graphics drivers aren't loaded. Web drivers aren't installed. I installed NvidiaGraphicsFixup, but it didn't fix the issue. I tried deleting the native graphics drivers from macOS and installing web drivers, but it didn't help.
      SMBIOS: iMac13,1
      Graphics card: ASUS GT630-2GD3 (It's a Fermi card and it needs injection, so I modified my DSDT. Full graphics acceleration worked in Sierra. No Clover injection. I tried using Clover injection instead, I saw no difference.)
      CPU: Intel Core i3-3210, iGPU disabled in UEFI

      All kexts updated to their latest versions, along with Clover.

      For more info, you can refer to the GitHub issue where I posted it. https://github.com/lvs1974/NvidiaGraphicsFixup/issues/3
      Any help would be appreciated.
      Thank you for your time!
    • By safar
      Hi   Clover limits the number of gpus to 4 :   from Clover source code : rEFIt_UEFI/Platform/Settings.c :   GFX_PROPERTIES                  gGraphics[4]; //no more then 4 graphics cards   Anybody knows why?   This number is limiting for me : - 1x gpu is AMD display GPU - 1x gpu is Supermicro's built-in vga IKVM output (Matrox 0x532102B)  
      - 3x gpus Nvidia for Cuda   I At present, I have to take off one Nvidia (but I'm trying to disable the build-in vga IKVM output through software, so that it's available for other operating systems : I'll make another post on that topic, to keep things clean)
    • By 16BitHusky
       am running sierra on a optiplex 780 with a pny gt 710. I followed a step by step guide here. My machine boots fine and actually shows that the pny 710 is recognized I have attached a link with proof. My issue is when I am doing anything that relates to video it artifacts and slows alot. I understand that this is a cheap graphics card but from what I read online it seems like the other hackintoshes dont have this issue with this card. I am wondering if you have had any similar problems or solutions to this. I  also have attached my config file. I asked around on reddit and they said this could be related to the qe/ci. I am pretty new at this so I don't know how to enable this. I have installed the web drivers for 10.12.6 and that hasnt changed anything. 
    • By deejaystage
      Hi guys!
      I have not acceleration in my IGPU graphic card, the system says: 7mb vram and everything goes very slowly, neither can to change resolution. I used lilu.kext and inteligraphicsfixup.kext but nothing happens. I tried a lot of things but nothing changes. Tried changing my Fake ID Intel: 0x59128086 and Inject Intel ig-platform: 0x59120000 but nothing happens. I`ve got this issue from 20 days ago and I don´t find the solution.
      My specs:
      Asus H110M-D mobo
      i3 7100 Kaby Lake
      Intel HD 630 IGPU
      4gb ddr4 ram
      500GB HDD WD
      High Sierra 10.13 OSX
      Any suggestion will be very appreciated!!
      Thanks in advance