Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
prytoluk

iATKOS L2 - Lenovo Ideapad S10 - Unsupported 32-bit-only CPU

2 posts in this topic

Recommended Posts

Dear friends:

I'm having some troubles in the past few days, trying to repair/fresh install (either is fine) a Hakintosh Installation.

I got the PC with not much info, aside from the PC model itself (Lenovo Ideapad S10) and a osx install boot problem i wasn't able to fix, so i gave up and prepaired for a reinstall.

The PC is definetely OSX 10.7 capable, i've seen many infos on it. That's it's resumed hardware specs:

Processor type Intel Atom N270
Primary Graphics Chipset Intel GMA 950


I've tried this guide: http://www.insanelymac.com/forum/topic/288795-guide-creating-os-x-usb-installer-using-a-windows-pc-only/ ; and i've been able to boot the bootloader fine, by pressing "3" at boot time (x32 version of clover), but as soon as i load the iATKOS installer, that's what i got:

"efiboot loaded from device:Acpi (PNP0A03,0)/Pci (1F|1)/Ata(Secondary,Master))/CDROM(Entry0)
boot file path: \System\Library\CoreServices\boot.efi

*********************************************
This version of Mac OS X is not supported on this platform!
*********************************************
Reason: Unsupported 32-bit-only CPU"

I've tried "mach_atom" and "arch=1386" as boot flags on the Clover bootloader, with no luck.

Any ideas?

There is also this guide: http://www.insanelymac.com/forum/topic/258491-guide-lion-dp1-on-ideapad-s10e/ it talks about some of the necessary KEXT's for the install. But i can't make use of it.

Thanks for the help!

Share this post


Link to post
Share on other sites

Ok... I found a solution to my problem.

Though you might be able to install Lion directly to your Lenovo Ideapad S10, as i mentioned above, i wasn't able to bypass the x86-only verification (it seems you can force it somehow...).
If you are at the same stage as me, you should try the following tutorial:

http://computersoftwareisyourfriend.blogspot.com.br/2011/09/preparing-your-installers-for-mac-os-x.html

Use IatkosS3v2 instead of lion, that's the key to sucess.

Select the 32bit packages you find on "customize" menu, select atom kernel, the Intel GMA 950 video driver, broadcom wifi driver, apple ps2 controller... (i'll try to add more precise infos later on)

After you managed to install Snow Leopard, you could try to install Lion using the following:
http://www.insanelymac.com/forum/topic/258491-guide-lion-dp1-on-ideapad-s10e/

Good luck for you all!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×