Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Samsung Serie 5 Intel HD 4000 (NP530U3C)

15 posts in this topic

Recommended Posts

Hello all ! 


I'm new in the hackintosh community, and I read a lot about it. I successful installed ML 10.8.3 on my Samsung NP530U3C, but I'm stuck at the problem that the Intel HD 4000 video card is still not recognized. 

In System panel I just have "64Mo System Memory Monitor" (I'm not sure of the translation, in french this is "Moniteur 64Mo de mémoire système") 


I've tried a lot of solutions to enable the video card, dsdt edit, kext install or edit the original driver, etc... 


Now I install the original Intel HD Mac Driver to restart from the beginning. 


Here is my full laptop configuration : 


Samsung NP530U3C-A01FR

Proc : Intel Core i5 3317U @1700Mhz (Max :2600) Ivy Bridge 
Motherboard : SAMSUNG ELECTRONICS CO., LTD. SAMSUNG_NP1234567890 FAB1 (Serial version : 123490EN400015) (BIOS : Phoenix Technologies Ltd. Ver. P14AAJ) 
Chipset : Intel HM76 (Panther Point) 
Graphics : Intel® HD Graphics 4000 (Monitor : Seiko Epson @1366x768 px (32bits)) 
RAM : 6Go (2Go+4Go) DDR3-SDRAM @800Mhz Dual-Channel 
Hard drive : 
• SSD SanDisk i100 24GB SATA III
• HDD HGST HTS545050A7E380 de 500Go SATA II
Network : TrendNet PEW-648UB 

Audio : Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (RealTek ALC269)
Battery : TBD by ODM, Intel Corp. Lithium Ion Smart Battery 
Touchpad : ELAN Technologies


I've installed VoodooHDA 2.8.2 for the audio, the Realtek Driver for the wifi, and Elan Driver for the touchdpad. 


Less important, but I have a problem with sleep mode too. When I want to go in sleep mode I just have a white screen... I tried SleepEnabler.kext but it gets me to a kernel panic. 


Thank you for your time and I hope you could help me get my HD 4000 working. If you need more information, just ask me. 




Edit : One more thing, I would maybe upgrade for a 256Go SSD (remove the 500Go HDD) and add more RAM, could you give me some advice for that ? And could I clone my partitions on the SSD ? Because I have three partitions, 2 for windows 8.1 and one for ML 10.8.3 (300Go for Windows and 80Go for Mac : more than the SSD capacity) 

Share this post

Link to post
Share on other sites

No one could help me a little bit ? 

I've tried DSDT patching, installing modified kext, injection in chameleon... But nothing works, I really don't know how to fix that... I've noticed that on the boot screen I can see 63Mb VGA Graphic controller, not 64Mb like in Mac. I cannot modify the value in the BIOS (my bios is not able to modify between 64, 92, etc... Like we could see in some tutorials) 

And for the dsdt patching, I don't know if iI made it in a good way, because I don't really understand everything and in the tutorials. It's a little bit blurred for me sometimes. 


Edit: I reinstalled OSx, to have a clean install, so I just installed the wifi usb stick, voodoohda, ethernet controller, trackpad. I've removed all graphics kext for the moment (except AppleIntelFramebufferCapri.kext, AppleIntelIVBVA.bundle, AppleIntelSNBGraphicsFB.kext, AppleIntelSNBVA.bundle) and take an smbios.plist from chameleon wizard (Mac Mini 6,2 : I've tried MacBook Air 5,2 too which have nearly the same configuration as my computer but none of them worked) 


Here is my org.chameleon.Boot.plist : 



<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Graphics Mode</key>
<key>Legacy Logo</key>
And I don't use DSDT file for the moment. (with this configuration my hackintosh works great and hd4000 is the only problem, the screen works, with the good graphic mode (1366x768x32) but I have glitches on safari (not google chrome), when I switch wallpaper, on the dock animations, on the notification bar, etc... And the YouTube videos in Chrome are lagging when I play them in full screen.)
Thanks for your help, 

Share this post

Link to post
Share on other sites

Thank you but I already try this solution and it doesn't work... But I notice (with kextstat) that even if I put the HD4000 kext in S/L/E, this is AppleIntelSNBGraphicsFB.kext which is loaded.

Share this post

Link to post
Share on other sites

Delete the strings:





Try IntelCapriFB=3 or 4

Share this post

Link to post
Share on other sites

If I disable PCIRootUID I have a black screen after the apple on boot. And HDA Enabler is for the audio if I'm right, no ? But I've tried and it doesn't work anymore.  :(

Share this post

Link to post
Share on other sites

Ok, enable PCIRootUID=1, but hdaenabler is for AppleHDA, not for VoodooHDA.

If you use SkipIntelGfx=Yes the system not load the HD4000 kexts

Share this post

Link to post
Share on other sites

Ok thank you but I already tried these parameters and it doesn't work anymore. But I have deleted the HD 4000 kext in s/l/e, I have only apple graphics snb now (if I put the HD 4000 kext it doesn't boot)

Share this post

Link to post
Share on other sites

The kext IntelHD and IntelFramebuffer are needed to recognize the graphics card.

Install the kexts, you just have to find the exact boot flag:
IntelCapriFB = a value between 0 and 11, one at a time to try

Share this post

Link to post
Share on other sites

I've some boot error with the one I tried. Which kext do I have to keep here ? (check kext.tiff in attached files, these are all the original apple kext I saved in a folder) 



Share this post

Link to post
Share on other sites



I've now installed Mavericks 10.9.3 with the AppStore installer (make an USB bootable stick to have clean install)

I have still problems with hd4000 graphics. Informations about the mac show "4mb monitor" now and I've tried all intelcaprifb boot flags (0 to 12) and no one worked for me. (I have installed latest version of chameleon v2.2svn-r2286)


Here is my org.chameleon.Boot.plist




Gaphics Mode=1366x768x32







IntelCapriFB=tried 0 to 12


With this configuration I can only boot in safe mode (which not load intel hd graphics kexts). If I want to boot in normal mode I have to remove all intelhd....kext, this is the only solution for the moment (so this is the same problem as ml 10.8.3)


I use MacBook Air 5,2 smsbios (it has the same processor and gpu as me)


If you need more information, just tell me.


Thank you for your time.


Edit : When I boot in normal mode with the intelhd graphics kexts I am blocked at the end of the loading of mavericks, at the message about Bluetooth : "[iOBluetoothHCIController][protectedBluetoothHCIControllerTransportShowsUp] -- Connected to the transport successfully -- 0xe6c0 -- 0x0000 -- 0xb400". When I'm booting in safe mode I see a second message just before I get the login screen, still about Bluetooth :

[iOBluetoothController][staticBluetoothHCIControllerTransportShowsUp] -- Received Bluetooth Controller register service notification - 0xac00

[iOBluetoothHCIController][start] -- completed


I think I'm blocked here just because the graphics kexts are not loaded.


But if you want I want send you the full system.log


Edit 2 : just noticed that the message I see in safe mode comes before the message I see in normal mode, so this message is just hidden by the login screen in safe mode.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.